1.3: DSD files skipping when EQ is enabled

The topic name says it all - anyone else experiencing this behavior?

Other than that - a great release!
Thanks to the Roon team.

Please add more details. Can you reproduce an issue with any DSD content ? What are your EQ settings ? What is the playback device ? What are its settings ?

Yes with any DSD files.

EQ settings:

TotalDac server settings:

A pic of your signal path would be useful as well, I guess.

Also some detail about the specs of the machine hosting your Core.

I’m seeing this, too, but only when upsampling to DSD256 (DSD128 works OK). When I check out my signal path, it shows those files are only processing at 0.8x, which means eventually (i.e., within a few seconds) the buffer empties and the player skips to the next file.

Might be nice to temporarily wait to begin playback when buffering is needed to ensure playback without interruptions.

Did I not read some where that the dsp engine only works on pcm files and not dsd?
If so, to use the dsp engine, the dsd file must be converted to pcm, the dsp stuff gets applied and then the whole thing converted back to dsd.
The symptoms described above are typical of what I have found where the processor in the core machine isn’t up to the task of converting pcm to dsd.

Turn off the dsp engine and does the dsd file play properly?

It skips so fast that I cannot grab the signal path.

SonicTransporter i7.

With PCM files the EQ works, also with DSD files downsampled to PCM.
It’s a SonicTransporter i7 so it shouldn’t be too weak…

It skips from the beginning when I hit play, takes 2 seconds to skip a 12 title 90 minutes album. Hit pause is not possible as well.

I wouldn’t be so sure. I have an i7 4770 processor in a Linux core and it can only just cope with stereo pcm to dsd128, its happier with dsd64. With multichannel dsd64 is only just possible.

If your core is also still importing the library and audio analyzer is running that’s not going to help things either. I think it was posted that if your seeing less than 1.3x processing speed then you are not going to get good results.

Perhaps when multi core dsd upsampling is enabled this might not be such an issue, but for now you can only expect so much from certain machine specs

Thanks guys, but I’m not so sure.

The EQ just doesn’t work with DSD files. When I downsample DSD to PCM, what I understand as an additional load for the CPU, it works. I get a 7x speed with downsampling and EQ:

But I thought the hard work was done going the other way from pcm to dsd. That’s where I get processing speeds of between 2 and 0.3. Which to my mind explains the problem you are having.

I can upsample to DSD without any problem…

Hi @NOA – Thank you for the report, I’d like to get a look at some logs from this failure.

Can you zip up two folders of logs for me, and upload them to Dropbox (or similar)? You can just post the links in this thread.

The two folders I need are:

If you can zip those up and send me a Dropbox link, we’ll look into this. Alternatively, if you don’t have Dropbox, let us know and someone from @support will send you information about uploading the logs directly to us.

Thanks and sorry for the trouble here!

-Eric