1.3: Linux RoonServer doesn't seem to be seeing music files on a local disk [solved]


(Danny Dulai) #25

check your PM – i need more zfs lore… also, @mitch has / on zfs :frowning:


(Jeffrey Moore) #26

Oh, yeah. I have a 1.2 backup from last week.

Is this something the interface will allow once Roon sees the filesystem, or a global search-and-replace in some database files?


(Danny Dulai) #27

the db holds a “storage location id” and a path relative to that root – editing the storage location’s path will keep the id the same, but re-root it. in settings -> storage, do you not see your 1.2 storage locations? thats what i mean for you to “edit”


(Jeffrey Moore) #28

Everything under settings->storage for me is stuck in “Migrating from pre-v1.3” state while the filesystems remain invisible to RoonServer, and the only menu option for them is “Remove”. So presumably I’ll see the edit option once that changes.

I’ll be patient, and this is a completely non-essential thing for me to try - so I’ll try it later, if at all. I just thought I’d spring the question while file paths were being discussed.


(mitch) #29

I know I’m not a typical install and many shops would have already called me unsupported. I can move to a real vm with an ext4 / and let roonserver manage a cifs mount if I have to but I’d really just like to give you a simple path to watch. I’ll even edit a config file if you want to hide it from the UI.

Frankly I think managing my storage and physical devices is my job, not yours, but I do understand the problem you’re trying to solve and why you want to solve it yourself.


(Patrick Lang) #30

So any plans around the case where / doesn’t have a UUID? Are you enabling browsing under / to solve that problem? I see the later replies only talk about the local RAID devices.

I just thought of another idea. If you want a reliable marker for paths without a SCSI identifier, why not have a well-known file we can place there? ex: /music/roon.uuid . If you see that file, use it’s contents as the storage ID.


(Olivier Verberckmoes) #31

Something similar is happening with docker?
See Roon 1.3, docker, local folders [resolved]


(Patrick Lang) #32

Running in containers is one variation of this problem. It looks like the key cause is that Roon 1.3 looks for identifiers associated with a physical disk. These could be missing with many things that are mounted on Linux including SMB/NFS file shares, zfs & some raid paths, and the root filesystem on Linux.


#33

Running Roon 1.3 here on Ubuntu 16.04.1 LTS with music primarily on NFS shares (qnap) and some also on local disk - all seems fine (knock knock) and library is just now rebuilding…


(Danny Dulai) #34

fix coming in build later today. you will have to edit your storage locations, but it will work.

@maniac, unsure how you working or what will happen with new change… my guess is you will need to migrate your path somehow


(Danny Dulai) #35

(Jeffrey Moore) #36

Thanks for the quick turnaround, guys!

I’m running build 194 now, and not only can it see my filesystems - I don’t seem to need to do the edit-the-path trick. RoonServer build 194 seems to have been happy to just pick up and use use the audio-file paths inherited from v1.2.

Scanning now (and at quite a clip, what with being able to do all that stuff in parallel).


(Patrick Lang) #37

+1

I’m up and running on 194 and the collection was there instantly. I didn’t need to do any edits.

I think these are the logs that show it reconnecting the existing path.

02/03 05:27:35 Debug: [broker/filebrowser/volumeattached] initial listing found drive mounted at /music
02/03 05:27:35 Warn: [broker/filebrowser/volumeattached] skipping /music because it is not a /dev/sd[0-9]* (mountline: //press.coffee.local/MusicArchive /music cifs rw,relatime,vers=1.0,sec=ntlmssp,cache=strict,username=roon,domain=coffee,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.1.2,file_mode=0755,dir_mode=0755,nounix,mapposix,rsize=61440,wsize=16580,actimeo=1 0 0)
02/03 05:27:35 Info: [broker/locations] adding storage location: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb
02/03 05:27:35 Info: [broker/locations] media availability: Internet:Name=Internet Media:Id=e268f098-04c4-4e65-af3f-38ba3c3fcecb is online
02/03 05:27:35 Info: [broker/locations] adding storage location: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8
02/03 05:27:35 Info: [broker/locations] media availability: MetadataService:Name=Metadata Service:Id=13769258-b70b-4243-b1d6-bd46e8257ba8 is online
02/03 05:27:35 Info: [broker/locations] adding storage location: Offline:Name=Offline:Id=f1e4b43f-f643-47ba-b875-fd93b32a6006
02/03 05:27:36 Debug: [broker/locations/migration] start, propname: location_automounts
02/03 05:27:36 Debug: [broker/locations/migration] start, propname: location_directory_b35daad67a81f14f4145ebdd372971f0
02/03 05:27:36 Info: [broker/locations] migrating old-style watch directory config b35daad6-7a81-f14f-4145-ebdd372971f0
02/03 05:27:36 Debug: [broker/locations] load pre 1.3 automounts, strlist: 07a4d153d11411ce41eb27500f303dfb|b35daad67a81f14f4145ebdd372971f0
02/03 05:27:36 Info: [broker/locations/directorystoragelocation] initializing FileBrowser.Entry:  / : /music, drive availability is: True
02/03 05:27:36 Info: [broker/locations/directorystoragelocation] drive is available checking to referencing fs provider and setting up dirwatcher: FileBrowser.Entry:  / : /music
02/03 05:27:36 Debug: [broker/locations/directorystoragelocation] drive path lookup took 4ms: FileBrowser.Entry:  / : /music
02/03 05:27:36 Debug: [broker/locations/directorystoragelocation] dirwatcher init took 0ms: FileBrowser.Entry:  / : /music
02/03 05:27:36 Info: [broker/locations/directorystoragelocation] attaching backend: FileBrowser.Entry:  / : /music
02/03 05:27:36 Debug: [storage/directory] directorystorage init, location(/music, dirwatcher is available: True)
02/03 05:27:36 Debug: [storage/directory] init just before reorg delete thread, path: /music
02/03 05:27:36 Info: [broker/locations] storage location backend created and attached (Folder:Name=:Location=FileBrowser.Entry:  / : /music:Id=b35daad6-7a81-f14f-4145-ebdd372971f0)
02/03 05:27:36 Info: [broker/locations] created enabled location, FileBrowser.Entry:  / : /music
02/03 05:27:36 Info: [broker/locations] adding storage location: Folder:Name=:Location=FileBrowser.Entry:  / : /music:Id=b35daad6-7a81-f14f-4145-ebdd372971f0
02/03 05:27:36 Info: [broker/locations] media availability: Folder:Name=:Location=FileBrowser.Entry:  / : /music:Id=b35daad6-7a81-f14f-4145-ebdd372971f0 is online

Roon 1.3, docker, local folders [resolved]
Docker images for Roon
(Olivier Verberckmoes) #38

Great guys. Things are working as before.
Just for your info: I restored the 1.2 config and the 194 build did all this great work! :wink:
Awesome!


#39

this is strange just updated to R194 an now all my paths are in state “DriveNotReady” - with first 1.3 release all was working fine transparently.
i will have to look closer yet what’s going on here…


(JSE) #40

@maniac, check this out, it will probably solve your issue:


#41

@JSE thanks will checkt that out.

in the meantime i have just edited storage entries - in storage click EDIT on each entry and select the same path again and click SAVE - this immediately found the correct folder again, made a quick scan and all seems OK :slight_smile:


(JSE) #42

That is exactly what is described in the linked thread.
Happy you can enjoy your music again :slight_smile:

If I read correctly all others have solved it too.


(Patrick Lang) #43

@JSE yes, scroll up to post 37 :slight_smile:


(JSE) closed #44