1.7 ... No parametric EQ but parametric EQ (?) ... and harshness :( ... had to stop playing music

Core Machine (Operating system/System info/Roon build number)
Roon ROCK / NUC8i3 / Serial #1C697A03FBE1


I’ve updated Rock at 1.7 and … is it ok that with Parametric EQ disabled I have it sign as active in the signal flow?

but, MOST IMPORTANT, compared with release 1.6 I have now an harshness that previously was not there at all… with exactly the same configuration. I restarted everything and checked all option and connections and it is all unchanged… except the sound that now is quite fatiguing (mid-highs are now too bright, lost of bass frequencies… mids not smooth-sweets as before) (with the same volume level), I had to stop playing music as it really was quite unplesant :frowning:

pls help

(25.11.19 12:18 edit: sorry, I didn’t recognize this post was for Support section… added now all info about my system)

Hello @Paolo_C,

When “EQ Parametrico” is enabled inside of the “Procedural EQ”, it will show two elements in the Roon Signal Path:

When using EQ Parametrico in Roon, make sure that you use the gain slider on the right hand of the graph to bring the EQ line below 0dB across the entire frequency range. This will reduce the chance of digital clipping, a common source of “harshness” in the audio.


1 Like

Hello John,

thanks a lot for help, I will check/try and let you know…
thanks again


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.