1.8/831 has a bug in support of Benchmark DAC: DSF playback is broken [SOLVED. Not a bug]

Roon Core Machine

Rock 1 build 227 on Intel NUC10i7FNH (32 GB, 1 TB SSD)

Networking Gear & Setup Details

CAT6 wired eithernet.

Connected Audio Devices

Benchmark DAC3, direct USB to Rock

Number of Tracks in Library

irrelevant

Description of Issue

Summary: it appears the latest release broke DoP on benchmark DACs (at least)

I have many digital .dsf64 files files. Since installation months ago, roon has recognized my benchmark DAC, and plays these files without compromise, using DSD over PCM for transmission to the DAC. This has always worked flawlessly. I also have a second system with an older PS Audio DAC, ethernet attached, where roon converts the dsf to PCM, downgrading to 16/44. Also has worked flawlessly, and still does. Since the 831 build, I can no longer use DoP on the benchmark, my primary system. If I change settings on the benchmark interface to use PCM, roon converts to 352 PCM, then down to 32 bit/176KHz, and it plays fine. If I try DoP instead, tracks play with no audio.
When I play dsf to the benchmark with DoP enabled, the signal path appears proper, showing DSD DSD64 2 ch —> Roon Core —>DSD over PCM v1.0 (DoP) —> Benchmark DAC2 HGC ALSA. This information is unchanged from previous operation when things were working. But the playback now proceeds silently. No errors starting up, and tracks play silently to the end.

Note I have a DAC3 which Roon has always identified as a DAC2. The DSP chip is the same in both models, I’ve been told.
so something appears messed up in the most recent build and the benchmark interface, most likely related to DoP. Obviously I’d like this fixed…

1 Like

Hi @jim_hamilton,

What troubleshooting have tried, such as rebooting the Roon Core and the DAC?

Thanks for asking.
I have rebooted both my rock and the benchmark to see if some sort of handshaking initialization was involved. I’ve also re-selected the benchmark in setup/audio devices, and tried a few settings in device setup for the benchmark. Nothing gives me volume. Went back to the default settings (which is all I ever used), which show:
connected to core: benchmark ALSA
settings: (these are the default setting for roon and this device)

  • DSD over PCM v1.0 (DoP)
  • MQA renderer only
  • volume control - device volume
  • volume limits: comfort 100, safdty min 0 safety max 100, device limits min 0 max 100
  • rsync delay 0 ms (tried changing this to 50 ms, made no difference, put it back to default 0

just to reiterate:

  • no hardware changes in my system
  • no software or firmware update to my benchmark DAC3
  • using the default for benchmark audio device setup, same as I have always used
  • using the same controller
  • only DoP is affected
  • if I change from DoP to PCM conversion in audio device setup, the files that are playing silently with DoP (and used to play fine before the upgrade) play properly.

one small disclaimer: I did not figure out the problem immediately after upgrade. I started noticing some playlist entries were playing silently, and eventually traced the problem to a general DoP problem affecting all DSD files. I’m only surmising that this is a software upgrade problem, but its hard to see what else it could be.

Set to Fixed Volume

Thanks, but nope. I had tried all three volume choices (DSP, device, fixed) before posting. But given the suggestion, I reset the volume setting for the benchmark to fixed and saved. I then rebooted my rock, and restarted the DAC. checked that the setting was retained, emptied the queue, and loaded/played a DSD. Same issue, plays silently with no errors. DAC is sync’d.

Do you have another computer to check DoP playback to the DAC, using a different music player from Roon?

This is a logical question. Seems unlikely to me, given that there have been no HW or SW changes to the DAC, but certainly something to check for completeness. I have many computers, but nothing configured for this test, which requires a DoP capable player with USB output. I’ll download the latest moode, install it on one of my pi’s and try that with the benchmark. Not a quick test for me. Along this line, I could also roll back the roon version, though I think I have heard this is not straightforward. I will also talk to benchmark tomorrow and see if they can replicate the problem.

ok, I got a fresh version of moode and configured it. It plays the same DSF files that roon is messing up just fine using DoP to the benchmark.

… and by the way, the benchmark DAC 3 is fully capable of playing DSD64 natively. Roon does not offer me an option to select native DSD for the benchmark. Both DoP and native DSD play great on the benchmark using moode. So…

  1. as originally claimed, roon broke something here.
  2. roon should permit native DSD to the benchmark DAC3 and does not. I noticed this previously, but while there are religious wars about whether DoP and native DSD have the same sound quality, I have listened to both on a pretty high end system and not seen the reputed difference that some claim.

roon: please fix DoP. sometime in the future, allow me to select native DSD for my benchmark.

That’s pretty strange. I had the Benchmark DAC3 B in my system for a week or so, just to try out. It was connected to the iFi ZEN Stream network audio transport. Sounded great. I had some problems initially, but it turned out to be a faulty COAX S/PDIF cable. No issues with DSD that I can recall. I did test a couple of different DSD formats, because I remember the LEDs changing.

You did not mention what device you are using to feed the Benchmark or what operating system it’s running. Perhaps something changed there.

hi david,
I appreciate the information and attempt to help, but please don’t confuse the issue.

  1. I also had no problems with the benchmark and DSD - until the latest roon release
  2. the first sentence in my first message says I’m running roon on a rock, USB connected to the DAC
  3. I’ve emphasized that nothing has changed in my system other than the roon update. no change to the benchmark hw/software/firmware, no cable changes, etc
  4. I’ve now shown that another audio system (moode), USB connected to the benchmark, plays DSD fine, same DSF files that roon suddenly won’t play (but did previously).

I don’t think I can be more clear. this is a roon problem that has popped up only recently.

This was a bit confusing, are the files actually named this way or were you describing their properties?

Regarding the Native capability, that’s up to Benchmark/USB Reciever manufacturer to provide drivers for the Linux kernel in use. I wouldn’t hold my breath.

And the scenario at hand, sounds strange. It’s not a general Roon B831 issue though, as i’m playing DSD in both DoP and Native on a daily basis. You should follow Peters advice on the Fixed volume setting, but thats more of a general reccy.

You did describe the signal path previously, but please add a couple of screen shots of the signal path when playing back DSD and PCM to this Zone?
And some of the audio zone settings?

This could be an issue in the ALSA properties, but i fail to see how this possibly could change when Roon application is updated.

Anyways, if you feel like it, you could have a look in the log files of your ROCK to accomplish two things:

  1. Locate the RAATServer_log.txt ( \\[Roon ROCK IP Adress]\Data\RAATServer\Logs )
  2. Examine which device id is associated with your Benchmark, and delete it’s corresponding .json-file, to completely reset it’s properties. (Please disconnect your Benchmark before this)
  3. Also see in the RAATServer_log.txt what capabilities it reports back upon reconnection and rediscovery.
1 Like

Solved. It was a DSP settings problem. In the DSP menu, under sample rate conversion (which I have disabled) is a set of DSD processing settings. Since I had sample rate conversion disabled, I hadn’t looked at its submenu. One of these submenu items is “enable native DSD processing”, which was set to yes. This is incompatible with the DoP over USB setting, and the handshaking to the DAC was broken for DoP as a result. When I set this to ‘no’, DoP began working.

This is not a roon 1.8/831 bug as I claimed. Either I messed with the DSP setting or roon changed the default for native DSD from no to yes. (I normally have no reason to use DSP and have seldom even looked at the menu there. Having the DSD processing as a submenu under sample rate conversion, and settings which have active effects even when sample rate conversion is disabled, is a user interface that could be improved.)

as a side note, I talked to benchmark support, who have an extensive benchmark/roon setup in their lab. He cautioned me to make sure that all the roon volume controls were set to their max as well for DoP.

On the related issue I brought up regarding native DSD, there is a lot of confusion about native DSD over USB. Apparently most DSD over USB is DoP. In my testing of DSD with moode audio, when I enabled native DSD in moode, it initially didn’t work. Moode provides an ALSA setting described as follows:


Default (plughw)
Perform automatic conversions if needed for example 0-pad the bit depth to a width supported by the audio device.
Enable a mechanism for creating a Loopback device that provudes a copy of the PCM stream.
Direct (hw)
No automatic conversions are performed. The audio device must support the output format or playback will not occur.


Native DSD will not work in my setup with moode unless this alsa setting is set to “direct hw”. But, as already noted, roon does not support native DSD anyway.

thanks to everyone who helped.

Roon supports Native DSD if the drivers for your hardware is compiled into the current kernel or your endpoint recognize this capability. This means, native DSD support may appear if Benchmark stresses the creation of drivers for Linux. Then Roon might build a newer version of their platform RoonOS whcih includes these drivers.

Glad it’s working now! :slight_smile: Enjoy your tunes’!

1 Like

Your DAC does not support USB native DSD. It only supports DoP. That is different from most DAC nowadays - most of them do support native DSD, at least on Windows.

thanks, the clarification is appreciated. I’m an engineer, but not an audio engineer, and I found a lot of confusion on this topic on the internet… I don’t know what moode was doing then. - its running on the pi. I’m running roon on a rock - intel hw but not windows.

Thanks, definitely enjoying the music. I’d like to close my participation in this thread with this statement from a benchmark engineer, to clear up any confusion. This is in agreement with the remarks later in this thread from Peter Lie. Perhaps useful for other benchmark/roon users:

“The DAC2/DAC3 USB interface cannot support native DSD over USB due to hardware limitations. It is not possible to change this with a driver update. The DSD data must be transported over DoP and then it is delivered to the D/A conversion subsystem as native DSD. The DoP encapsulation preserves the native DSD data with exact bit for bit accuracy, so native DSD over USB is not needed.”

I did a lot of network engineering. Networks are all about encapsulation/layers, from hardware framing through multiple protocol layers. If encapsulation/decapsulation is done in hardware and does not introduce jitter, it’s pretty much a non-issue IMO and as stated above, though you will sometimes read otherwise in audiophile forums. My request for native DSD over USB support in Roon for the Benchmark DAC was misinformed. With other DACs, your mileage may vary.

1 Like