1.8 Audio devices in Settings but not in Zone picker [Ticket In]

Same here, Gato DIA-250 Integrated w/ DAC connected to Roon Core (1.8 - 756) via USB (Mac Pro '13, Big Sur 11.2.1). Zone disappears overnight, restart of Roon app resolves it.

Thanks,

@noris and @dylan, here is some additional information that may be helpful.

After updating everything to build 756, all zones were available for about 60 hours. Even after turning some of the endpoints off and on. However, this morning, when I turned on my main listening system, the Ropieee zone is gone. The issue is definitely related to zones that aren’t always present like DACs that you turn off or mobile devices if you stop playing or leave the app. All my AppleTVs and the old iPhones that I uses only as bridges are still there. Once the error occurs, other non sticky endpoint also disappear.

The Ropieee, all my macOS zones and our mobiles phones used with headphones are gone.

Looking at the logs, the error occurred at 02/13 16:44:45 today. I made a copy of the Logs folder soon thereafter, so I have logs going back from now until 2/8. If that is helpful.

What time zone is the system using for the logs?

Restarting core (Roon Server Software only) restored all audio zones.

Core Machine (Operating system/System info/Roon build number)

ROCK Version 1.0 (build 227) stable
Roon Core version 1.8 build 756
Gen8 i5, 8GB RAM, 500 SSD

everything else is the same as initial post

3 Likes

I have the same problem after upgrading to 1.8

Same problem on a Synology core and NUC endpoint running ROCK USB into Oppo UDP-205 USB DAC.

Restarting core fixes the issue but it comes back.

I mentioned it was ok, but only sustained for 5 hours, the issue came back again.
Thanks for your efforts, hope it be fixed as soon as possible.

Might be a version of this but my endpoint was disappearing every time my USB dac connected to a Pi was powered off, and I’ve found a workaround that fixes this. By enabling an endpoint that’s on the pi itself, that doesn’t go off, the USB endpoint comes back fine when the Dac is turned back on.

Described here. USB Dac endpoint becomes unavailable since 1.8 - #7 by dylan

I had this problem on day one of Roon 1.8. After restarting my Nucleus Roon core, my RPi4 with USB connection to Meridian Prime would show up again. If I turned the Meridian Prime off, it would not come back unless I restarted my Nucleus. Finally, after a couple times of doing this, I rebooted my router also. About the same time, we all got updated to Roon 1.8, build 756. I have not had this problem since then and I can turn my Meridian Prime on and off and it reappears instantly, as it should.

EDIT: I just tested it again and it’s still working as it should with Meridian Prime turned off and on.

Hi, I’m having trouble getting my Chord Hugo 2 to show up in my audio devices in Roon. The issue is happening on a Macbook Air M1 running Big Sur 11.1. The Air is connected wirelessly to my Roon core, a Macbook Pro early 2015. This issue has developed since I updated to the new version of Roon.

The Hugo 2 is connected via USB cable to the Macbook Air and works just fine through OSX and the Tidal app. Roon recognizes that the Hugo 2 is connected and displays it under “This Mac” on the “Audio” setting tab in Roon. Is shows as “CoreAudio.” I have disabled and enabled it multiple times and tried resetting the “device setup” to defaults. “Private zone” is not selected.

Despite all of this suggesting there is nothing wrong with my connection to the Hugo 2, Roon says at the bottom of the screen that I have “No audio devices found.” Stranger still, I was able to add the Hugo 2 to a group with the System Output of my Core and successfully played losslessly to the Hugo 2 and the System Output. So Roon actually has no problem outputting to the DAC, it simply won’t display it as its own device in the player.

I tried disabling all the audio devices and then reenabling, but now I don’t see any devices available to play to, despite several showing as enabled in the Audio settings window.

Help?

Same issue here:

02/14 08:53:01 Debug: NotifyCorruptZoneDatabases Exception LevelDb.Exception: IO error: lock /var/roon/RoonServer/Database/Core/f05024d5dd4f4d4e9e85cd849895d1a9/transport/zone_16012fd3a5f31d64c74b8382fbf6bde0fcd5.db/LOCK: already held by process
  at LevelDb.Database._CheckError (System.IntPtr err) [0x00037] in <c495c7ebabb54b78a9ef13ecb1cd00aa>:0
  at LevelDb.Database..ctor (System.String path) [0x00075] in <c495c7ebabb54b78a9ef13ecb1cd00aa>:0
  at Sooloos.Broker.Transport.ZoneDb..ctor (System.String dbpath) [0x0000d] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Zone..ctor (Sooloos.Broker.State state, Sooloos.Broker.Transport.Module module, System.Sooid zoneid, System.Collections.Generic.IEnumerable`1[T] endpoints) [0x0010f] in <816381aafbe2495a9150b9060c285ec5>:0
02/14 08:53:01 Error: [transport] emptying out corrupt zone database 22:1:f3a5d32f-641d-4bc7-8382-fbf6bde0fcd5
02/14 08:53:01 Critical: scx: in OnExit: System.NullReferenceException: Object reference not set to an instance of an object
  at Sooloos.Broker.Transport.Zone._CancelPendingSleep () [0x00000] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Zone._StopWithoutTouchingDatabases () [0x00007] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Module.NotifyCorruptZoneDatabases (Sooloos.Broker.Transport.IZone zone, System.Exception e) [0x0005b] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Zone..ctor (Sooloos.Broker.State state, Sooloos.Broker.Transport.Module module, System.Sooid zoneid, System.Collections.Generic.IEnumerable`1[T] endpoints) [0x00133] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Module.NewZone (Sooloos.Broker.State state, Sooloos.Broker.Transport.Module module, System.Sooid zoneid, System.Collections.Generic.IEnumerable`1[T] endpoints) [0x00000] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.Broker.Transport.Module.ev_threadexit () [0x009fe] in <816381aafbe2495a9150b9060c285ec5>:0
  at Sooloos.SynchronizationContextThread.OnExit () [0x0000a] in <2b8464ac30eb4403a9ac8d3163052362>:0

Having the same issue on Windows 10 with audio zone disappearing. Having to restart core multiple times a day. Problem only started with update to 1.8

1 Like

I have this issue only on my work Macbook Air 2015 as endpoint with DAC attached every other endpoint no issues. DAC in this case Hiby R5 drops off, I can see it in devices but Roon won’t see it as a zone. It worked initially but I changed one setting in device settings and it them started this behaviour. Reboot of core restores it temporarily and then it drops off again.

Same issue here.
Reboot endpoint or reconnect usb-dac does not solve the problem. Only reboot the Core does.

Setup:
Core 1.8 (build 756) on NUC8i5BEH Win10pro 20H2 Build 19042.804
Endpoint NUC5PPYB Rock 1.0 (build227) > Chord Mojo usb-dac

Same here. Pi4, DietPi, RoonBridge. Need to reboot the core (on Synology) whenever the DAC was switched off. Before reboot of the core i cannot select the bridge in zone picker. Grouping the bridge with another zone works as a workaround.

Thank you for posting this. I had the same issue with my iPhone and iPad. Did a full reboot of my Innous Zenith III. All good again now.

Same issue, though 3 Ropieee endpoints, 6 Chromecasts and 4 Airplays are all visible. It’s only the Schiit Modi 2 Uber connected to my Mac that is not visible as an endpoint, even though it appears in the settings. Rebooting the Core (ROCK on an Intel NUC) tends to make it visible again. Roon remotes have occasionally lost the Modi in the past, so this might not entirely be a 1.8 issue

Also happening here from time to time - please fix it quickly.

1 Like

Same issue happening for me as well. But the one thing I didn’t see anyone else mention was the mix of the specific zones that disappeared.

Roon Core - v1.8 Build 756 64-bit
Endpoints - Combination of technologies including

  • Direct Roon Core output via WASAPI - Pre-box S2 DAC
  • Roon Endpoint MacBook Pro running v11.2.1 via Focusrite 18i8 audio interface
  • Roon Ready Naim Mu-so 2
  • Chromecast - Three different endpoints using two different versions of Chromecast devices
  • Airplay - Apple TV 4K and Denon AVR-X4100W receiver
  • Sonos Streaming - Sonos1

The Airplay devices and the Sonos1 are still visible. But the remaining direct connections, the Naim Mu-so 2, and Chromecast connections are all gone.

After restarting the Roon Core everything returned.

I am having same problem, the DAC just disappear from audio zone. Using MacBook Pro with local USB DAC, it is appearing in Mac sound setting and no issue, Roon found it in Settings → Audio, but Audio Zone cannot select at all.

Same issue. Zones are coming and going without reboot. But can’t get the RaspberryPi zone back.

Even on the iPhone app, the iPhone itself is intermittently disappearing.

Very disappointing Roon.

1 Like