1.8 bug: it is no longer possible to navigate from album to composition

This is an issue with both the Roon 1.8 clients for Windows and iOS.

It is no longer possible to navigate to a classical composition from a recording of that composition, EXCEPT if there are more than 2 recordings of the composition in my library. In that case I can click on the disc symbol on the album page and it will navigate to the composition.

In 1.7 this was always possible.

See an example in this screenshot. Only Horn Concerto No. 2 has the link to the composition.

Hello @ask, is this happening for any album you visit or just this album?

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

@nuwriy It happens with all albums (all the ones I have checked).

I am running Roon core 1.8 build 753 on an Intel Nuc with Ubuntu server 20.04

Windows client is also a Roon 1.8 build 753.

@nuwriy Do you need more information from me?

@nuwriy Why are you not following up this thread?

I need a link to go from a recording to the corresponding composotion.

It was available in 1.7 but is gone in 1.8.

It is where it was in 1.7 too. Use the 3-dots menu - scroll down if needed.

It is not there? Here is a screenshot of the 3-dot dropdown menu. Where do you want me to click?

Hi @ask

Can you try scrolling down in the 3 dot menu? It should be there, you just have to scroll to it.

@dylan it is definitely not there. But I see now that the individual tracks have a link to the composition.

I didn’t see this before, since it didn’t even occur to me that the link would not be on the composition level but rather on the individual movements.

So then I know how to access the composition, I guess I’m fine. But it’s not clean. This is a bug, right?

@dylan Also why are not the movements/tracks of a composition indented, like they were in 1.7? Another oversight?

Now it is much harder to navigate in a multi-composition recording.

1 Like

@dylan @ivan @nuwriy

@dylan Can you see the question I asked you a week ago to which you did not give me an answer? Could you please consider my question?

Restatement:

  • Why do I have to click on individual parts (tracks) of a composition to navigate to the composition page? I.e. why is there no link on top level?

  • Why are the parts of a composition no longer indented?

1 Like

This was brought up by quite a few people in the forums and I wrote a bug report here.

I guess current thinking at Roon is, that this is “by design” and not “by bug”. The reasoning goes along the lines of “easier in portrait mode”. Maybe they rethink - dont know. I think it looks terrible. Movements are indented everywhere. Booklets of recordings, concert programs, you name it… You just no longer easily see where a composition starts and ends.

The composition matching issue you experience I think has been brought up before as well. Just cant find the link right now. I put it in when I find it.

1 Like

Apologies for the delay, @ask — Our team’s queue is a bit longer than typical at the moment due to the release.

I’ve passed your feedback along to the team for further consideration. I can’t make any promises here, but I’ll make sure your feedback is seen by the team!

Thanks @dylan

Could you please also tell me whether the no-indentation of composition parts is “by design”, as @bbrip suggested, or if it is unintentional?

And what about the navigation to composition? Is it intentional that this is only available on the individual tracks of a composition? Look at the screenshot in the first post of this thread. In Roon 1.7, I could click on a symbol next to “Horn Concerto No. 1”. Now I have to click on the three-dot-menu of “Allegro” and choose “Go to composition”. Is this by design? Sorry about the nitpicking, but it is important for me to know.

All the best to the Roon team! I’m sure you are all very busy.

@dylan I am still awaiting your reply to the above post. If you don’t have time, can you please hand it over to one of your colleagues?

A post was split to a new topic: Navigation icon no longer appears

I agree the “logic” behind this is a mystery. You get a symbol when you have 2, 5 or 15 recordings of any given composition in the library, but not if you have just one? I would just expect the same library symbol with a “1”. Anything else doesnt make any sense.

2 Likes

Hi @ask

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

This was by design, but we recently changed this:

The composition navigation changes were also by design. While I can’t make any specific guarantees, I can say for certain that your feedback has been passed along to the team for future consideration!