1.8 Build 970 won't install

Roon Core Machine

Synology 216+II 4GB, DSM 7.1

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

18000 tracks

Description of Issue

I get the usual “an update is ready to be downloaded”. The update process runs normally (click here to install … Downloading… Installing… Click here to relaunch…) and when the core is back online, settings > about returns build 952 as if nothing happened.

Is there an install log that I check for errors?

Tagging @crieke for you, maybe he has a clue what’s going on.

A Celeron and only 4GB of RAM sound like a ticket to frustration with Roon.


My el cheapo nas has been doing a good job so far. It even handles playing DSD’s over a chromecast audio so no hardware complaints here.
Except now for this minor update problem.

1 Like

aha, found a log. getting there …

Error: [appupdater] While installing update: System.ComponentModel.Win32Exception (13): An error occurred trying to start process ‘/tmp/da505c9e-9ee0-40e7-ab5a-2da5a01b89b7/RoonServer/start.sh’ with working directory ‘/volume1/@appstore/RoonServer/RoonServer/Appliance’. Permission denied
at System.Diagnostics.Process.ForkAndExecProcess(ProcessStartInfo startInfo, String resolvedFilename, String[] argv, String[] envp, String cwd, Boolean setCredentials, UInt32 userId, UInt32 groupId, UInt32[] groups, Int32& stdinFd, Int32& stdoutFd, Int32& stderrFd, Boolean usesTerminal, Boolean throwOnNoExec)
at System.Diagnostics.Process.StartCore(ProcessStartInfo startInfo)
at System.Diagnostics.Process.Start()
at Base.DotNetChildProcess.StartImp(String filename)
at Base.ChildProcessBase.Start()
at Base.ChildProcess.Start()
at Sooloos.Updater.<>c__DisplayClass42_0.b__0(Object )

See this topic. It can probably point you in the right direction.

Thanks for that, Alfred.

Checking the permissions on my RoonServer mount is the 1st thing I tried.
Funny thing is I have no internal user for Roon on my system (?!). The more I dig in my setup, the more suprised I get that everything is working flawlessly as it is :slight_smile:

I tried to create the folder Appliance under RoonServer because it didn’t yet exist.
That didn’t help and I got the exact same error msg.

I tried to grant full control to ‘Users’ on RoonServer. Same thing. Doubt that it is really a permissions thing, but if I knew what account is used that may help.

Basically I’m stuck here, even though I feel it must be something trivial. Hence my hope is with @crieke


I have this issue too …

@stefan_joris @Sean_Keyes

You did not mention which version of the Synology installer you are using.

I’d uninstall Roon Server and install it again with the latest spa from the roononnas website. If you select the same storage folder for your database during installation, it will pick up your current database. It should also install the latest version of Roon Server.

If you use an an usb (or esata) volume, make sure it is formatted with an ext4 filesystem. Other filesystem might have issues in regards to permissions as well.

Thanks for intervening @crieke Christopher!

My package manager only shows this Roon app, it’s been in stopped status since the DSM 7 upgrade. Is this the installer version you refer to?

Roon starts with this scheduled task;


So I uninstall this ‘stopped’ Roon, I remove or disable the scheduled task (correct?) and re-install with latest spa from the roononnas then.

this is what is currently running on my Synology

Normally the updates run OK, this is the first time I’ve had an issue. Ive uninstalled and reinstalled and that seems to have fixed the issue but its been a right pain to do … thanks for your assistance @crieke

Your app sure looks healthier to begin with.

Great @Sean_Keyes!

It seems you are running the DSM6 installation on your Diskstation. I’d really recommend to use the current build, as it is hard for me, to provide support on this kind of install, as it was never meant to run on DSM7.
So yes, please remove the task to manually start RoonServer from the Synology Task Manager…

If you encounter any issues with the current build for DSM7, please let me know.

I have not observed any update errors here yet, so I hope, this is a one time error. If that is not the case, please let me know.

The DSM7 installation, will create a root folder “RoonOnNAS” for all Roon related files. This was necessary, as I could not re-use any DSM6 database files due to ownership issues.
Background: DSM6 was running as “root” user, which is not allowed in DSM7 anymore. Because of that all files belong to “root”. The installation process creates a RoonOnNAS directory and should copy the old DSM6 database into it, so it has the ownership.

There is also a RoonOnNAS/bin directory, where you can put the amd64 version of ffmpeg from JohnVanSickles page. (extract the downloaded archive first, only the file ffmpeg is needed in the bin directory). This will enable playback of AAC files and radio streams again.


OK! Thanks for clarifying @crieke
Uninstalled, reïnstalled, and everything was back up and running in no time.
Good stuff

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.