1.8 graphics artefacts Windows 10 + Nvidia graphics

Update to 1.8 is causing graphics artefacts on all the text and art work. If I move the mouse the artefacts appear then stop. On Windows 10. Nvidia graphics card. All drivers are up to date.


Which graphics card. I have a 1070ti without any issues. Are you using any Game overlay software like from GOG, or Discord, etc?

My card is a GTX 1070. I do use discord, but it’s not running while roon is open. Obviously not had any problems like this with roon until this 1.8 update.

Rugby… if you move your mouse… Maybe empty your computer cache?

Not sure what you mean by “computer cache”?
When roon 1.8 now loads up, the graphics artefacts happen without the mouse moving, then when I move my mouse over any artwork it happens, but worst of all when I scroll with the mouse wheel.
My mouse is a Zowie FK1 it has no drivers.
I have no problems with any other piece of software or game only this new version of roon.

This might be related

All sorted now. In that thread they say to add “-nodeepcolor” to the target address of the roon taskbar shortcut. At first it wouldn’t let me add this, it was saying the address was incorrect. So I replaced the shortcut with a new one from roon.exe
Added in the -nodeepcolor to the target and it now works fine again. So looks like after the update, the shortcut icon changed, but must’ve messed it’s self up somehow??
Very relieved.

1 Like

Since you’re using an NVIDIA card, this isn’t the same bug as the Intel GPU issue, but it looks like turning off the same feature fixes things for you. Can you tell me a little more about your setup? I’d be most interested in:

  1. Are you using multiple monitors?
  2. If so, are these monitors running at the same refresh rate?
  3. Are any of these monitors configured to use 30-bit color? If you have multiple monitors, are they all configured to use the same color depth, or are do the settings differ? This is usually something you have to manually configure on NVIDIA cards.

As you say this isn’t the same as the intel bug, but by adding -nodeepcolor definitely fixes it. But obviously ideally this shouldn’t be happening at all.
Only use one monitor, refresh rate is 144hz and is 10bit
I just tested it again, I removed the -nodeepcolor from the target, and reloaded roon,
The artefacts returned.
Put it back in the target, reloaded roon, and it was fixed again.

I had this exact problem a while back. It was RTSS within MSI Afterburner that was the culprit. If that’s enabled, turn it off.

I did run MSI afterburner at the time of the update when this problem started.
I’ve since uninstalled it as it stopped working after a windows 10 update (damn updates)
Just tried removing the -nodeepcolor from the target, but the same problem persists.

And RivaTuner isn’t running as a process still? Do you have any other overclocking/monitoring software that can provide overlays? Just because the visual artifacts match mine, it really looks like something is hooking to Roon that shouldn’t be.

Nope RivaTuner is definitely not installed and running. I had Fraps installed, just uninstalled that. Didn’t fix it. Your probably right that some other program is causing it. But why only now after the 1.8 update?
Maybe steam overlay? But steam hasn’t been running when testing and it’s still happening. It’s a mystery.

Hi, I have same problem. After update on 1.8. My system RTX3090 + Monitor NEC PA311D on 10bit color ofc.

same problem here. EVGA 3090 Ultra + Predator X38P

Here is a screenshot of the actual artefacts

Had the exact same glitch on a Ryzen 9 3900x on a Gygabyte Aorus Master X570 running an NVidia RTX3080.
Adding the “-nodeepcolor” variable to the shortcut worked like a charm.


looks like I’m not alone. Hope they find out what’s causing this.

Just done update to 1.8 (Build 783) I removed the -nodeepcolor fix and it’s working perfect now. Thanks for your help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.