1.8 not finding my SGCD (but MacOS and Amarra can see it)

My SGCD worked with Roon for well over 2 years (ALAC, DSD, FLAC, WAV) - but now my recently updated to Roon 1.8 does not see the PS Audio SGCD.

I have now tried this on 2 machines:

  1. Macbook Pro (which it worked for 2 years) MacOS 10.13.6 - My Mac can see it as a Sound Output device, and my Mac can still play sound through it, but Roon 1.8 does not list it as a device. I even tried a license of Amarra Luxe that I own and it plays through the same Mac to the SGCD… but not with Roon 1.8. 1.8 simply doesn’t seem to see the PS Audio Stellar Gain Cell DAC through USB.

  2. Microsoft Surface Laptop with Windows 10 - also can not see the SGCD

Had someone help me on the FB Forum, and shared with me the SGCD is not a Roon certified device – yet it worked well for over 2 years…

Hey @David_Kelly1,

So sorry about the trouble with a trusted device…and a great apology for how long it took us to reply.

Is this still the case, does Roon not see your SGCD, but your Macbook can? If so, could you please check that the firmware on your device is updated. And, can you maybe restart both the devices and your Core?

Thanks in advance :pray:

My Mac is working again, my W10 Surface is not.

I am TERRIFIED about installing the latest update, afraid it will stop working again.

How do I check the logs to see what is happening?

Hey @David_Kelly1,

Thanks for staying in touch and sharing where things stand now. I’m sorry that all your devices don’t simultaneously work… :pensive:

You can find your logs here:


Roon 1.8 stopped working – it does not see my PS Audio SGCD. I’m going to try to fix this again, if I can’t, I’m canceling my Roon subscription. My Mac is used ONLY for one thing: Roon, and it has noot been updated. The SGCD hasn;t been updated either - but Roon updated itself, and now it doesn’t work.


Mac OS can see the Sound Output “Stellar Gain Cell DAC” Type USB. System sounds play through the DAC. iTunes pays through the DAC. AmarraLux plays through the DAC – it is only Roon that (again) can’t find it.

Trues it with my W10 laptop and the latest Roon – also doesn;t see it.

Hi @David_Kelly1

Do other devices show up okay? Can you share a screenshot of Settings > Audio?

1 Like

Core is my iMac, Remote is my MacBookPro. First screen shot shows the MacBook can see my DAC on USB

mac sees SGCD

On my MacBookPro, all I can see in Audio is my iMac’s outputs:

Last screen shot shows the Core and Remote - both have the latest version
remote and core

Sorry for the late response, @David_Kelly1. Can you please use the directions found here and send us over a set of logs using a shared Dropbox link (or any other file sharing service)? Thanks!

I gave up on it – so I sold the DAC. I now have a Mytek BB, and it is working well.

I <<>> think you need to add a setting to use the OS connected USB, I have read quite a few other threads on other DACs, and it sounds like there are a few others not able to connect to their PS Audio, Schiit, Sony HAP-Z1ES and other “regular” DACs.

I think from memory a lot of times the USB audio is showing up but because it doesn’t have a name that’s instantly recognisable or appears to be it, people can miss it.
It will usually show up as an audio option attached directly to the core.
My screenshot shows 2 audio outputs, none of which are enabled but one of them is the actual USB that could be used to go directly out to a dac that is not recognized by Roon.
But it does not actually say that so…