192/24 Reduced to CD Quality


This must have something to do with hardware limitations, but whenever I play this particular album via my Peachtree Audio M24’s via USB, I can only get CD quality playback. The DAC in the M24 is rated at 96/24 via USB, and I would understand the file being knocked down to those specs, but “High Quality” is the end result. I do not have this problem with other hi-res files played through the M24’s, just this one so far.
The album plays lossless on my home system (DAC in Bluesound Vault 2i). Would being mono have any effect? Just curious.

Hello @Jim_White1,

When you go to the “Device Setup” screen for the Peachtree zone, what are the highest available sample rate and bit depth options available in the “Show Advanced” screen?

Is it possible that your device is presenting two playback zones in the Settings > Audio screen? If so, I would try both to see which provides the best format support.


I will check that next time I am at the cabin and report back. Now that I look at that screen, It could very well be that the limits are set incorrectly. When I switch to the Audioquest Drangonfly I do not have the problem. Thanks John!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.