5-10 sec no sound during playback/roon RAAT Devialet D220 Pro

Core Machine (Operating system/System info/Roon build number)

Media Server: Lian Li PC-Q25B; Corsair SF450 Gold; 2 x 8GB Kingston DDR2400 ECC RAM; Asus P10S-I; i3-7100 3MB 3.9 GHz; 64 GB Transcend MTS400 M.2 SSD; NH-9Li; NH-S12A PWM; NH-A14 PWM; 2 x 8TB WD Red (Mirrored using Microsoft Storage Space) + 3 x 10 TB WD Red; iKVM IPMI-Remote Management; Windows 10 Pro; EaseUS Backup; WD Utilities;

Latest Roon Version (downloaded yesterday)

Audio Files (not only) are on the 8TB disk. On the 10TB disks are Movies & TV Shows

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Devialet D220 Pro CI - connected through AQ Ethernet cable to switch

Description Of Issue
I wanted to give the Devialet Trial offering of roon a chance using roon RAAT.

If e.g. playing Diana Krall “From this Momement On” in 16bit/44,1kHz or 24 bit/96kHz or via Qobuz there is 5-10 sec no sound during playback. After this time sound is back. Playback proceeds during the phase where there is no sound. Protocol used is Roon RAAT.

Playing Qobuz from my Media Renderer connected to USB to my Devialet works without problems. I have also JRiver. The same is valid with JRMC running as a client to the server connected through USB to my Devailet. I never got UPNP playback working from my media server using JRMC to the Devialet (stuttering, buffering issues), also using Devialet AIR with MC is not working flawless.

Could it be that the CI Module is damaged - I have than go back to Devialet or is it more a network issue?

Unplug the power line adapters and see if it changes anything.
I would highly doubt that the CI module is at fault.

No difference. I also added exclusions to windows defender excluding all roon applications and folders. No difference. I also stopped the firewall. No difference.

There’s currently an issue with Devialet and 1Gb network connections, perhaps that is at play here. Have you tried connecting the Devialet with WiFi, or if possible, forcing the port to 100Mb?

I configured the Devialet port on the switch to 100M. Does not help.
For the Devialet port on my switch I have auto negoation disabled and flow control enabled. Is that correct?
For the other ports I have auto negoation enabled and flow control disabled.

I believe so, though you could try with flow control off.

Hello @Manfred_Schuermann,

Is the behavior the same if you try to connect the Devialet and Core directly to the router, bypassing the repeater and powerline adapters? Or if this is not possible, can you try connecting the switch to the router and bypass the repeater? We have seen both powerline adapters and repeaters cause issues with Roon in the past, so getting these out of the equation will be a good first step here.


  1. What I have done in the meantime, I switched the Switch from manged to unmanged but that did not solve the problem.

  2. What works if I run roon on my media renderer connected over ethernet to the roon core and then connect the media renderer via usb to the devialet, but that is not my goal - I wanted to get rid of my DIY build media renderer.

  3. I have moved the roon core to the media renderer and copied a small subset of my flac files 16bit/44,1 kHz; 24bit/48kHz, 96kHz, 192kHz and DSD files to the ssd (where Win 10 Pro is installed) inside my media renderer.
    -Scenario a: Using DHCP
    -> the problem occours at all high res FLAC files and DSD
    -Scenario b: Installed an additional Intel single port ethernet adapter, using fix IP-Adr. between the D220 Pro and my media renderer with roon core (directly connected with an ethernet cable)
    ->the problem occours at all high res FLAC files and DSD

As a test, can you plug your D220 and media server directly into the fritzbox 6490, and remove the powerline and repeater? Or, remove the powerline and repeater, and plug the lynksys into the 6490 with a long network cable?

I connected my Router with a 10m Cat5E cable directly to the switch (what a luck to have it at home). Enable again DHCP in the Devialet and connect the Devialet to the switch.
Repeater and Powerline adapters are not connected anymore to the router or to the switch.
Playing D. Krall 24/192kHz from my media renderer (where roon core is currently installed) after 2 sec no sound, sound back after ~5sec.
I don’t think its an DHCP issue.

Its not a dhcp issue, I suspect the lynksys switch is choking on the throughput which is why it would be nice to test without it.

In one of the previous test I changed the linksys switch replacing it with a TP Link but does not help. I can again do it.

So I replaced the switch to TP-Link (managed) again -no config necessary. No Repeater, no Powerline. But the same problem. I don’t believe its the switch. In the initial state described in the picture in my first post I can stream 4k HDR videos with JRMC without any glitches.

I put together a summary:

Base Line a): WD-Red→MS (roon core) -> Ethernet -> Linksys Switch → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times)

Base Line b): WD-Red→MS (roon core) -> Ethernet -> Linksys Switch → MR (roon) ->D220 Pro | USB (works)

Test 3:WD-Red→MS (roon core) -> Ethernet -> TP Link Switch → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times)

Test 4: SSD→MR (roon core) -> Ethernet -> Linksys Switch → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times)

Test 5: SSD→MR (roon core) → D220 Pro | USB (works)

Test 6: SSD→MR (roon core) -> Ethernet → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times) (FIX IP-Adress of Devialet, add. NIC with FIX IP-Adr., no Router, no Repeater, No PL involved)

Test 7: SSD→MR (roon core) -> Ethernet->** Linksys Switch** → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times) (10m Ethernet cable to Router, no Repeater, No PL involved)

Test 8: SSD→MR (roon core) -> Ethernet -> TP Link Switch → D220 Pro | Roon Ready (no sound during Playback for ~5 sec, a few times, ) (10m Ethernet cable to Router, no Repeater, No PL involved)

And if you plug your D220 and media server directly into the fritzbox 6490?
You could possibly have a bad cable, or one looks ok but negotiates a slower speed.

I use a wired Roon server connection to a fritzbox 7590, and a wifi connection to a D440, with no problems at all. There must be an explanation why your setup doesn’t work correctly.

But Test #6 is local playback through a dedicated Ethernet connection directly to the D220 Pro with Fix IP-Adress. No Router, No Switch, No Repeater, NO PL involved into playback.

I also reinstalled latest Firmware again, with powering off the D220 Pro for 10 sec; but does not help.

Hi @Manfred_Schuermann,

Thank you for running those tests. Your symptoms appear to match the one’s listed in this thread:

We are in contact with Devialet regarding this issue and actively discussing the possible causes.
As soon as we have any updates to share we will be updating the thread.

yes .-) - I got it working. I had the idea back on the train today. Playing since 40 min different type of HighRes FLAC files without problems, even DSD works.

All Ethernet Adapters in my network are Intel and all have enabled Auto Negotiation.

What works:

I configured the port of my Linksys switch connected to the Devialet in the following way:
Auto Negotiation=Disable
Port Speed = 100M
Flow Control = Enabled

What does not work:

Auto Negotiation=Enable
Port Speed = 100M
Flow Control = Disabled

Auto Negotiation=Disable
Port Speed = 1000M
Flow Control = Enabled

The Devialet has a problem with Auto Negotiation and with 1 Gb Ethernet.

Hi @Manfred_Schuermann,

Glad to hear that you’re up and running with those changes.

Just something to keep in mind – the port speed change is not meant to be a permanent solution, this can cause other types of problems down the line where data is not being delivered to the DAC in time.

I would still suggest keeping a close eye on that thread so that when our investigation with Devialet is concluded and a fix is published it is recommended that you revert back to gigabit speeds.

– Noris


In my last post I forgot to mention to get it working I had two switches in place (there are not visible from the listening place). A TP-Link 8 Port SG108S switch where everything is connected excluding the Devialet. The TP-Link is then connected to the Linksys switch via 1Gb Eth,. The Linksys switch is then connected to the Devialet with the parameters mentioned in my previous post. With this config no problems any more, even upscaling everything to DSD works without any problems.

I tried it to get it working with the Linksys switch only but I had not found a config to get it done (Snooping on/off, multicast on/off - Linksys switch).

RAAT is really phantastic with SQ better then if I use my MR connected via USB chain, Sotm card and JPlay USB Isolator.

So I am really thinking about purchasing Roon. I have a few more questions - should I open a separate thread?

Yes, support threads are supposed to be for each individual support question. If you have general questions, then please start a new thread. That way others with the same question may notice the thread; which they may not if it is buried inside a different support thread.

1 Like