502 Error with Port Forwarding/Did Not Find UPnP

I’m having the following problem and I’m not able to interpret it, I’ve already checked on the router and UPNP is enabled.

Can anybody help me?

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED xxx.xx.xxx.xx:55002, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“XXX.XX.XXX.XX”,“router_external_ip”:null},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“xxx.xxx.xx.x”,“found_upnp”:true,“error”:“Did not find UPnP service with WANIPConnection on network”}
}

Hi ______,

Thank you for reaching out for assistance with port forwarding and I appreciate your patiene for the last few days as the team has worked to onboard everybody. I’ve split your post into a separate thread so the team and other users can assist you more directly.

Typically, errors like the one you see can be caused by a misconfigured Port Forwarding setting, so if you are not seeing Ready listed in Roon Settings -> Roon ARC, please look over this guide before proceeding.

If you have reviewed this guide and still have not resolved the issue, can you provide the following details about your network setup to help expedite troubleshooting?

  1. Who is your internet service provider?

  2. Please list the make and model of your modem and router?

  3. Do you have any additional network hardware, like additional routers or managed switches?

  4. Does your network have any VPNs, proxy servers, or enterprise-grade security?

  5. What machine are you using as a Roon Core, and how is it connected to the internet?

Thanks!

Hi @Audiophile_Kave,

Reviewing the diagnostic error in your original post, the UPnP service with which Roon is attempting to connect to ARC doesn’t have access to the WAN IP address of the router. There are a few possibilities here:

  1. Is there a firewall enabled on either your Core or the router?
  2. Have you installed the latest firmware for your router from the manufacturer or ISP?
  3. Do you have any additional network hardware in between the Core and your upstream router, or a second router in this setup?
  4. Who is your internet service provider, and are you using a provided modem/gateway?

It’s possible you’ll need to manually configure a port forwarding rule in your router GUI using the port listed in the ARC tab in Roon. Please review the manual configuration section of our Help Center guide, and let me know if you need assistance.