882: "There was an issue loading your database". Fresh install. Can include DropBox link to my logs

Roon Core Machine

Windows 10 Pro with latest updates
I7-8700 3192 MHz 6 cores

Networking Gear & Setup Details

Ethernet connection to Core
Nighthawk X6 R8000

Connected Audio Devices

  1. Direct USB from Core to a Lampizator DAC
  2. Also tried Sotm SMS-200 inbetween Core and DAC

Number of Tracks in Library


Description of Issue

  1. Uninstalled Roon. Completely cleaned up everything.
  2. Fresh 882 install. Ran Roon
  3. All working ok. DID NOT import music library. Stopped Roon.
  4. Restarted Roon. All good. DID import library. Stopped Roon.
  5. Roon wouldn’t start. “There was an issue loading your database”

This is with the latest build 882.

My suspicion is that the database isn’t corrupt, but the Roon database restructure with the latest build and the application layer code that interacts with the database has not been updated properly.

This bug only manifests itself when particular users (such as myself) have something in our database that uses the new database structure but causes the coding bug to trigger. All application layer code paths need to be updated to work with the new database structure.

The tricky part is making sure the new code is also backward compatible with the old database structure in case someone tries to do a restore of an old database with the new code base.

I can include my logs and am willing to help the support folks as much as I can. For the time being I’ve gone back to JRiver and have found out the DLNA support with the SMS-200 is pretty good so at least I can still listen to my music.

Hey @leftside, if you could send over a link to your logs that would be excellent!

Ok all done

Looks like I was close in my diagnosis in a previous post.

The database was never corrupt. This was just a general exception thrown by the code when the code didn’t know what to do when loading a database that had unicode characters in it. Only the company will know why loading unicode characters with previous builds worked successfully and not with the latest builds.

Thanks Roon devs and QA for finally finding and fixing this problem. I know all too well the pressure you must have been under. Hopefully you follow good TDD practices and will now have updated your automation test scripts :wink:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.