A few ROCK questions re; BIOS, Fan-Speed & General Behaviour

OK so after giving up with W10pro to run roon on a 10th gen NUC. I have installed ROCK which was simple enough.

I’ve made the legacy setting required to allow the NUC 10th gen for the ROCK installation etc.
Question: can i now reset the BIOS to factory setting (F9) and leave it in the state?

I’ve restored and migrated the database. But I notice the fan speed on the NUC (every-now-again) to pickup and slow down.
Question: is this normal or can it be controlled?

Now there is effectively a bespoke OS; How do I shut the NUC down?

I can provide input on the shut down question. Have you accessed the Web UI page? Setting - Setup - Configure then clink on the IP address. Or enter the IP address in the your browser. There is a red power icon on the upper right portion of the Web UI screen. Selecting that will provide an option to Reboot or Power off.

I should add that process has worked for me for a long time but in the last several months it gives me the message that power off is complete but it does not power down the NUC. I press the power button on the NUC for several seconds to power down now.

OK so… the BIOS setting need to stay (tried F9)
@Mike_LC thanks got that now :slight_smile:

So just that fan speed. When i reset the bios settings i also put the fan into quite mode and have turned off Turbo setting on the processor.

  1. Press F2 during boot to enter BIOS Setup.
  2. Press F9 to set defaults.
  3. Press F10 to save and exit BIOS.

Yes i know that one; My question was more to do with once installed. but i now know that legacy settings need to remain in BIOS for ROCK to function.

OK so regarding the fan speeding up and down. I reinstalled ROCK, installed the CODECs, and rebuilt the DB from scratch, so a total fresh rebuild. The fan continued to behave as it had before in a; speed-up/speed down rhythmic cycle. maybe every 2mins@ 1000rpm and then 2000rmp for 10/15 sec.

Last night i decided to shut the NUC down completely and remove the 19v power cord from the back.
Switched it back on again this morning and so far so good! no up/down fan speed…

I suppose the next think to do would be to use manual fan speed settings, if it continued to miss behave?

OK so the fan started doing the up/down cycle again. The solution is to use ‘manual’ fan settings in BIOS/cooling.

Something’s not quite right, you shouldn’t need to do a hard shutdown. Anyway, see


It’s a known issue; the Web GUI doesn’t work properly, and the brief push on the power button doesn’t work either. It was first reported along with the CD-ripping issue on ROCK/Nucleus. I’m hoping these might get fixed in 1.8 - whenever that will arrive

Hmm, I thought that was only if a CD drive was connected?

FWIW I have no problems with my NUC.

And if you don’t have a CD drive connected, and you have no problems with your NUC or the Web GUI, then that’s a valuable data point.

I have a drive connected, and since Roon OS build 227 was released, I have these problems with ripping, the Web GUI and the power button.

@dylan - for info?

Mine shuts down perfectly via the GUI/ red button.

Do any of you have recommendations on fan speed settings?

Thanks Brian, I had tried the single press previously but apparently didn’t wait long enough. Just tried again, took about 5 seconds but it did power off. Good to know with my WEB UI power off not working for me.

Hey Geoff, I’ve been having the CD-ripping issue for months, had tried multiple CD’s and non worked. Yesterday I tried again, didn;t work. Had the Web UI up and it showed the ripper as normal. On a whim, I disconnected the usb cable, refreshed the web UI to verify the ripper was no longer there, reconnected the usb, refreshed the Web UI to verify the ripper was there again, then tried to rip again. Surprisingly it worked. I ripped the cds I had waiting. Guess we will see if it is still working for the next cd I get. And I just tried the single press for shutdown. It did work after about 5 seconds.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.