(A specific) Android/MIUI phone cannot connect to the Core

Hey there! I’ve got troubles connecting a specific phone to a Roon Core.

I think the root of the problem is not with Roon, but with the phone: it doesn’t know where to go to find the Core. I wonder if it wouldn’t help if I could provide the Remote with a specific IP address where it should search for the Core.

Further system information and weird experiences (the phone can connect, under certain circumstances) are below.

If you can help me figure out what to do with my phone, I would be so happy.

Roon Core Machine

Mac Mini

  • OS X 10.16.0
  • IP addresses wired: / wireless:
  • Subnet mask
  • Roon version 1.8 (build 931) stable
  • Roon configuration option “Accept connections from remotes” = “Yes”
  • Firewall settings described under the section “Networking Gear”.

Roon Remotes

Redmi Note 10 Pro

  • MIUI Global 13.0.8 Stable
  • IP address
  • Subnet mask
  • Roon version 1.8 (build 931) stable

MacBook Air

  • OS X 10.14.0
  • IP address
  • Subnet mask
  • Roon version 1.8 (build 931) stable
  • I also tried using this machine as Core, and experienced the same issue: all remotes except the Redmi Note 10 Pro could connect.

HP laptop

  • Windows 10 Enterprise, version 21H2, OS build 19044.1645
  • IP address
  • Roon version 1.8 (build 931) stable (64-bit)

iPhone SE 2020

  • data unknown at this time (phone not available to me), it’s completely stock

Networking Gear & Setup Details


I tried this on multiple networks, including two hardware routers and one mobile phone’s portable hotspot. My “home” network router is:

  • Huawei HA35-22
  • IP address
  • Port forwarding enabled. I used both host mode (target: “Mac-mini-wireless”) and client mode (IP address I restarted my router after configuring port forwarding.

The Core connects to the network via Ethernet or WiFi. Remotes connect to the network via WiFi. All are on the same network (the router provides 5G and non-5G modes; I tried both) and have IP addresses of 10.0.0.x.

The Core (Mac Mini) has a firewall. I have tried with the firewall enabled and disabled:

  • firewall enabled:
    • “Block all incoming connections” is unchecked
    • Roon, RoonAppliance, and RoonServer are configured to “Allow incoming connections”.
    • “Automatically allow built-in software…” is unchecked.
    • “Automatically allow downloaded signed software…” is checked.
    • “Enable stealth mode” is unchecked.
  • firewall disabled: all settings are disabled/unavailable.

Expected behaviour:

All remotes can connect to the Core.

Observed behavior:

All remotes except the Redmi Note 10 Pro can connect to the Core.

The weird parts:

  • I have been able to connect the Redmi Note 10 Pro remote to the Mac Mini Core under “exceptional” circumstances, which I am not able to reliably reproduce. These include:
    • Roon Core is running on the Mac Mini. The Remote is searching for a Core and cannot connect. I install and open Roon Server on the Mac Mini. The the remote sees two possible Cores, both on the Mac Mini, and I select/connect to one of them.
    • While the Remote is searching for a Core, I enable the MacBook Air as the Core. The remote could not connect (as expected). I (re-)enable the Mac Mini as Core, and the remote sees/connects the Core.
    • None of these connections survive a restart of the mobile app/phone.
  • I’ve used the Redmi as a remote for other applications:
    • I can SSH from the Redmi Note 10 Pro into the Mac Mini.
    • Retune: The Redmi Note 10 Pro sees the MacBook Air’s iTunes library when I use Retune as a remote. It sees, but cannot connect to, the Mac Mini’s Apple Music library (error 501).
    • Audirvana: when I try to connect to the Mac Mini from the Redmi Note 10 Pro, the Redmi doesn’t see the Mac (just like with Roon). Except! one exceptional circumstance that is also not reproducible:
      1. Audirvana is open on the Mac Mini.
      2. I open the remote app on the Redmi and it cannot connect.
      3. While the Redmi remote is open, I open the remote app on the iPhone. The iPhone detects the Mac Mini and I need to enter a numerical PIN. As soon as I enter the PIN, the Redmi connects.
  • It doesn’t matter which combination of WiFi networks I’m on (core/remote, 5G/not 5G), the MacBook Air, iPhone, HP, can all connect to the Core. And the Redmi Note 10 Pro cannot see the Core.

When the redmi times out if you click on help on the connection screen it pops up a window where you can enter the core’s IP address. If that doesnt work, do the same process but this time enter

1 Like

That seems like exactly what I’m looking for, but I can’t find it. How long is the timeout?

I’ve watched the screen for >10 minutes, and it stays at “Looking for your Roon core” with the animated circle.

Oh god, I found the “help” button just by…looking at the screen, but harder.
Fixed. Great. Thanks.
Considered closed.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.