Accessing Roon Backup on Core

Roon Core Machine

Running OS 1.O build 227.
Server software is 1.8 build 1021.

Networking Gear & Setup Details

Connected Audio Devices

Home AV receiver via USB

Number of Tracks in Library

About 45,000

Description of Issue

Nucleus is up and visible on ethernet home network but cannot find right path for network share – and backups can be found via restore backup link but they all fail after 1% loading.

Hi @Greg_Harding,

Thank you for your patience and I sincerely apologize that I wasn’t able to get a response to you before the weekend.

The tech support team has investigated diagnostics from your device and we have a few conclusions to pass on to help bring your system back to full functioning status:

This Nucleus is unfortunately completely out of storage space with evidence of possible low-level corruption in the database. The system logs show that less than 76 mb of storage space remains on the internal storage location. Take a look at this attempted backup performed on Friday:

08/12 04:01:11 Warn: [backup] restore, manifest file is corrupt: b_20211115080129_5c68f2aa-198e-44ed-9199-fd867e7bf9ae - System.IO.IOException: No space left on device : '/roon/data/RoonServer/.restore_tmp/Database/Core/7633c73f145445219c5f40c14f1c38fb/transport/zone_1601de006ab14768cf4698b67c31884d191a.db/000135.log'
   at System.IO.RandomAccess.WriteAtOffset(SafeFileHandle handle, ReadOnlySpan`1 buffer, Int64 fileOffset)
   at System.IO.Strategies.BufferedFileStreamStrategy.FlushWrite()
   at System.IO.Strategies.BufferedFileStreamStrategy.Dispose(Boolean disposing)
   at System.IO.Stream.Dispose()
   at RoonBackup.Backups.Restore(Canceler canceler, IFileSystemService fs, IFileSystemDir rootdir, String machineid, String backupname, String outdir, Action`2 progress_cb)

To put it simply, database corruption means that the records Roon is reading from your database are different from what was originally written. This isn’t common and can happen for a number of reasons, but there are fortunately steps we can to avoid or minimize loss to the library and restore Nucleus functionality.

We’ll need to perform the following:

  1. move your database backups off of the Nucleus to an external storage or NAS, since the Nucleus is out of internal storage.

    a. In Roon’s Settings > Storage, remove all old storage folders that contain the files that are being relocated. These will be your Backups folder/location mapped in Roon.

    b. Quit Roon on your Remots (and stop RoonServer on Nucleus though the Web Administration Interface). The best experience will come from letting Roon look at the folders when the files have settled.

    c. Move/Copy the files to the new location (you can connect a USB drive directly to the Nucleus if you’re using external storage).

    d. Start Roon/RoonServer again.

  2. Open Roon and map the new storage location to the Nucleus, so the Roon Core can locate and access your new backup location
    a. To add a new storage location, simply go to Settings/Backups, click the “View Scheduled Backups” button, and then click the “Add” button. Having set up your new backup location, you can delete the old one by clicking the “3 dots” menu by the location, then “Edit”, and finally “Delete”.

  3. we’ll then attempt to restore the most recent backup that doesn’t show evidence of corruption.

    a. Stop RoonServer from running in Nucleus’s WebUI
    b. Navigate to your Nucleus’ Database Location
    c. Find the folder that says “RoonServer”
    d. Rename the “RoonServer” folder to “RoonServer_old”
    e. Restart the RoonServer in the WebUI to generate a new Database
    f. On the Roon Remotes, press “Use another Core” and connect to the new database
    g. Restore your database from a Backup from before you started experiencing the issue.

If the database loads properly, your edits, playlists, tags, etc should be intact, and we can confirm everything is performing properly once it’s been restored.

For context, for database backups, Roon strongly recommends using an external storage location (USB, for example) or NAS device connected via Ethernet network share. It is critical that you cease using \\NUCLEUS\Data as a backup location for your regularly scheduled Roon backups. The reason is that Roon treats the entire drive as the storage location for your music files, and having folders containing Roon backups mixed in this is not a good idea.

I recognize this was a large volume of information, so the tech support team will be watching for your response in case we can help clarify or demystify any of the above steps. I know backup corruption issues are frustrating. We’re here to support you.

Hi Connor.

Many thanks for the response.

I will walk through your instructions and let you know how I make out. Somewhat lacking in computer tech abilities (apologies) so I expect I will need more help yet…

Not sure about the storage problem though as my PC shows my nucleus as having about 640GB free (see screen shot attached –reference drive Z).

As I say however, will head down the path you have charted out.

As part of that I will definitely move my new back-up location to another drive (indeed, until now I was backing up to one or more folders on my Nucleus). But this is where I am bumping into my first problem – adding a network share as a new backup location.

I have ordered a networked external ethernet drive that I assume I will be able to add to my home network as a NAS without too much trouble (and then navigate to there by adding as network share for Roon backups), but in the interim I thought I would try and use a drive on my home networked computer.

The drive I am trying to get to is drive E of my main desktop PC – as shown on the first screenshot. I have created a top-level folder on Drive E called RoonBackup. But I keep getting an error message – as shown in other screenshots – in trying to navigate to my E Drive. Have tried a few name/path variations but cannot seem to find the right folder path / naming protocol… Also tried setting up my C drive as the location, but had the same problem.

And I think I may have the same problem getting to my NAS once I set it up, so asking now…


Hi again Connor. I managed to attach an external hard drive to my Nucleus and also to add it as a new back-up location. Alas, prior to adding it as new back-up location I was only able to copy/move over from Nucleus a couple of recent back-ups (the others kept getting hung-up when copying over so I ended up deleting them). So unsure about proceeding to step 3. I am going to first run Roon Remote for a while and see if the database problem / error message re-appears. Thx.

Hi Connor. I now also have a NAS set-up on my home network to use as another back-up location to the external drive I have hooked up with my Nucleus (mapped as drive “X”), but I am unable to find the right path to navigate to when I go to add it as back-up location. Same error message as in the prior screenshots I sent your way. Roon remote has also acted up a couple of times - essentially timing out and searching for but then finding core…

Hi @Greg_Harding,

Sorry for the delayed response here and that your troubles with this issue. Thank you for your diligent reporting on the results.

First off, the combination of connectivity issues and the NAS filepath failing suggest there might be security settings on your network blocking connection between devices. Do you have a firewall enabled on this network on any of your Roon Remotes, or on the router itself? If so, you can find a list of exceptions to add for Roon in your firewall settings here.

An additional resource I wanted to share is our Help Center guide to setting up a network share on a NAS. You can find that here.

These two details suggest there may be underlying issues in your local network that we’ll want to tease out. The tech support team is going to pull logs and investigate to try to determine the cause.

Would you mind specifying what networking hardware is involved, and how your network is configured? I assume the NAS is hardwired to the same router as the Nucleus via ethernet?

We’ll keep an eye out for your response and thank you again for your patience.

Hi Connor.

The NAs is up and running for all other purposes. It is a Western Digital My Cloud device that is connected by LAN to my home ethernet the same way my Nucleus is connected. I can drag files to and from the NAS from both my desktop and laptop (where it comes up as a mapped drive). I can also access the NAS over an app on my android phone (see and work with files/folders).

I do have Norton 360 running and I did go in and turn off the firewall. But I keep getting the same error message of an invalid network filepath when I try and add the NAS as a backup. Variations of the file paths I have tried include: (1) the mapped drive name – \X:\ (2) the name of the drive – \Greg’sMyCloudHome:\ and the IP address I pulled off of my router: \\ Have tried with and without a backslash at the end or a colon, as well as without the apostrophe in “Greg’s”. Some screenshots attached.

My router is an Actiontec model T3200M. I have a fibre optic internet provider. Many other devices in the home all continue to work fine (wired and wireless such TV’s, phones, thermostats, etc.).

I have been thinking I just cannot get the file path naming convention right – be it to the NAS or, for example to a drive on my PC (as I tried earlier and reflected in one of my replies).

Thankfully I have a saved path to my Nucleus which is working (when I bring up the Backup screen) and I am now able to back up to the external drive that I also now have connected to my Nucleus (by accessing that saved Nucleus path).

I am thinking if I can get this NAS back-up file path (Network Share) problem beat, then I can turn to the Roon core / Remote stability problem I am having (a problem which is currently much improved over before, when I had my back-ups on my Nucleus core, but with Roon Remote still sometimes pausing and also crashing occasionally when I come back to it after doing other things on my PC). I am trying to follow the articles you sent, and will continue to do so, but seem to be struggling…

I also now have an additional hurdle when it comes to finding an old back-up that does nor reflect a corrupted database (my original problem it appears?) – as I lost those older back-up files when trying to move them off of my Nucleus (so the current back-ups from the last day or two I have on my external drive as connected to my Nucleus will probably reflect any corruption that has made its way into the database?). I did also save a copy of the internal storage flle from my Nucleus on another drive - not sure if this is of any use as a back-up from which to seek to address any corruption?

Am going to leave my firewall off for the time being but will probably turn back on at end of day – including after trying to figure out that firewall exception piece you shared.


![2022-08-17 (1)|690x269](upload://lnbpS0bJ7RLZUBSQbu7eXIbWeoq.jpeg) ![2022-08-17|690x269](upload://gqP3qgnEYCcrFTDVituDbU4IG40.jpeg)

Hi @Greg_Harding,

We’ve taken a look at the most recent diagnostics from your device, and, confirming your screenshots, it appears there are errors attempting to mount the WD My Cloud that you’ve set as a backup location.

Note that the WD My Cloud is not a full-featured NAS device, so when adding via network share you’ll want to double check that the IP address you’re using is the My Cloud IP address and then configure the drive for SMB.

The IP address you’re using, if from the router, might not be the actual IP address of the My Cloud drive. If you don’t know your My Cloud IP address, you can find it in your My Cloud dashboard. You’ll need to create a folder within the top level of the My Cloud that Roon can access for backups.

So, rather than the format you’ve been using with the IP address you found on the router, try something like the following in the Add Network Share page:

  1. smb://ip address/share/folder

Where the IP address is from the My Cloud dashboard and the share/folder is your desired Roon backup location.

So for example, it might look like this:

  1. smb://192.168.1.xx.xx/sharedmusic/Roon

Sorry for the delay in getting back to you, and please let me know if we can clarify these steps on our end. Please also review our steps in this article, as we have a dedicated section for the My Cloud device as a NAS: