Accessing the music folder on my PC

Core Machine (Operating system/System info/Roon build number)

Intel NUC8i5BEH
Version 1.0 Build 227

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Novafidelity X40 connected by USB
Denon AVR-X7200WA

Description Of Issue

I am having trouble getting Roon to see to music folder stored on my PC. It doesn’t automatically find the folder so have tried adding it in ‘add some music’ and ‘add network share’ but it still won’t find it. Please can anyone advise what I might be doing wrong?

Have you first shared the folder in Windows on your PC? See here:

1 Like

Many thanks for your quick reply. No I hadn’t done this so have just gone through that process and successfully shared the folder. I’ve gone back into Roon and put the correct path in and it starts ‘adding’ but then I just get an Unexpected Error message!

Unexpected Error is usually a permissions issue, I think. You have added a username and password that is the same as used to share the folder?

and what did you put in as the Network file address?

See here:

I have have this as the file address which is the stated network path:


I have it set so there is no password protection so have left the username and password fields empty.

That’s not the correct format of the Network address. It should be:


1 Like

I’ve been trying, unsuccessfully, for hours to set up a backup option on my Windows 10 PC (to provide an additional backup location to Dropbox (as Roon advises). NOTE: my Core is on my ZenMini (NOT on my PC); maybe this is the root of my problem?. I have shared my ‪C:\Users\geoff\Music folder according to the procedure pointed to above, and entered the network address in the format suggested but still get the red error box. If someone can provide an idiot’s guide with step-by-step instructions to successfully complete this exercise, I (and others) will be eternally grateful.

It would be helpful if you could show a screenshot of the “Add Network Share” screen showing the Network path, the username, and the precise error message…


The Username I have used is the one that appears when I boot up the PC. I’ve tried entering my bootup PIN as a Password but get same error message.

Two things:

  • I’m fairly sure that that form of Username will not work.
  • If you mean your Windows PIN, then this won’t work either.

What you need is the username that is used by Windows internally and your password, not your PIN.

The internal username is usually the name of the username folder at C:\Users\username. So for example, even though I use my Microsoft Account to sign in, my User folder is at C:\Users\gcoup, so I can use gcoup as the username + my password in the Roon “Add network share” screen.

Thanks for pointing me in the right direction though I still had problems before I got there in the end. I changed my Username to “geoff” as in C:\Users\geoff\Music. I don’t have an internal Windows password since I chose the PIN option for sign in when I set up Windows 10. So I tried my Microsoft account password. This didn’t work either so I changed my MS account password to eliminate special characters (I think I read somewhere that Roon doesn’t like them?) but that made no difference even after re-booting. So I created an internal Windows 10 password and used that. Still no joy so I changed my username to \DESKTOP-QK9H9Q5\Users\geoff\Music and BINGO, it created a Location named \DESKTOP-QK9H9Q5\Users in addition to Dropbox. I chose this new location for back up and it showed me the folder hierarchy under Users. I navigated down to the geoff\Music folder and chose the RoonBackups folder (which I had created as a shared folder some time ago, fortunately). I made my first successful back-up!!!

I’m not quite sure what you did there… But it seems as though you have got it working.

An alternative that I sometimes suggest to those who are comfortable with the administration of Windows is actually to create a new local Windows account for Roon (username roon + a password) and add its permissions to the root folder that you want to share over the network to a Roon Core…

Geoff, many thanks for your help.

Hey @Mark_Redler,

Sorry to hear about the trouble with using a network share in Roon - did @Geoff_Coupe’s suggestion help? Were you able to access the music folder on your PC?

As for @Geoff_Bishop, I’m thrilled this thread proved helpful to you too.

A big thank you to @Geoff_Coupe for the valuable help :pray:

Hi Rebeka. I changed the path as suggested but this didn’t work either and I am still unable to access my Novafidelity X40 as well but I have an Innuos Zen on order so am hoping this will be a better solution and will work more seamlessly with Roon.

So you didn’t succeed in connecting to your PC?

I note that you said:

I have it set so there is no password protection so have left the username and password fields empty.

Could you explain how you did this? As far as I am aware, Windows 10 will always insist on having a username added to the permissions of a folder share. And Windows 10 will also always insist on a username object having a password as well.

The computer has a username but no password to log in to it. I will check the folder share etc when I get a minute to see if there is a username and password.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.