hangs when trying to connect to log in to Roon Server Linux VM built using the Easy Installer script

Roon Core Machine

Linux 22.04 Server VM guest (4 GB RAM, 128 GB HD) running on Proxmox Hypervisor host on NUC 12 i7-1260P hardware.

Networking Gear & Setup Details

No VPN, Ubiquiti ERX Router with Unifi switches all wired.

Connected Audio Devices

Devices tried: Apple iPad Pro (MPF02B/A) and iPhone 12 (MGJH3B/A) running ROON IOS app and also Linux PopOS 2204 desktop with ROON bridge installed.

Number of Tracks in Library

No library yet as I have not successfully got that far.

Description of Issue

I have installed ROON Server x64 in to the VM using the ‘Easy Installer’ script as per the ‘Installing Roon on Linux’ instructions in your help pages. The install reported as successful when the script completed showing ‘All Done! RoonServer should be running on your machine now.’ . At an OS level I can connect to the Linux VM from other machines on the network (i.e. I can ping the roon server and SSH in to it).

I then installed the Roon IOS app on my iPad. It prompts me to choose my Roon Core and shows me a ‘connect’ button next to my Roon Server VM named ‘roon-dev’ (there is also a green circle and the word ‘Ready’ next to it). After I click the purple ‘connect’ button it prompts me to Login to my Roon account. I enter my Email and Password credentials at the Welcome page, click ‘Sign-in’ and then I just get a spinning circle within the sign in button.

I know my web account credentials are valid as I can sign in to the Roon internet website successfully however I am not sure if the IOS app is trying to sign me in to my Roon server or if it is trying to authenticate me via the web first?

I am new to Roon and so it is all a bit confusing. Please can anyone suggest some pointers to help me focus in on exactly where the issue lies?

UPDATE: I managed to find a workaround by installing the Roon app on a MacBook Pro. After the initial login screen (i.e where it hung using the IOS and Linux remote apps) I was prompted with a second login page with a message asking me to “confirm that the app I am using was downloaded from the Roon site’ (see attached screenshot) and to login again. When I re-entered my credentials on this second page the authentication completed and I could successfully connect to the Roon Core server. I then tried using the IOS and Linux Roon remote apps again and this time I was not prompted for credentials, they both connected straight away.

I suspect there was an issue displaying the second login page in the IOS and Linux app and the client was waiting for confirmation from a page I could not see?. Perhaps the page was blocked by my clients? Maybe the clients thought it was an Ad? Anyhow, hopefully this will help someone else if they have a similar issue.

This is the second login prompt I saw in the MacOS Roon remote app…

That has also happened to me, when I first tried to set my Server up. I re-tried it a few minutes later and it worked. But there has to be some kind of issue.

Edit: And of Course: Welcome to the Community!

UPDATE 2: The above workaround does not work for the Roon Arc app on IOS. Unfortunately the login process still hangs and so means Roon Arc is unusable.

I whitelisted ‘’, ‘’, ‘’, and ‘’ in my IOS ad / popup blocker program ‘1Blocker’ and allowed popups in Firefox for IOS but this did not help. Next I turned off the ‘Block Popups’ and ‘Content Blockers’ in ‘Settings > Safari’ on IOS and this seemed to work.
Once I entered my credentials again in the ‘’ page (which was now visible!) then I was authenticated successfully and logged in the the Roon ARC app.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.