Add Network Storage will not recognize NAS Hostname-Synology

I had a perfectly working Roon installation using a Sonictransporter with SSD to run Core and a Synology DS412+ NAS for media storage. The SSD died and as a result I had to do a new install and restore the Roon database. I went to add back the network storage location but Roon no longer recognizes my NAS by its hostname “Music_NAS”. I get a message that it is unable to connect to the host. However, if I use the IP address, it connects just fine. I prefer to not use the IP address as it is dynamically assigned on my home network.

During the time that the Sonictransporter was having its SSD being replaced, I did an update of the Synology DSM to 6.2.1. Is it possible that there is a setting that needs to be changed in DSM?

The NAS is visible on my network and on my iMac through Finder; no issues at all. The files load into Roon when I use the IP address. Yes, I’m being very careful to type the hostname in perfectly- no extra spaces; proper upper/lower case; etc. The fact that the IP address works shows that the login and password are correct. The issue is that the hostname is not recognized. I even went into the NAS and changed the hostname and tried that- no luck.

Any ideas?


Easy way out is to assign a fixed IP to the NAS; saves you some troubleshooting time. Harder way would be to check the file services on the NAS and the Sonictransporter, both need to be capable of SMB1; I know that for a Mac running Core Windows File Sharing needs to be on but not sure for Sonictransporter - maybe this is related (go down to the part where they mention a SMB loading bug):

As I said, if it was me I’d just give the NAS a fixed IP and be done with it. Nevertheless, good luck.

In my experience, the protocol that provides local server names does not work reliably between Synology and Linux boxes. Fixed IP, as @Jose_R_Nieves says, is your friend.

Try using [NASNAME].local instead of just [NASNAME]. That’s what I do with my CentOS-based RoonServer accessing my Synology, and resolution has always been reliable.

1 Like

This is a top tip and sorted out my problem that none of the other resources here or in knowledge base succeeded with.
Thank you

Thanks all. In the end, the best advice is certainly to set a static IP for a NAS. Luckily, I use an EERO network and it makes it amazingly easily to “reserve” the IP address that any device is using for that device right from the EERO app, supposedly effectively creating a static IP. So I’ve tried it and we’ll see how its orks. Thanks for the help.

Adding “.local” to my NAS’s name seems to have worked for me. It’s weird: I had been accessing the NAS for a couple of years with just the name, no “.local”. This morning, after running an update, that no longer worked. I tried all kinds of things. IP address worked, but I didn’t want to rely on that. Hopefully, the “[NAS_NAME].local” won’t let me down. Thanks, @cwichura!