After recent update Roon stops playing randomly on Blue Pulse Mini 2i and Rookie (wifi)

Roon 1.7 (build 537) running on rock core.


Hi after one the recent 1.7 release my Blue Pulse Mini 2i running on wifi (great signal) and my ropieee will suddenly stop playing. At first I thought that I was having a wifi problem but when I use the Blueos app it works fine. The problem does not occur on my wired endpoints.




Description Of Issue


Hello @Jorge_Espinosa,

What is your network setup like? Can you list the model/manufacturer of your networking gear?
If you temporarily connect your zones via Ethernet, do they then work as expected?

Router is Asus AC3100 running firmware 2.178 (latest). The ethernet connections work fine . This only happens with the wireless connections (Blue speaker and Rooopie) and only in the last couple of months after the 1.7 upgrade. The Blue app on the same wireless network to the Blue speaker has no issue.

Hi @Jorge_Espinosa,

Since you are using an ASUS router here, have you made sure to enable multicast routing as per our Networking Best Practices Guide?

If you temporarily connect either of the problematic WiFi endpoints via Ethernet, do you still experience the same issue?

Does the issue only happen on certain types of content such as only high-res or MQA?

So I enabled Multicast but no change. I played cd quality recording on Blue speaker using Blueos app. Played over an hour no problem. Stopped after 15 min with Roon (device disappears sometimes for a few seconds and reappears on list of devices). Listened to CD quality recrding on Rooopie yesterday afternoon. Played fine for about 45 min then started stopping every few minutes. Don’t understand since wired connections are rock solid.

Hi @Jorge_Espinosa,

Thanks for testing this further. Have you by any chance run this test?

I suspect you might have some WiFi interference in your environment, I would do the Ethernet test and if that resolves it, you might want to look into changing the WiFi band channels to something less populated.

Why does it only happen with Roon and not with the Blue app? Is there anything different about how Roon likes to an endpoint? Could Roon be more sensitive to a small lack of connection? Is there anything in the recent upgrades that would have affected things?

Hi @Jorge_Espinosa,

Roon works in a different way than the BluOS app, in the sense that all the audio processing is done on the Core first and then sent to the endpoint, rather than BluOS natively reaching out to the streaming services/accessing the media files directly.

This kind of setup is done for a number of reasons mentioned in our Architecture documentation and it is the way that Roon currently works, with a Core + Endpoint setup.

If there are points where the connection is not great and the endpoints are dropping packets due to interference on WiFi, then this can certainly cause issues in playback.

As the temporary test I mentioned, could you try connecting the problematic endpoint via Ethernet instead of WiFi to verify if Ethernet works as expected? At least then we will know to better focus our efforts on the Core -> Endpoint WiFi connection.

Hi. This only connects wireless. One is a Poly that I cannot connect on ethernet. Another is my laptop which I did and worked fine. The last is my Bluesound speaker which worked fine on ethernet. The problem only arises on all three when connected by wifi. I also switched from Roon to Qobuz this afternoon after several drops to see if the problem was wifi interference. Qobuz streamed fine, no disconnects. I also switched the routers (Asus to Netgear) and no difference. It has been a couple of months now since I have been able to stream Roon wirelessly. :frowning:

Hi @Jorge_Espinosa,

Can you reproduce the issue on your Ropieee, note the exact local time + date + track of the failure and send me a copy of your ROCK logs by using these instructions? I can take a look to see if there’s any further clues there.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.