After update my iOS app cannot find Core

Good morning,

I updated last week and now my remotes cannot find my Core. I’m running the following:

Core - Salk Stream Gen 3
Control - Apple iOS for iPhone + iPad

My core is accessible on my network but the app just says it s looking for remote libraries. I’ve even given it the IP address and it just keeps looking.

Any help would be appreciated. Thanks Brandon

Have you re booted the apps? May be worth re booting the core.

Thanks for the report @Brandon_Gustafson, the insight is appreciated. Sorry to hear of the troubles.

To add to the advice given by @Chrislayeruk (:thumbsup:) I would also try rebooting any relevant networking hardware (i.e router, switches, etc) as well the core and remotes. Furthermore, since noticing this issue have you tried reinstalling the application on the iPhone and iPad?


Thanks @Eric
I’ve rebooted the Core and deleted and reinstalled the Apps as well as reset my router and access point. I’m still getting the same “looking for remote libraries in the app”, but can see the core and its contents from my computer. Let me know if there are other measures I can take?


Hi @Brandon_Gustafson ---- Thank you for touching base with me and providing the requested feedback, both are very appreciated!

Moving forward, I would like to see if we can trigger a change in behavior with the mentioned remote devices by having you perform 2 troubleshooting exercises (please see below). Additionally, may I also ask you to please confirm that you do not have any active firewalls / antivirus applications currently running or a VPN configured on your setup? I am curious if anything could be blocking the remotes from communicating with the core machine.

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a iphone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote

All the best to you and your family during the new year!

Thanks for the suggestions @Eric but I’m still getting the same result of “looking for remote libraries” following the instructions above. Is it possible in the update that the apps are no longer able to recognize the Roon software? As I mentioned earlier, I can access the files through my blue sound device and can communicate with it though its manufacturers website to verify the core is working properly. Have a happy new year and I’ll try and fiddle with it more next week.


Hi Brandon.

The same happens for me sometimes.
I just restore from my latest scheduled backup an then it’s back up and running.

Settings/Backups/Find Backups


Hi @Brandon_Gustafson ----- Thank you for touching base with me and providing the results of the proposed troubleshooting exercises. The update is very appreciated!

Moving forward, I want to be certain that all your devices are up to date and with this in mind can you verify for me that the core machine (i.e Salk Stream Gen 3) is also running the same build as the remote devices (i.e 'build 249")?