After upgrade to 1.8 my networked audio (Sonos) and video (Panasonic TV) devices disappeared

Core Machine (Operating system/System info/Roon build number)

Roon Core runs on an MacBook Pro 2013, version 1.8 build 756.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 210 (ethernet, works fine), several MacBook Pro (wifi, work fine), several Sonos (One, play3, play5, connected via Sonos Boost(ethernet)), iPads and iPhones (work fine, wifi)

Description Of Issue

Other then the MacBook Pro and the meridian 210 all other devices are gone and can not be found. Before the upgrade everything worked fine. Tried to connect the core via wifi, no difference. After reading the posts in the community, I tried several restarts, no difference. What to try next?

Since 1.8, my Sonos still shows up as a device but it won’t play - just keeps saying Roon lost control of this device. Everything else works fine. Tried restarting Roon, NUC, network, Sonos… nothing works.

Have you tried a “factory reset” and re-connection of the Sonos device?

Graeme, thanks for the replay. Tonight I resetted my compete system (includig the Sonos devices). Now they are back in the Roons system. I cannot explain the error or the recovery now, but happy everything works again. Thanks. And so far happy with 1.8!


A close friend of mine is in the IT support business. He always says “if all else fails, BRB (Big Red Button)” Turn it off, turn it on, reset it…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.