Airplay devices (Apple TV and Airport Express) not showing up

Hi @support - I recently transitioned from running Roon on my office PC (Windows 10) to a dedicated Intel NUC server (see details below). The sound quality is enormously improved with the new setup but I’ve encountered one issue with the transition …

  • My 2 Airplay devices are now only showing up in Roon very sporadically.
  • Most of the time they actually are not there, but every once in awhile they pop back in as available zones.
  • When they do show up, it seems to usually be only one device or the other - although occassionally they have both been showing up at the same time
  • I don’t recall having this problem when I was running Roon from my Windows 10 office PC.

For my main system my endpoint is a Sonore microRendu and this always shows up- so that’s good. But as one of the benefits of Roon is being able to play to various zones … I would like to get the Airplay devices back.

Running Roon version 1.3 build 259 64 bit
Windows 2012 Essentials R2 in Minimal Server Mode
Audiophile Optimizer Installed
Intel NUC (NUCi3BNH) w SSD and 8GB RAM
Running music from the SSD and from Tidal
Small library of only 3637 tracks

Hi @Kyle_Fieleke ----- Thank you for the report and sharing your observation(s) with us. The feedback is always appreciated!

Moving forward, may I very kindly ask you to please provide me with the following:

  • While this may seem elementary, since noticing this behavior with your Airplay devices, have you tried power cycling all of your equipment? This would not only include your “Roon setup” but also any networking hardware you are currently implementing as well.

  • Can you please briefly outline your network configuration/topology, as well as providing insight into any networking hardware you are currently using. I want to have a clear of how your devices are communicating and the tools being implemented that make those connections possible.


Thanks Eric!

  • I am using a Netgear Orbi setup with 1 main unit (router) and 1 satellite.
  • The NUC server is connected via ethernet.
  • The 2 airplay devices are connected by wifi.
  • The microRendu is connected to the server by ethernet; I have bridged the 2 ethernet ports together for a ‘direct’ connection between the microRendu and the server, which greatly improves the sound quality.

Per your instructions I powercycled the router. I then also powercycled the 2 airplay devices.

After doing this, 1 of the 2 Airplay devices started showing up (the 2nd one I powercycled) for a few minutes, and then disappeared. Currently only the microRendu is showing up again.

Hi @Kyle_Fieleke — Thank you for touching base with me and providing the requested feedback. Both are appreciated!

Moving forward, can you verify for me if you are able to successfully ping the IP addresses of both of these devices while Roon is in this state (i.e can not see the Apple TV or Airport)?


Hi Eric - just finally got a chance to test this.

At the moment the Apple TV is showing up and the Airport Express is not.

And I can successfully ping both of them from the Roon server.


Hi @Kyle_Fieleke ----- It’s good to hear from you, thank you for touching base with me after giving the requested procedure a go. Very appreciated!

While I understand that you can successfully ping your devices, I am curious. Since noticing this behavior have you tried testing with either the Apple TV or Airport Express hardwired via ethernet? If so what was the experience like?


Hi again - no, I have not tried it hardwired. Both devices are connected to the network by wifi.

Hi @Kyle_Fieleke ----- Thank you for the follow up and confirming that information for me. Appreciated!

Moving forward, can you please use the instructions found here, and send us over a set of Roon logs from the Win10 device hosting your Roon core. I’d like to have our techs take a closer look into this behavior you are experiencing.

Addition: Have you tried factory re-setting the express during your troubleshooting? I had one of the units in my home for a little while and vaguely remember running into some issue with the device that were being felt, even outside of my “audio” usage(s). If memory serves me correctly, a factory re-set resolved the behavior for me.