Airplay distortion

One of my endpoints is a soundbar, and I use Airplay to stream to it. I can use wifi, or I can use a direct ethernet connection, but either way, I will sometimes get a slightly garbled audio quality from the airplay. If I hit pause, wait a second, and then resume, the problem sometimes go away. I will sometimes have to hit pause/resume 5 or 6 times before the sound is acceptable.

1 Like

Same here with airplay.
Problem started a few weeks ago. Before the 339 build, I think with the 334 build, maybe 323.
Nothing changed on my system, that worked flawless more than a year before.

Most of the time problem starts after 10-20 seconds while playing the first song after starting my windows pc with the roon server.
Pausing and waiting a few seconds resolves the problem most of the time. Restarting roon server also solves the problem. And then I can play music for many hours without any problem.
Server log didn’t show anything different from normal playing.

1 Like

Thanks @AE67

Out of interest, what is your Airplay device? Mine is a Yamaha YSP2700

Yamaha R-N602

1 Like

Hello @wintoid & @AE67,

Thank you for your reports, I’d be happy to take a look to see what could be causing the issue here.

Can you please provide more information regarding your Roon Core specs and how your network is setup here? Are you by any chance using Routers that require a bit more setup as the ones listed here?

I would also be curious to know the Signal Path information when this issue occurs, does the processing speed seem to be fairly low at the time?

Please let me know when possible and we can continue from there.


Hi @noris

My Roon Core is running on a Windows 10 virtual machine hosted in HyperV on a Windows Server 2016 machine (i5 7600T with 32GB RAM). I’ve assigned 8 GB RAM to the Roon Core machine.

In terms of network setup, there are 2 floors between the Roon Core and the soundbar. If I’m using all-ethernet, the connection would be like this:

Soundbar ethernet->Netgear GS108 ethernet->Asus AC3200 ethernet->Roon Core ethernet

If I’m using wifi, the connection would be like this:

Soundbar wifi->Asus AC68U wifi->Netgear GS108 ethernet->Asus AC3200 ethernet->Roon Core ethernet

The two wireless routers I have are running completely different SSIDs.

The wifi and ethernet networks each have other endpoints (Squeezebox Boom and Raspberry Pi respectively) which are working fine. It’s only the soundbar which exhibits the problem.

The Signal path looks like this: image

I don’t think my Roon Core really breaks a sweat, it seems to be quite overpowered for my needs. Does that help?

Roon: Version 1.5 (build 339) stable (64bit)
Core: Windows 10 Pro, CPU Intel i5-2500K, RAM 8 GB, Nvidia GForce GTX 560 Ti
Router: Fritzbox Cable Router

Roon plays audio over airplay to a Yamaha RN-602 Stereo Receiver connect with Ethernet

The same completely unchanged system I used for the last 2 years and which worked flawless with Roon, til the current problem starts a few weeks ago.

The signal path looks exactly as anytime. Processing speed not visible (means >100x, if I am remember correct). This time playing a mp3 file from internal HD as error occured. And also first song I want to play. Core was booted ~10 minutes before, so any start process are long finished.

Hello @wintoid & @AE67,

Thank you both for posting your setups here. @AE67 - You are indeed correct, since the processing speed is not visible, then it should not be a processing issue, glad we could at least narrow that down.

A few other questions to help narrow down the cause:

  • Do either of you by any chance own an Apple TV or another Airplay device and can confirm if this issue exists only with the Yamaha devices or is it visible on other Airplay devices?
  • Is this behavior consistent with all types of content (TIDAL and Local Content) or does it seem to just affect one and not the other?
  • Have you performed any firmware updated on the affected devices recently?
  • Is the same behavior displayed even after a reboot of the Roon Core and the affected device?
  • Are Roon & RAATServer listed as exceptions on your Router/Antivirus firewall?
  • If you have the option in your Routers, can you check for a setting called IGMP Proxying and see if enabling that yields any results? I know that the Fritzbox has this setting, but I am not sure if the ASUS Routers would have a similar option.
  • @wintoid - If you temporarily connect the Roon Core to the primary router instead of running it through two routers and a switch, do you still experience this issue?

Please let me know when possible and we can continue from there.



Had to check. Today it was local content.

Yes, but after the first time, the problem occured.

Yes, as discribed before, most times exactly after that. In the first song after starting core and device.


Option is already activ. And I have an ethernet connection, not WiFi.

Tested with Apple TV and the problem doesn’t happen. Only with the Yamaha.

I’ve experienced it with both types.

No recent changes, but everything is up to date

Yes it doesn’t make any difference

I’m not blocking ports internally

I don’t have time at the moment to get too stuck in to this, but will try to come back to it in a week or so.

I did a very brief google on this, and the pfSense page here implies that this is for proxying IGMP traffic between network segments. I’m not a network guru, but surely all my network traffic is inside one segment?

Hello @wintoid & @AE67,

Thank you both for your detailed replies to the issue at hand.

We have tested the issue with other airplay devices we have in-house but this issue seems to only be affecting Yamaha Airplay devices, which we do not currently have in our lab.

I have escalated this case with our hardware team to see if we can acquire any Yamaha airplay devices to reproduce this issue but I cannot comment on a timeline of when or if we will be able to source those, but do know that your reports have reached our team and we are investigating regarding possible causes.

I will be sure to update you both with any progress we make for this case and I appreciate your patience while we investigate further.



Hello @wintoid & @ae67,

After doing some research about the Yamaha devices and AirPlay, I came across this thread describing a very similar set of symptoms to what you both are reporting

Yamaha supposedly sent an older firmware to roll back to which fixed the problem for the user. I would recommend reaching out to Yamaha and inquiring if they would provide the tools to perform the rollback.


1 Like

Just some feedback on this. Yamaha released a firmware update for my soundbar YSP2700 and it seems to have fixed the issue.



1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.