Airplay group loses sync Sonos and Sony AVR

I am having a similar issue. I have a Sony AV receiver with Airplay support, and a Sonos Play:5, which also supports Airplay. I group the 2 zones in Roon. Initially, everything works well, but over time the audio becomes out of sync. I have a DSP parametric EQ setting on each zone. Does anyone have any tips on how to fix this?

OK, that makes sense. But isn’t one of the stated capabilities of Roon to allow Airplay zones to be grouped and played together?

Hi @Louis_Richardson,

Can you reproduce this issue and let me know the exact local time + date in your country when this occurs and the track that you were playing to both Airplay zones?

I’d like to enable diagnostics mode and take a look at the logs from your Roon Core when this issue occurs for any additional clues.

When I have time, I will try to reproduce it, and get back to you.

1 Like

10/18/2019. Time was 0839. The track was “Rock’n Me” by Steve Miller Band. It was a track from Tidal. 4 tracks had played previously before I noticed the 2 zones being out of sync.

Hi @Louis_Richardson,

Thanks for letting me know that timestamp, I have activated diagnostics mode for you account and what this action does is automatically upload a set of logs to our servers for analysis. I can confirm that logs have been received and have been passed to our hardware team for closer inspection, I will let you know once I have more information to share. Thanks!

1 Like

Hello @Louis_Richardson,

I have enabled a diagnostic feature on your account that may help us determine what is causing this behavior you are seeing.

When you get a chance, please restart your Roon client and try to reproduce this behavior again.

Once you have reproduced the issue, please stop playback and close the Roon app as quickly as possible. Once you have closed Roon please create a zip archive of your Roon logs and share them with us using a Dropbox shared link or Firefox Send.

You can find instructions on how to locate your Roon Logs here.

The diagnostic logging may have a slight performance impact on Roon, so once you have uploaded the Roon logs I will be sure to disable the diagnostic flag as quickly as possible and respond in this thread with a go-ahead to once again restart your Roon Core.

-John

Wasn’t sure where to post this. John, I sent you a direct message with the same link, and a little more info. Will wait to hear back. Thanks.

Hello @Louis_Richardson,

Thanks for update. I have disabled the diagnostic flag on your account. Restart your Roon Core for the changes to take affect.

I have forwarded the logs to the QA team for analysis.

-John

1 Like

Hello @Louis_Richardson,

We sincerely apologize for the delay in our response. This ticket required QA testing that coincided with the 1.7 release, and we wanted to ensure that this was properly investigated.

Our current theory is that the Sonos is losing synchronization with the Sony AVR. Would it be possible to group the Sonos Play:5 with the Sony AVR using iTunes on your PC and allowing playback to continue for a few hours?

-John

Thanks for the response. When I have some time, I will download iTunes to my server computer and give it a try.
Do you just want to know if I lose the sync when I use iTunes?

OK. I did this today.I played a few hours of music to the Sony AVR and the Sonos Play:5 through iTunes

Toward the beginning, the Sonos Play:5 stopped playing. I checked i Tunes, and saw that it was no longer selected as an endpoint. So, I reset it. Both played in sync for about a half hour, and then became out of sync. However, after a couple more songs had played, they were in sync again. They remained in sync for the remaining (roughly) 1 1/2 hours.

Hello @Louis_Richardson,

If the Sonos are getting out of sync when using iTunes, this indicates that the issue is not Roon-specific. While is an interesting data point that the devices are able to resynchronize after they fall out of alignment with iTunes, this behavior is still indicative of an issue with the AirPlay implementation on either device, and thus we cannot guarantee that this configuration will work with Roon.

I’m going to leave this ticket with the open status in our tracking system. If we start to receive other reports of this behavior occurring with other AirPlay devices, we will be sure to update you on the status of any further investigations and changes in this area.

-John