Airplay Grouped Devices Out of Sync

Core Machine (Operating system/System info/Roon build number)

Mac Mini (2018) running Mac OS 10.15.7, Roon Version 1.7 (build 667)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Arris BGW210 Gateway/Router, Apple TV 4K connected via ethernet, Sonos One SLs connected over WiFi via Ubiquiti Unifi AC Lite access point.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos SL (Kitchen) - Wireless
Sonos SL (Dining Room) - Wireless
Apple TV 4K (Living Room) - Connected to Anthem AVM-60 via HDMI

Audio stream is FLAC 96kHz 24bit via Qobuz.

Description Of Issue

When grouping these three “Airplay” devices in Roon, the Apple TV plays out of sync relative to the two Sonos speakers. The sound is immediately out of sync and remains out of sync even if I pause and restart the audio.

There is no option to adjust a “Zone Grouping Delay” or “Clock Master Priority” in the settings for the Apple TV nor the Sonos speakers.
When grouping just the two Sonos speakers together, they remain in sync.

Is there any way to get Airplay devices to play in sync via Roon?

Hi @Anil_Panigrahi,

If you connect the Sonos via Ethernet as well are they all in sync?

Dylan above will definitely help you out but in the meantime it might be worth to try this:

From what you describe the apple tv zone is the out of sync (I assume the Sonos SLs play in sync). What usually happens is that AV receivers introduce a time delay to the audio due to DSP / conversions etc. Apple introduced the above option to try and adjust for this. This was of course aimed at Airplay 2 syncing so no guarantee that it will affect Roon’s airplay playback. It is not exactly like Roon’s manual sync adjustment but rather a bit more automated (using your iPhone’s mic).
It is a long shot but worth a try just in case it helps.

Thank you for this excellent suggestion! I tried it, but unfortunately the sound still remains out of sync from the Apple TV relative to the Sonos speakers.

1 Like

I do not have the capability to connect the Sonos via ethernet, however, I connected the AppleTV via WiFi so that all the devices were connected via WiFi. The audio is still out of sync coming from the AppleTV, but the two Sonos speakers are in sync.

Of note, when using DTS Play-Fi with a similar configuration in the same locations (2 Play-Fi compatible speakers connected to Wireless and the Anthem AVM-60 connected via ethernet) all audio is in sync.

Please let me know if there is anything else I can try to get Roon multiroom playback via Airplay to synchronize.


In my opinion it does not matter for the sync of Airplay 2-speakers, if these are connected via WiFi or ethernet.

Maybe this will solve your Problem:

Chose an iOS-device as an roon-endpoint (iOS 11.4 or later) and use Airplay 2 from this device to stream to your speakers and apple tv.

This works fine in my setup (4 Airplay 2-devices). The only Problem is, that you can‘t control your roon-stream from other roon-control-apps.

I hope there would be an optimization from roon itself.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.