AirPlay Not Working for My System

Core Machine (Operating system/System info/Roon build number)

2019 27" 5K iMac, 40GB memory, Big Sur (11.2.1), Roon version 1.8 (build 756) (day 3 of trial), machine is always on.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Orbi RBR50 & RBS50 router and satellite, updated to latest firmware, iMac is hardwired to network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i - analog audio out to Anthem 520, hardwired to network through local unmanaged switch
HomePod - WiFi, using reserved IP address
Sonos Play5 - WiFi, using reserved IP address
Devices have all been enabled through Roon Settings

Description Of Issue

If I try to play through my HomePod or Sonos or Bluesound Node via Airplay it doesn’t work, no music comes out. I get the same results regardless of what device (iMac, iPad or iPhone) I use as the controller.

I’m a new user so hopefully I’m just doing some step wrong. I select the HomePod on the bottom right corner of the Roon controller, select a song, then hit play, usually nothing happens and play symbol immediately reverts to the triangular play symbol, if I hit it a second time it will stay on the pause symbol and I can click on the coloured dot and see the signal path which ends with “AudioAccessory1,1 Airplay streaming”. However there is no sound coming out of the HomePod and the song time counter does not increase. If I click on the HomePod icon I see my list of Audio devices with the jumping bars next to HomePod. I get the same results if I try to AirPlay to the Sonos Play5 or Node except with the Sonos and Node it just stays on the initial paused state (no coloured dot, no jumping bars).

Airplay is otherwise working fine. I can Airplay music playing through the Apple Music or the Tidal apps on my iPad via Airplay to the HomePod or Sonos and it works fine.

When I send music from the Roon Controller to the Sonos Play5 via Sonos Streaming it works fine. I have no problem when I send the music to the Node via the Roon Ready direct path.

I have checked to ensure all devices are on latest firmware and have rebooted my router a couple of times.

1 Like

Hi @Scott_Leslie1

Do you have a passcode enabled for Airplay on the HomePod? If not can you try enabling this?

Can you share a screenshot of Device Setup in Roon for the HomePod as well?


Hi & thanks for getting back to me.

No I had not enabled a passcode for Airplay. In order to do so I went into the Home app on my iPad and changed the “Allow Speaker & TV Access” from “Only People Sharing This Home” to “Anyone On the same Network” (I don’t recall setting this, I think Anyone on the same Network is the default, but needed to change it to enable setting a password) and tried to Airplay Roon to my HomePod and it worked. Having made that change I can now Airplay to my HomePod. I didn’t go as far as setting a password.

Given that it works now I imagine you don’t need the screenshot but just in case it helps here it is.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.