Airplay now not working when switching to ROCK

Roon Core Machine

ROCK v2.0 build 1128 running on NUC 10 i3 with 8GB RAM and 128GB SSD

Networking Gear & Setup Details

NUC connected via ethernet to ASUS RT-AX86U no VPN

Connected Audio Devices

Onkyo TX-NR5100 - ethernet and HDMI, Onkyo TX-NR7100 - ethernet and HDMI,Onkyo TX-NR1007 via Apple TV 4k -ethernet and HDMI, along with 2 other Apple TV 4k using TV as audio - ethernet and HDMI

Number of Tracks in Library

3,419 Tracks

Description of Issue

I am a fairly new user and initially installed Roon on Dell XPS desktop as CORE. I had all the audio devices listed above with no issues. I decided to go an extra step I purchased a NUC - above - and installed ROCK after backing up my database on the desktop and restored on ROCK. I have recycled my router and Spectrum modem multiple times in order to try to resolve my new issue of my Apple TV’s inability to play using roon. I have disabled the Apple TV’s in Settings >> Audio and re-enabled, Airply code generated and entered but nothing. I hope you can resolve as I have now committed $$s to the roon environment.

Please try changing your ATV Airplay settings, and require a password.

A) Open settings on the AppleTV
B) Navigate to AirPlay and Homekit
C) Tap on “Allow Access”
D) Set “Allow Access” to “Anyone on the Same Network”
E) Set Require Password to “On” and create a password
D) Back out of the menu to the home screen
F) Try to enable the zone in Roon. It should ask you for the password


That seems to have resolved the problem - thanks. I suggest including this somewhere on AppleTV setup.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.