AirPlay on RoPieeeXL

My iPhone and iPad don’t see my RoPieeeXL device when trying to use AirPlay. I am obviously doing something wrong. This is not a big deal because I have other ways to use Apple Music and I really never use Apple Music, but I would like to get this working.

I have RoPieeeXL loaded on a Raspberry Pi 4 and am using a Dragonfly Cobalt USB DAC and Sony headphones. Everything is connected using ethernet, but I have also tried WIFI.

Does anyone have any ideas how to get my IOS devices to see RoPIeeeXL on the Raspberry PI 4? Thanks.

@Jim_F can you access the RoPieeeXL web admin via either iOS device? Just want to confirm they’re on the same local network. Having them all on the same wifi might also help at this point, even if just temporary (as the iOS devices won’t be on ethernet).

Also, just in case, here’s the Apple page showing how to connect an AirPlay speaker via iOS:

Look for AirPlay audio from your iPhone, iPad, or iPod touch

1 Like

Thanks Mark. The “How to AirPlay audio” instructions solved the issue.

Now that Mark helped me figure this out, AirPlay from my iPhone and iPad to Raspberry Pi 4 running RoPieeeXL works very well with Apple Music.

1 Like

I just tried this again playing Apple Music on my iPhone and using AirPlay to my Raspberry Pi 4 running RoPieeeXL and out to Meridian Prime and headphones. Everything works as it should and sounds great. I can control volume with iPhone and Meridian Prime. Normally the iPhone is on max and volume control is with Meridian Prime.

RoPieeeXL is a great product.

1 Like

@Jim_F, good to hear it’s working for you! I’m considering getting an RPi4 and loading RoPieee XL onto it now. Do you know if if supports AirPlay 2 or just AirPlay 1? I’m hoping to use it for a multi-room audio setup using Airplay 2 speakers.

It’s not official Apple certified Airplay.

It’s an Airplay1 emulator (Shairport).

1 Like

Good to know! I’m finding some conflicting posts on whether or not Shairport supports multi-room audio in the style of Airplay 2. Here it makes it seems like it is possible.

Personally, for a smooth and reliable and headache free Airplay experience I’ve given up on Shairport and just use official Airplay2 gear now (Bluesound Node 2i and soon the new KEF LS50W 2).

I’m not exactly sure how that works. I don’t use Airplay with Roon. I can use Airplay from my iPhone to RPi4 headphone rig, but that’s all I know. I guess if you had reason to use Airplay with Roon, you would set it up as a Roon endpoint using Shairport.

1 Like

Pretty sure it’s using shairport-sync, which is a fork of shairport. As was said, it’s a reverse engineered unofficial implementation of the airplay protocol. In my experience it has worked flawlessly for my needs.

I’ve used it as part of a multi-room multiple zone selected playback in iTunes. But I’ve never tried using it when syncing really matters.

Hi all - VERY new here. I have a macpro in my office with huge iTunes library, and have a Qobuz account. I have been streaming using Apple Airport units for years, but would like to do HiRes files. I got a raspberry Pi 4B in a fan case, assembled it today, and have an SMSL M100 DAC tied to it to feed my audio system. Installed RoPieeeXL today, then updated to the 2.648 beta. It’s all connected via wifi now. I can see the RPi4-XL as an endpoint (speaker) in the system, and I’ve tried using iTunes and Qobuz. They see the RPi4 - and it seems like all is good, but - there is no audio out to the DAC. (USB bus). The Pi has 4 USB ports - does it matter which one I use?

Not sure what changed overnight - but - I switched the DAC USB cable to the lower left USB2 port on the RPi4, renamed the endpoint without a dash, and power cycled as I got a cuppa this morning. When I came back, I could see “RoPi4XL” as an airplay device, so I streamed iTunes to it and that worked. Then I started the QoBuz app on my iPhone and played a 96k Norah Jones song - that worked - but, the DAC displays 44k - maybe that’s the best I will get using WiFi? It’s a 1950 house and will be near-impossible to run Cat5 ethernet to my stereo … but at least I have good audio through the Pi4!
Next thing is to get a higher res feed to RoPi4! Airplay 2 perhaps?

Your insurance company would like to have a word…


1 Like

From memory, I think that Ropieee needs externally powered DACs to be powered up before Ropieee is, otherwise they are not detected.

That is not correct. USB DAC’s must be powered up before the unit becomes visible in Roon, but there’s no need to start it before RoPieee.

1 Like

My mistake!

No worries! Just wanted to be clear to users. Aim is to make it as easy as possible for users :grin:

It is indeed. I have had a year of trouble free operation with one of my five endpoints, with RoPieeeXL and will convert the other four (from DietPi) by the end of the year. Will send you a donation when I do so. :grinning:

1 Like

Agreed - then again, all the cube taps are for low power wall warts - for my old Audio Alchemy DAC, for an auto Digital Radio tuner, the Denon TT and its preamp are always off, as is the Carver Tuner. The only thing actually ON is the Acurus RL11 Preamp & the Carver amp, and now the RoPi4, and the SMSL M100 DAC.
So, RoPiEEEXL is looking at the wifi from my Airport Extreme, which functions as router for the whole house. I feed USB out of that into the USB input port on the SMSL DAC - but all I am getting is 44k on the DAC, even when feeding a hiRes stream from Qobuz.