Airplay problem with Roon from Mac to Roksan Attessa

Roon Core Machine

Mac Mini M1 8GB OS 12.1

Networking Gear & Setup Details

Ethernet netgear switches

Connected Audio Devices

Roksan Attessa Streaming Amp using Airplay. Amp connected using Ethernet

Number of Tracks in Library

14000

Description of Issue

Roksan Attessa amp not yet Roon certified so using Airplay to connect to Attessa. Using Roon on iPhone to select music to play.

Every track has skipped audio with drop outs or clicks or noises on it.

Using locally stored tracks or tracks from Tidal or Qobuz.

If I Airplay direct to the Attessa from my iPhone using Tidal or Qobuz app the track plays perfectly

If I use the Blusound app all tracks play perfectly

Not sure how to diagnose problem with Roon.

I am new to Roon and really like what I see but it’s no good if the sound quality is seriously compromised!

Thanks in advance

Kevin

I have tried using AirPlay direct from the Mac mini to the Attessa and that plays fine, so there’s something about Roon that’s causing the dropouts, clicks and pops…

I’ve had a look in the RAAT server logs and am getting endless entries like this:

01/06 12:19:31 Warn: [raatmanager/mac] failed to translate data source
01/06 12:19:31 Trace: [raatmanager/mac] LOST 410CE808-0000-0000-1619-010380472878
01/06 12:19:31 Trace: [jsonserver] [127.0.0.1:58466] SENT [1] [nonfinal] {"status": "DeviceRemoved", "device": {"device_id": "410CE808-0000-0000-1619-010380472878", "type": "coreaudio", "name": "PHL BDM3275", "vendor": "PHL", "config": {"external_config": {}, "volume": {"devic
01/06 12:19:32 Trace: [raatmanager/mac] FOUND id=410CE808-0000-0000-1619-010380472878 usb_id=
01/06 12:19:32 Trace: [raatmanager/mac]       vendor=PHL                            name=PHL BDM3275                    outname=                    
01/06 12:19:32 Warn: [raatmanager/mac] failed to translate data source
01/06 12:19:32 Trace: [raatmanager] [PHL BDM3275] loaded config from /Users/xxxxxxx/Library/RAATServer/Settings/device_8fa3398742fd9f2f9ed2e96524c604e6.json
01/06 12:19:32 Trace: [jsonserver] [127.0.0.1:58466] SENT [1] [nonfinal] {"status": "DeviceAdded", "device": {"device_id": "410CE808-0000-0000-1619-010380472878", "type": "coreaudio", "name": "PHL BDM3275", "vendor": "PHL", "config": {"external_config": {}, "volume": {"device"
01/06 12:19:38 Warn: [raatmanager/mac] failed to translate data source
01/06 12:19:38 Trace: [raatmanager/mac] LOST 410CE808-0000-0000-1619-010380472878
01/06 12:19:38 Trace: [jsonserver] [127.0.0.1:58466] SENT [1] [nonfinal] {"status": "DeviceRemoved", "device": {"device_id": "410CE808-0000-0000-1619-010380472878", "type": "coreaudio", "name": "PHL BDM3275", "vendor": "PHL", "config": {"external_config": {}, "volume": {"devic
01/06 12:19:39 Trace: [raatmanager/mac] FOUND id=410CE808-0000-0000-1619-010380472878 usb_id=

They are happening every couple of seconds - could this be the problem? The device PHL BDM3275 is my monitor which is connected via HDMI. It’s not “active” as a device in Roon.

Hi @Kevin_Morgan ,

Thanks for reaching out! Do you by any chance have any other Airplay zones you can try to stream to from Roon? Do those work without issue?

Have tried it with a different Airplay endpoint (Marantz NR1607) and it sounds fine. So something weird going on between Roon and the Attessa then?

It’s weird because if I Airplay direct to the Attessa it’s absolutely fine, it’s only going via Roon that I get the problem

1 Like

Hi @Kevin_Morgan ,

That is an interesting discovery!

What happens if you try to play to your iPhone as a Roon Zone and then use Airplay from the iPhone to send the stream to your Roksan (as opposed to directly from your Core). Is there a change in behavior then?