Album Art Disappears

Core Machine (Operating system/System info/Roon build number)

Windows 10/Core 1.6(Build 416) stable (64bit)

Description Of Issue

Album art keeps disappearing! If I restart the core server, restart the remote, perform a backup; all of my album art is gone. The only way I can get it to come back is to restore a backup; which is kind of a pain to have to do daily!

It appears to only be on the Roon Remote on my desktop. When I browse on my iPad or iPhone, all the album art appears!

Hello @Jacob_Poye,

Is your remote installed on the same machine as a core ? If not, can you give us more info about the machine where remote is installed: OS, hardware, how it is connected to the network etc.

Can you also describe your core machine - hardware, how it is connected to the network etc.


Hi Vova!

In this instance, yes the remote that is losing album art is in fact installed on the same machine as the core server. More specifically, it is two separate installations. The Core Server runs as a service and was installed first; then the remote installed which accesses the core on the same machine.

Core Machine is my primary desktop. i9-9900k, m2 nvme drives, rtx 2080Ti graphics card, networking is LAN to my router/switch; no wireless.

Let me know if you would like any more specifics!


Hi @Jacob_Poye,

You mentioned that this behavior only occurs for the Roon Remote running on the same Core. Is the behavior the same if you try to disconnect the remote and reconnect it via Roon Settings -> General? Have you tried reinstalling the Roon Remote app yet? I would also give this a try (after making sure that you have a Backup of your current database).

Hi Noris; yes I have tried re-installing the Roon Remote with the same problem. Also, disconnecting and reconnecting to the core doesn’t fix it either.

Hi @Jacob_Poye,

Thanks for confirming that disconnecting and re-connecting did not resolve the issue and for trying a regular install. Next, I wonder if setting your old Roon Remote installation aside will help with the issue. To do so you can try the following instructions:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Connect Roon as a Remote to the RoonServer install

Can you let me know if that changes anything?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.