Album Art-Work upload speed Tidal vs Roon

There must be a parameter that I don’t have right. In Tidal, a page of albums loads in seconds, in Roon remote it takes 5 seconds per album in the Album choice of the main menu. I use the Roon Nucleus connected to a tested 30 Meg download speed via ethernet. Occasionally – Roon loads just as fast. Any suggestions, excepting returning to college for a degree in CS, will be appreciated. Bill

Hi @William_Utz ---- Thank you for the report and sharing this observation you have made with us, the feedback is appreciated!

Moving forward, I want to make sure that I am conceptualizing this behavior you are experiencing correctly. Based on your report it sounds like you are experiencing the following:

When using the TIDAL application from a device that is also acting as a Roon remote the TIDAL application is loading albums quickly but when using Roon albums are taking longer to load in the display. Is this indeed the case? Please do correct me if I am wrong :innocent:

Data gathering:

  • Do you experience this behavior with ALL of your Roon remotes? Some? Just one?

    • Please provide the make and model of the remote device(s) you are noticing this behavior with.
  • What screens in Roon are you noticing this “delay” on? Are there areas of the application that are populating quicker than others?

  • Have you tried not only rebooting the Nucleus but also the affected remotes as well?

  • Have you tried reinstalling the application on the affected remotes?



yes this occurs on my HP laptop serving as the remote connected wirelessly which I believe has an Intel HD graphics card. This is my only remote.

The area of problem is I have 180 Tidal albums that are very slow to image and will hold up any commands until there is a gap in information transfer. I have wondered if Cortana is mucking up the works. Running Windows 10 on a relatively new HP.

I have booted both the Nucleus and HP, have reloaded the remote software and reboted, all to no avail.

As I am in Denver, I wondered if we could hook up some AM and you take control of this machine and look around. I also have the white screen after minimization and have not been able to figure out the formatting of the installed Scandisk 2490 G hard drive I installed in the NUC… At 65, I know my skills in this arena are waning, but it would be nice to get these basics ironed out.



After stopping all auto start programs in Windows 10 the Roon app works correctly. Could you provide the exact page to find the Roon Administrator so I can format my SSD in the Nucleus?

Thanks for the updates @William_Utz, pleased to hear that the HP laptop remote is now functioning as expected once the mentioned auto start programs had been stopped.

I have shared some articles from our knowledge base below to help configure the internal storage of your Nucleus:

Nucleus & Nucleus+ User guide and manual
Nucleus Web Administration Interface
Formatting Nucleus Internal Storage