Album count dropped from 1061 to 743 over night

Roon Core Machine

Monterey 12.1. 2 Macs, a 2019 iMac and a 2021 MacBook Pro

Networking Gear & Setup Details

not relevant here

Connected Audio Devices

Gigabit Ethernet connecting both computers and the Nucleus+

Number of Tracks in Library

Was 1061 Albums

Description of Issue

Number of albums dropped as noted above. Last night I had 1063. Today I have 743. Running the latest ‘non-beta’ Roon. With many albums I know I have the titles do not show up in search, but when I search by composer they do show up as on my server. So something clearly wrong. That’s a lot of data to have lost, or not have displayed.

Addenda: Now, a few minutes later one of the albums I was searching for did appear by album name, but but more than 400 albums seem to be gone, or out of the count.

Restart the Roon Server app on your Core. That fixed this issue for me.


Several other users, me included, have experienced similar problems. Just restart your Roon Core, should fix your issue.


Absolutely fixed it. Thanks. Not so stable a version after all it seems. Thanks again for the solution.

1 Like

Great! Over the 6 or so years I’ve used Roon, I’ve developed a fairly reliable routine for addressing occasional problems. This always begins with restarting the Roon Server app on the Core, then moves to rebooting the Core machine, then on to other, deeper potential fixes (networking, etc.). I’m happy to say that 95% of my issues have been solved this way (on one occasion the HDD on my core became corrupted and had to be replaced).

I’ve had my share of issues over the last two years. Still, I’m overall happy. I thought the beta was a mess. Still can’t download the update on one Mac, but found my own workaround. Thanks again for the helpful tip. Will remember it for the next time.

It’s just about a mantra now…
When in doubt… reboot!

And I don’t mean just with Roon but with ANY PC or PLC connected or controlled device.
Sure it should not be a requirement but 99% of any issues I have are fixed in this manner.


Hey guys – for anyone who’s experienced this issue, can you answer a few quick questions?

(1) What OS is running your Roon Core?

(2) Where are the disappearing albums stored? Internal drive? USB Drive? Networked Drive?

  1. I’m running Sonicorbiter 2.8 on a i7 sonicTransporter-AP (Linux)
  2. Library albums (~84,500 tracks) are stored on the sT-AP’s internal hard drive (8TB)

EDIT: One thing I did not check is whether the dropped count includes only files or Qobuz favorites as well. I was signed into my Qobuz account when I noticed the dropped count, however.

cc: @Andreas_Philipp1

(1) Ubuntu 20.04.3 Server
(2) local files (apron. 56.000) on SDD local to Roon Core; the rest is Tidal albums. I don’t remember if the missing albums were local files or Tidal albums or both.

FWIW, I didn’t experience this when updating to the beta builds. Update to the release build made album count drop, but a search for a well-known “missing” album found it alright. I then restarted Roonserver and the album count came up corrected. I haven’t experienced this behavior since this restart after the update to the release build.

I’m on a Nucleus + with everything stored on its internal drive. As far as I remember, I lost my own FLAC files… I just have a handful of things from Tidal.

I’m having this issue since the update to build 882. I run a Roon backup nightly with all backups indicated as successful.

  1. RoonServer on MacOS BigSur v. 11.6.1, Roon 1.8 build 882 running on a headless Mac mini.

  2. First noticed issue in local library album count where I have placed a bookmark. Interestingly enough the first album I noticed as missing showed up when I did an search for it. There were multiple albums not showing in my local library bookmark including ALAC rips and DSD downloads. Local albums are on a core attached USB drive.

2(a). Also had large numbers of Tidal/Qobuz albums missing in the album count. It has been in the neighborhood of 1-2 K albums out of a total library of 8.5K albums.

The issue has resolved upon a restart of the core which is a pain since the core runs headless. Issue has occurred each of the last two days.

I can’t confirm if the issue is just an album/track count issue, or whether the albums are not loaded into Roon.

It is a bit unnerving to be missing albums, particularly local rips and downloads.

Hope you can get to the bottom of this.


Thanks for the info everyone, we were able to piece together a good lead and have next steps for engineers.

1 Like

My library has counted back to zero. Homescreen shows Zero Artists, Albums And Tracks
My Library Albums show zero but Artists are there and albums can be accessed through artists My Artists shows 4768 of 0 artists.
My Library Composers also shows up and can be accessed in this way.
Have tried restarting my NUC but this didn’t work for me. Any ideas?

Try updating to the latest version of Roon. We think we fixed this one since your message.

Thanks. Is there something newer than 884. I think that was my last update.

No, 884 is current.

yes, updating and restarting fixed my issues,

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.