Album playback and metadata issues in Roon causing discrepancies, Qobuz stamp present despite not being in favorites, troubleshooting steps taken without resolution (ref#YT7AKO)

What’s happening?

· Something else

How can we help?

· None of the above

Other options

· Other

Describe the issue

I downloaded an album from Highresaudio. I then put it into storage on the Nucleus. On my computer and on the Nucleus the album has 30 tracks and a play time of 1:55. In albums in Roon it has three discs and, when last seen, a play time of over 5 hours. It also has a Qobuz favourites stamp on it. It is not in Qobuz favourites. I tried several things but now cannot open the album. I threw out the files on the Nucleus, turned off Roon, restarted my computer, and reloaded the files on the Nucleus. No change. Any ideas?

Describe your network setup

modem is Starlink, router is Starlink, ethernet goes from the router to a network switch that goes to the Nucleus

I looked at albums in Roon with Qobuz Library ON and discovered the album, and was able to open it (once only) and take some pictures. The “remove from library” option was displayed, but didn’t work.





You can see how long it is at over 5 hours. Also the display is weird with repeated tracks. It should look like the last picture which shows a closely related album. It seems quite likely that I can never play the download I bought since this contaminates it. However, that is better than losing all the metadata in doing something drastic.
I tried turning off Roon, turning off the Nucleus, turning on the Nucleus, turning on Roon, and this time got the apparent Qobuz favourite, but smaller! Same messages come up if I try to remove from library, presumably because it isn’t in the library really.

I should add that, when I could see the album, it showed the tracks looking fine through to Disc 1-30, then it started over with a Disc 2 and two duplicates of each track. The appearance–the spacing–was different.

Hello @Susan_Tyler ,

Can you please connect all your desired storage locations to your Roon Server and then try to run a Clean Up Library process and check to see if this helps?

I tried that but it didn’t work. My storage locations are two SSDs in the usb slots on the Nucleus. This is presumably tangled up in some way with Qobuz favourites and is not connected with the contents of the drives. It does not appear with Qobuz favourites in my Qobuz account. I probably pressed “add to Library” on Roon with this one. So it exists only in some insubstantial way with Roon and the Nucleus.

Hi @Susan_Tyler ,

Thanks for giving that a try. Do you by any chance have any Backups of your Roon database from before importing these files that you could try to restore to? Or if you don’t have a lot of metadata edits and don’t mind starting with a fresh database, you reset the Nucleus database:

  • Create a Backup of your current Roon Database
  • Stop RoonServer from running in Nucleus’s WebUI
  • Navigate to your Nucleus’ Database Location
  • Find the folder that says “RoonServer”
  • Rename the “RoonServer” folder to “RoonServer_old”
  • Restart the RoonServer in the WebUI to generate a new Database
  • On the Roon Remotes, press “Use another Roon Server” and connect to the new database