Album-view filtering suddenly seems broken [Investigating]

Roon Core Machine

2017 MacBook Air, running Mojave. 1.8 GHz Intel Core i5. 8 GB 1600 MHz DDR3.

Networking Gear & Setup Details

Verizon FIOS router, connected via ethernet, no VPN

Connected Audio Devices

Schiit Bifrost 2 DAC, connected via USB

Number of Tracks in Library

121K tracks

Description of Issue

I have a large library of Grateful Dead shows, all of which are titled like this: “YY-MM-DD - Venue, City”. They’re all tagged as “Dead Shows,” and I have a bookmark so I can easily access them:

Until the latest release, filtering was really useful on this page, given the standard naming convention for each show. I could filter for “74-” for instance, and see all shows from 1974. Or I could filter on “77-05” and see all shows from May 1977. Etc.

With the latest release, though, I can’t do this any more. No longer does filtering seem to be looking for the filter criteria exactly as presented; now it seems to be looking for ANY character in the filter criteria, in ANY place in the album name. So now, if I enter “74-” hoping to see all my Dead shows from 1974, I get this:

This isn’t at all useful to me. And this any-character-in-any-place approach to filtering seems nonsensical. I can’t think of a use case where this is better than it was before.

I hope you’ll consider reverting to the previous method of filtering views. Thank you.

It’s been a week since I posted this. @support, is there a response coming soon?

Thanks.

Hi, @Brock_Bair, sorry for the delayed reply, we will investigate this one.

Thanks!


Ivan