ALLO DigiOne Signature not playing

Core Machine (Operating system/System info/Roon build number)
Intel NUC running ROCK v1.7 build 610. Connected via ethernet through Netgear GS305v3 5 port gigabit switch to All DigiOne Signature running DietPi v6.26.3.

DigiOne connected via SPDiF to PS Audio Stellar Gain Cell DAC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Description Of Issue

No sound coming from the device. Roon recognises the DigiOne as an endpoint and indicates that the track is playing, simply no sound. Other endpoints are working fine, including HiFiBerry, and iPad as an endpoint. Initially I was able to fix the problem by rebooting ROCK and closing/reopening the remote app. Now this is not fixing the problem.

I also tried rebooting DietPi and closing all other software options such as Squeezelite or AirPlay. No luck. All suggestions welcome!

Maybe try RoPieeeXL. It has support for your HAT. XL supports a few protocols in addition to Roon so should be suitable for testing.

1 Like

Thanks. I have managed to get it to play again by rebooting ROCK. It’s frustrating though. I may flash a new os to see if that fixes it.

First thoughts are re-flash the OS or try another SD card , they are notoriuos for failing.

I have Pi4 with Allo Digione running RoPieee, only trouble i had was fixed by a re-flash

1 Like

Hi @Philip_Kent,

Were you able to try a re-flash as suggested above? Did that help?

If not, can you share a screenshot of the signal path when you’re trying to play to this device but you’re not getting sound?

1 Like

Hello @dylan, I haven’t had chance to do this yet. Thursday and Friday are public holidays here so I will probably have a chance to look into the issue then. Really appreciate the support on Roon forums. I’ve had help with a few niggles over the years which is very reassuring. I’ll be in touch in a couple of days and will report progress.

1 Like

Two things:

  1. Something other than the HAT is selected so nothing is coming out the Coax. Verify with dietpi-config -> Audio Options -> Soundcard and make sure the allo-digione is selected. Reboot / try again.

  2. The HAT is selected and working fine. Something is not configured on the DAC. Do you see signal rate change on the DAC? I believe that DAC has volume control as well. I know, silly, but volume is up everywhere right?

Bit more info… Using RAAT, Roon will watch the DAC buffers and make sure everything is, effectively, “in sync” all the way to the DAC. If there was an issue with the HAT then Roon would complain and stop playback or cycle through songs very quickly after each error. You can see these errors by running ‘dmesg’ on the dietpi box. I don’t think this is happening which means everything is working fine with the HAT or the HAT simply isn’t being used and audio is leaving something besides the HAT.

Hello @ipeverywhere thank you for the suggestions. I have checked that the DigiOne is indeed selected in the audio settings. I don’t think I mentioned that this fault comes along even when I’m in the middle of a listening session which rules out most forehead slapping errors. Having said that, in true intermittent style I’m not having a problem at the moment.

Could it be the DSP? I had the feeling that Dylan might have been going down that route. I’ve turned it off now and, as I said, it’s been stable for a few days.

Spoke too soon, it’s just stopped mid track! Going to reflash the os.

1 Like

I’ve gone the whole way and replaced the micro sd card and flashed a different os: Ropieee. Let’s see if this fixes it.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.