Allo USBridge Benchmark DAC HGC3 [SOLVED]

Looking for some help to get this running properly. Currently, the benchmark dac and allo usbridge is not showing in roon, I’ve tried resetting everything and can’t get it to show. I’ve also reinstalled roon core on my pc. Yesterday the benchmark dac was showing on roon but when I played music it will simply skip every song. No music would play. Any help with troubleshooting would be greatly appreciated … I only have the trial of roon and only want the subscription if I can get this setup working. Thanks

System Setup:
Windows 10 pc 64bit Intel i5-3330 3GHz running roon core 64bit; ethernet to:
Allo USBridge running dietpi and roonbridge; usb out to:
Benchmark HGC3 dac
Remotes: pc, iphone, ipad

Roon remote enabled in settings
Media is 100% tidal streaming but I’ve tested with a local album as well

You might try turning off any Firewalls on the PC and see if the USBBridge shows up.

I’ve tried this also, made no difference. Is there a way to add firewall exception for Roon? To rule that out permanently


The DAC should be connected to the bottom port on your USBridge.

Now, let’s take things in order.

This sounds like some type of either power, or networking issue.

Has the USBridge ever worked ?

Have you tried rebooting it ?

Have you tried updating it ?

When you set it up, did you set it up for simple or dual power supplies ? If it’s dual, are both known to work, and connected ? If it’s one, have you tried swapping it ?

Also, let’s get involved, so that they too can help.

Hi Xekomi,

Thank you for your help. I just received the USBridge last week so no it has never worked. The first thing I did was create a backup then update to the newest dietpi version. I’ve tried a number of things each time rebooting after the change. This morning I decided to load the backup and start fresh. The USBridge is now showing again in Roon but it still skips the tracks. It also shows under networks. PC drivers are all updated as well.


It is setup for single power supply (the one provided by allo) using the 5v connection.I have not tried using only the microusb power supply as the allo instructions say not too unless operating dual. Still, all lights work on the usbridge and I am able to view both through the web gui and monitor via gui. I’ve also tried different outlets. Power seems to be fine.

Hopefully somebody from Allo can support.

Just some general comments:

  1. The unused zones should be disabled, click on the gear and choose disable.
  2. The zone in use should be given a name.
  3. The media streaming options you took a picture of for the DietPi have nothing to do with Roon usage.

With Roon, your server which is running on Windows PC needs access to the storage which you setup under Settlings/Storage. The Allo USBridge just serves as a network endpoint to receive the stream from the server and then forward it to the DAC.

Firewall Exceptions in Roon

The programs to white list are Roon, RoonServer and RAATserver. Firewall and port information can be researched here:'t_Roon_Remote_Connect%3F

Have you tried naming the DAC2 zone ?