Although I see an album in my Tidal favorites, it fails to play. I have to search Tidal for the same album and re-add it

It seems like some albums in my Tidal favorites don’t point to the actual music on Tidal’s servers. I have to search for the album again and add the same album to my favorites.
This usually afflicts albums that have been in my Tidal library for a long time.
Has anyone encountered this? Does anyone have an automated fix?
Can Roon discover these orphaned albums in Tidal and reunite them with their content?
I’m guessing that from Roon’s perspective, Roon doesn’t even see these empty albums littering my Tidal library.
A couple of example albums are Ghetto Disneyland by Skinny and Mercy by Active Child. I can find both albums in Tidal, but even though they are in my Tidal library, Roon doesn’t see them and I can’t play them. Tidal gives me a “content is no longer available” or “connection error” message when I try to play the version of them that are in my library.

Thanks for reaching out, @adam_tuxbury!

So we can gain a little more insight into what exactly you are experiencing, may I ask that you please confirm the following:

  • Just to confirm, you are not seeing these albums at all in Roon, correct?
  • Can you share a screenshot of what you are seeing when you try to play the album here?


1 Like

That’s correct. I do not see those orphaned tidal albums in my library at all within roon. I only see them in my tidal library from within the tidal software.
I suspect this is all on tidal. I’ve opened a support ticket with then too.

Any idea how this content got into your library? Did you add it in Roon? In the TIDAL app? Via our Collections feature?

If you can let us know a little more about how the content originally got into your library, that might help us understand the issue faster.


Sorry about my delay in responding. I’ve been emailing with Tidal support to no avail.
Going through my tidal library within the Tidal app, I’ve found several albums that don’t play but that I can search for and still play. Most of them I’ve added to my Tidal library using the Tidal Android App. A couple of them I added with Roon, using some classics album feature within Roon. In that case, Roon added 2 Al Green albums to my Tidal library, and the next day when I tried to play them, neither would play. I then searched for the same albums in Tidal, found them, and played them.
When I generate a link to these albums using the share function within the Tidal app, each album in the pair (the one in my library that doesn’t play and the one that does play) have different links. One of the links is dead; the other links to a working, playable album.
Tidal told me that the albums changed in some way or were released. I’m still waiting on feedback on how exactly they changed.

For example, here is a pair of links to the Al Green album that Roon added to my Tidal library. The link that doesn’t work is the album that Roon added. The link that does work is the album that I searched for manually.
The link from my library that doesn’t work:
The link from the album through a new Tidal search:

Hey @adam_tuxbury,

Thank you for the additional details!

I tried replicating the behavior that you’ve described above, and unfortunately I have not successfully done so. This is not behavior that we’ve seen before, so we don’t think that you should be experiencing this behavior with future adds to your TIDAL library.

With that in mind, if you are still experiencing this behavior with new TIDAL albums in your library, getting to know a little more about how these additions and the exact steps you’re taking when adding them. Have you noticed this happen with any new albums?


Thanks for trying.
I just replicated the issue with a new Tidal Collection.
In the OSX Roon app, I navigated to the Tidal Collection section and added the World category to my Tidal library.
I then opened the OSX Tidal app and sorted my favorited Tidal albums by Date Added. The first album that shows is called Folila by Mariam, Amadou.

I click on that album, still in the Tidal app, and get the following error screen in the OSX Tidal app:
“Page not found. Something went wrong. The page you were looking for doesn’t exist. The content is no longer available”

The link to this orphaned album is

I then did a new search within the OSX Tidal app for that same album. I’m able to find the album and play it. It was released in 2012. The link to playable version is

Back in my OSX roon app, under my Tidal favorite albums, sorted by Date Added, the same album just doesn’t appear at all.

I will be super confused if you can’t replicate that.

Tidal is doing something screwy with albums, and Roon must be storing obsolete links to albums in these Collections. I don’t know. Any ideas?
I don’t really care about the Collection feature, but I care that albums I’ve saved to my library just disappear. Tidal Support has basically told me to deal with it. Is there any way that Roon could automatically check for orphaned albums and re-add them to my Tidal library? That seems like a major feature, but it would be pretty awesome.

Thanks for taking some time on this.

Just some data:
The Roon app shows that I have 968 albums in my Tidal library.
The Tidal app shows that I have 1026 albums (assuming I counted right).
That means that my Tidal library has 1026 - 968 = 58 orphaned albums. 5%. That’s not terrible. It’s not very good either. Out of 44 albums in that World Collection that Roon added to my library, 10 of them are orphaned (they appear in my library but don’t play). I searched for each of those 10 albums and all of them are still playable in Tidal.

Thanks for the additional information here, @adam_tuxbury, that definitely helps!

I’ve passed your report along to the technical team for further investigation. As soon as I receive their feedback I’ll be sure to update you on their findings.

Kind regards,