Amazon Fire HD 10 roon remote

Build 831 update crashes to home page after approx 1 minute. Audio continues. Happens on battery or hard wired to charger. Core on i5 CPU 8gb Ram SSD. Pi3 end point running up to date ropieee hard wired to router.

Update - doesn’t happen on Fire HD8 tablet or android/apple remotes on same network

Hello @Paul_Butler,

Thanks so much for letting us know that your Amazon Fire HD 10 tablet crashes… we’re sorry about that.

Have you tried:

  • uninstalling the Roon Remote app
  • restarting the tablet
  • reinstalling the Roon Remote app

Do you see any change?

I have two Fire HD10 tablets of different versions which I use as Roon remotes. Both are running the latest version of Roon remote (Roon version 1.8 build 831). On the newer tablet everything works as it should, including the new lock screen feature. However on the slightly older tablet the lock screen feature and the keep screen awake feature have not been working since the Build 831 update. I’m presently following the steps outlined by @beka in the post above.

Followed the steps and now i have the exact same problem as the OP, i.e. Roon keeps crashing after about one minute.

Here are the details about the two tablets:

newer tablet: Fire HD 10 (9th generation) running Fire OS
On this tablet Roon remote (build 831) works perfectly.

older tablet: fire HD 10 (7th generation) running Fire OS
On this tablet Roon remote (build 831) keeps crashing and sometimes even freezing the tablet.

After trying to uninstall Roon remote on the 7th generation Fire HD tablet the app will not completely uninstall and will not open or update. In other words it’s completely screwed up. Multiple reboots have not fixed the issue. the app does not appear on the device’s home screen but does appear in the App Store library and will not update or open (aka frozen).

Reinstall and restart seems to have solved it. Many thanks

I spoke to soon. Was ok for about 5 mins this time but it’s back. Can confirm it’s a 7th Gen HD10 fire as per other poster. HD8 works fine

Hey @Paul_Butler,

Thanks for following up on this thread. I’m so sorry the victory was short lived… is there any possibility to update the software on the HD10 7th gen?

@Jazzfan_NJ thank you for chiming in and sharing your very relevant experience :nerd_face: . Could you please let me know if you can do the same as above?

@beka Okay so I think I managed to resolve all the issues.

First there is no way to update the Fire HD 10 to anything beyond Fire OS

Second the tablet was not allowing me to reinstall Roon Remote from the Amazon AppStore. Although the Roon Remote was uninstalled the AppStore kept showing the app as being installed with the “open” button highlighted. Clicking on the “open” button did nothing.

Solution: I had side loaded the Google Play Store, which does run on the Fire HD 10, a while back so I tried to install the Roon Remote from the Google Play Store. Not only did the Roon Remote app install but it now runs without any problems. Not the most elegant of solutions but hey it worked!

1 Like

How amazing to hear! Thanks for the investigation and effort, @Jazzfan_NJ. I’m so happy you can use your second tablet as well :partying_face:

@Paul_Butler, would you be able to try this work around?

How do you get Roon Remote on your Fire HD. After downloading the App, I was not able to proceed. Screenshot below from the tablet.

Your help is much appreciated.

Hi, @Tategoi, Roon Remote not current version in Amazon Appstore - #5 by kevin as Kevin posted here, unfortunately, there is a 24-48 delay for Amazon store.

Apologies for troubles.


1 Like

Hi @ivan sorry to have missed out Kevin’s reply. I will wait for it then. Thanks for the reply.

1 Like

I’m in same boat here - updates have downloaded fine on my sonic transporter but use Amazon Fire as my remote and says I need an update which I can’t seem to get. Dead in water as a result.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.