"An audio file is loading slowly" after MacOS Big Sur install

In the past, I’ve flawless used Roon (core on iMac) to play files to my Weiss DAC501, including large DSF Audio files. The audio files are stored on my Synology NAS DS218.

Then, last week, I upgraded the iMac to Big Sur 11.0.1. (I am not aware of any other upgrade/change to my system.) Suddenly I get error “An audio file is loading slowly. This may indicate a performance or hardware problem.”

As an example of a file that exhibits this problem, I can refer you to attached image 1; and the error displayed is in image 2.

I would be grateful for your support in fixing this problem.

Peter Schindler

Hello @Peter_Schindler, can you help me understand your networking setup and how these devices are connected currently? Do you have this issue with files stored on the iMac locally?

Hello Nuwriy,

thank you. I’m happy to explain further detail, but please note that the network set up has not changed from when the playback of the files in question worked perfectly to when the problem - An audio file is loading slowly…" appeared. The only thing that changed is that the iMac was upgraded to Big Sur.

At any rate, here is the network set-up:

  • iMac: MacOS version 11.0.1 (20B50) (Big Sur); connected to LAN via Ethernet cable
  • NAS: Synology DS218+, attached to iMac by USB
  • DAC: Weiss (https://weiss.ch/) DAC501, attached to LAN via Ethernet; Roon-Ready device.
  • LAN Router: Linksys LGS108 (8-port router)

As regards your question “Do you have this issue with files stored on the iMac locally?”, I have not tried this. I will give this a try and report back; in the meantime, please let me know if the above explanations help you in helping me.

Cheers, Peter

Hello Nuwriy,

I’ve now rebooted the NAS and the iMac, and it works again.

I have deliberately not done so before because, after a lifelong carrier in I.T. and system, I find “reboot” the lazy person’s out. After all, in a solid system, rebooting shouldn’t fix anything.


Hello @Peter_Schindler, I’m glad things are working again! If the issue returns, please try playing some files locally from the iMac and let me know if it works!

Maybe some fixes coming here too

Hello @nuwriy,

the problem has occurred. So, I copied one album into a folder on the iMac’s internal hard drive. This is the album:

And playback proceeded without problem. For your reference, the memory usage at the time of playback was:

Given that it plays back fine from internal drive and has problem if from DS218 Synology lab, what can I do? The Synology DS218 is connected to my LAN via Ethernet. Where do you think is the problem:

  • Ethernet not fast enough?
  • NAS not serving up files fast enough?

I look forward to your comments.


PS: Here is one more screen print:

Hello @nuwriy, one more additional piece of information: I rebooted the NAS (but not the iMac), and the NAS reboot playback of the album residing on the NAS worked well also.

Looking forward to hearing from you!

Cheers, Peter

Hello @Peter_Schindler, this is good information to have! Have you tried a different Ethernet cable to see if that helps? I’d like to have you reproduce the issue with a different cable and reply here with a timestamp (in your local timezone) and the track you noticed the issue on so I can enable diagnostics for your account?

Hello @nuwriy, interesting hypothesis. Another ethernet cable. Since you are not requesting a specific cable quality (I assume that even Ethernet cables have different grades), is your suspicion that the cable (or the plugs on either side) is “broken”?

Do I need you to notify of the timestamp of when the error has occurred or a target timestamp when I aim to reproduce the error? I’m asking because I suspect you will need to enable diagnostics before I reproduce the error no?

Finally, let me tell you know that I’m located in Hong Kong. (No VPN needed here.) At this moment:
Time zone in Hong Kong (GMT+8)

Tuesday, 22 December 2020, 6:00 pm

Hello @Peter_Schindler, a timestamp of when you notice the issue will work just fine. After that, I can enable diagnostics for your account and take a look.

Hello @nuwriy, ok, will do over the next days and revert back. Thanks!

Peter I feel your pain. Big Sur has made my 2019 MacBook air useless. And now requires regular reboots (more like my PC’s).
Not sure what has caused it but the latest update 11.1 seems to have improved things slightly, but hopefully more improvement to come in the new year


Nello @nuwriy,

I’m now running the experiment.

  1. existing Ethernet cable (dark blue), file playing from NAS (file “01_Monty-Alexander–Love-You-Madly_2xHD_2XHDRE1187_2ch256.dsf”), timestamp: 17:36 starting, December 27, Hong Kong, GMT+8:

    - same problem as before within 10-15 seconds.

  2. replacement Ethernet cable 1 (light blue), file playing from NAS (file “01_Monty-Alexander–Love-You-Madly_2xHD_2XHDRE1187_2ch256.dsf”), timestamp: 17:44 starting, December 27, Hong Kong, GMT+8:
    No problem, played this file without problem and transitioned well to next file: 02_Monty-Alexander–Love-You-Madly_2xHD_2XHDRE1187_2ch256.dsf

  3. replacement Ethernet cable 2 (yellow), file playing form NAS (file “01_Monty-Alexander–Love-You-Madly_2xHD_2XHDRE1187_2ch256.dsf”), timestamp: [xx:xx] starting, December 27, Hong Kong, GMT+8:
    Out of curiosity, I tried one more cable. (The colours are irrelevant of course, just helps me keep track which cable for which experiment.) With yellow, also no problem, played this file without problem and transitioned well to next file: 02_Monty-Alexander–Love-You-Madly_2xHD_2XHDRE1187_2ch256.dsf

First, thank you; would have never guessed it’s the cable.

Let me also ask: in your experience, what is the problem with the existing cable (dark blue)? I’m really curious what the root cause is for future reference.

Thank you again!

Hello Mike,

thanks for chiming in. @nuwriy has been an excellent problem solver. See my reply; the change in Ethernet cable did the trick. I would not have guessed.
Hope he can solve your problem too.

1 Like

Peter sorry my problem is not a Roon problem, as it generally runs sweetly for me.
My Mac is a work Mac, and while it has Roon on it it rarely gets used for playing music.

I suppose it was a general bitch at the quality of Big Sur and it’s crashyness.
Glad your problem was resolved at least.



got it, thanks

Hello @nuwriy, I’m sorry to have to report that the problem re-occurred in the last few days. ( Since my last message there has been no change in my system except for MAS OS upgrade to 11.1)

Once again, a rebooting of the NAS cured the problem. All this leaves me none-the-wiser as to what the problem really is:

  1. Your suggestion to change the Ethernet Cable (to NAS) appeared to work as per the experiment results I sent you. But solution was temporary; lasted around 20 days.

  2. Rebooting the NAS cures the problem, but is temporary, too.

Changing the cable every x days is not desirable :slight_smile: Rebooting the NAS every X days is not desirable, but not difficult.

Still, we haven’t gotten to the root of the problem. Do you have any further suggestions?

Thank you!

Hello @Peter_Schindler, let’s get another set of diagnostics in front of the QA team. Could you please reproduce the issue and reply here with a timestamp and a track name? I also wanted to reconfirm that the Synology DS218+ is attached via USB to the mac still or has that been connected via Ethernet to the router?

Hello @nuwriy,

good to hear from you. When the problem re-occurs I will give you the time stamp and the track name.

The Synology DS218+ is, indeed, connect via Ethernet to the router as it has been since the very beginning.