"An audio file is loading slowly" for DSD64/DSD128

@support I am having a problem causing the ‘slow loading file’ message when playing DSD64 and 128 files - which I have not had issues with before. After launching Roon, it will play 2 DSD128 files perfect. Processing speed is 10.6x. During the third track, it will abruptly stop, flash the error message and advance to the next DSD128 track and after playing a bit will abruptly quit and go to the next track. When I try DSD64, it plays some, stops and goes to the next track. These are all local files of course.

  • I have turned on the dual processor feature but no change.
  • I have increased RAM on iMac where the Roon Core resides from 8 to 32GB. The new iMac has 2 processors with its single core.
  • I have turned off all DSP features: upsampling, equalizer, volume control without any change.
  • I have rebooted Roon and all hardware in the chain. No affect.

All hardware is hardwired. Nothing wireless.
The Roon Bridge is an Innuos Zenith SE. The Roon Ready DAC is Simaudio Moon 280D

I use an SOtM Ethernet switch. A SOtM tx-USB ultra is positioned between the Zenith and DAC.

All ideas/suggestions appreciated. Thx.


Hi @Bruce_Orr,

I have split up your post into a separate thread so that I can better assist here. I have a few questions starting off:

  • Can you please let me know where the audio device are streaming from?
  • Are the files located on the iMac or on a Network share?
  • If the files are located on the iMac’s local storage, is the drive a regular spinning disk or is it an SSD? * Where is the Roon database stored, on the HDD or on an SSD?
  • Does this issue occur with multiple endpoints?
  • What is your router model/manufacturer?
  • Is the behavior the same if you bypass the Ethernet switch and connect the endpoint to the router?

– Noris

What year/ model iMac is this?

Thanks for jumping in to help. I am traveling this today so wont have access to the iMac until tomorrow to provide exact model name. It was purchased new in the last 6 months. It is 27”. Will provide more info tomorrow. Thanks again.

Thank you Noris.

  1. The Roon Core is on a 6-month old iMac
  2. Local files are on a LaCie Porsche design external HDD attached directly to the iMac
  3. When I return home tomorrow I will determine where the Roon data is located.
  4. The only endpoint I have tried is the Zenith.
  5. The Router connected to the modem is a Netgear Nighthawk. Wireless turned off.
  6. I have not yet tried connecting the router directly to the Zenith endpoint to see what happens. I only know it has worked in this configuration in the past.

Noris, with regard to the location of the Roon files - if you are referring to Roon Backup files, I save backups to two locations - one is the external hard drive and the other is on the iMac’s hard drive.

My iMac is is model iMac18,3
Intel Core i5 – one processor, 4 cores
32GB of Ram Memory
Purchased new from the Apple Store within the last 6 months.

I hope that helps. I look forward to your thoughts on solving my DSD loading/playing issues.

@Noris Below is a coplee summary of answers to the questions you raised earlier. I addressed some of these things earlier, but they are all summarized here for your convenience.
Computer Housing Roon Core
iMac is is model iMac18,3; Purchased new from the Apple Store within the last 6 months
Intel Core i5 – one processor, 4 cores; 32GB of Ram Memory

The iMac/Core is hardwired into the network Router, SOtM switch, Innuos Zenith SE (Roon Bridge/Endpoint), and thru a SOtM tx-Ultra USB regenerator to a Simaudio Moon 280D DAC (which is also Roon Ready)

Local files are located on a LaCie HDD external hard drive connected directly to the iMac

The Roon and Roon bridge apps are located on the iMac’s HD in the Applications folder.
Two Roon Backups are created - one stored on the LaCie external HDD external drive, and the other in the Music folder on the iMac. Are there any other Roon files I’m missing?

The Router is a Netgear Nighthawk R7000.

Again, I have not tried connecting to a different endpoint

That should be giving you more than enough power to run DSD128. Sorry your original proc/core counts threw me a bit

@wizardofoz --thanks for the reply. Yes, I agree the horsepower should be there, there’s got to be a clog in the line somewhere. I hope @noris can help me solve!

Hi @Bruce_Orr,

Thanks for providing that info. I was more curious to know where your media is stored (not the Roon backups) and it appears that this is on the LaCie HDD according to your response. Let’s try a few tests here:

  1. Can you move a few of these DSD files over from the LaCie HDD to the iMac’s HDD and try playing them again? If this works as expected the bottleneck might be the drive.

  2. Let’s verify if this behavior is endpoint specific or if it occurs just on the Zenith. Do you have other endpoints that you can try using that are able to output these DSD files?

  3. This setup seems a bit complex and has a lot of pieces, let’s try simplifying things a bit. Can you try connecting the Moon DAC directly to the Core bypassing the SOtM Regen and Zenith Bridge? If things are working on a simplified setup that would give us a great data point.

– Noris

So here’s the latest from the frontline:

  • when bypassing the Zenith and tx-USBultra, the same problem reoccurred. FYI, this was also a direct Ethernet feed.

  • After moving source local files to the iMac from the LaCie, however, the problem ceased. DSD128 was processing at 10.8x using only volume leveling and headroom adjustment.

  • I tried making things a little tougher by adding an equalizer configuration, and everything is still humming - and we’re still at 10.1x

Couple of Questions

  • I guess the best intentions don’t always bear fruit? In this case, I was trying to make it easier on the iMac by using the LaCie - but maybe all I was going was saving some space?

  • what are some rule of thump processing numbers that represent minimum levels for operation?

Thank you,


Bruce, I would run a first aid (under Disk Utility in the Applications/Utilities folder) and see if its having any issues. A bad drive on a Mac can cause all sorts of system slow downs especially with the file systems - I had a bad external SSD on my thunderbolt2 4 bay that causing no end if issues like 3 days to clone a 256GB drive onto a different raid setup in the same enclosure. Took out the SSD and things were all good again…but the SSD while it was still working only had errors when using it for backups. Otherwise no errors were being flagged.

Suggest you try another cheap USB3 drive to copy all your music to as a backup and see how that works too…could be an issue with the Lacie or maybe that port (USB I assume?)

Thanks @wizardofoz , I think you are onto something with a wonky LaCie HDD. The problem was solved after I relocated the local music library from the LaCie to the iMac - at least no problems playing the DSD files so far. I tested things further by adding upsampling and filters and the DSD files still played without issue at processing speeds of 10.8x.

I can’t say I’ve isolated the cause to the LaCie vs. the iMac, but I’ll figure that out over time when I get around to buying a new external drive.

Really appreciate your help. Thanks.


1 Like

Hi @Bruce_Orr,

If things are stable with the LaCie out of the mix I would suspect it to be the bottleneck here. The processing speed you are seeing is good, anything over 1.2x-1.5x is the very minimum you should be seeing when trying to play files, but there are also other factors which may impact the performance (quality of cables, speed at which the media is read from the drive, drive format, ect.).

If you are trying to troubleshoot the LaCie drive further, my initial suggestions would be to run the disk check that @wizardofoz suggested, try a different USB cable and try a different port for the drive’s connection.

Either way, at least now we narrowed down the issue to just one piece of the setup so the next steps for troubleshooting are a bit more clear.

– Noris

Thanks, Noris. Yes, at this point we have solved the problem I needed to fix. I can figure out if there is a problem with the LaCie and if that problem is anything that is affecting my usage. There does not appear to be any benefit to moving files back to the LaCie, even if I resolved that issue.

Thank you again.


1 Like

USB devices often can’t transfer data as fast as a local or internal drive. DSD128 is a large file data wise so might mean you could still use LaCie for smaller files like PCM and DSD64. You could point Roon library at two locations…I have highlighted the differences in files sizes in this screenshot.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.