An audio file is loading slowly - RPI openvault NAS

first of all sorry for my bad English, I hope being clear enough to describe my problem :slight_smile:
I’m in the process of evaluating Roon and let me say that I think it’s a wonderful piece of software.
My issues started when I tried to play some HD files, and I was very often faced with the infamous “Roon - An audio file is loading slowly” message.

My core is an (admittedly old) iMac running OS X El Capitan, the files are served by a homemade NAS built around a RasperryPi running OpenMediaVault. The files resides on a couple of 2TB disks running in RAID1.
The Roon version is 1.3 build 262.
The output device is another RPi equipped with an Audiophonics Sabre 9028 I2S DAC running DietPi.
The NAS, the iMac and the output RPI are all connected to the switch via cat.6 cables.
The eth0 port of the NAS is running with MTU=1500, no jumbo frames involved.

Trying to figure out the root cause of the problem, I switched to another player (MoodeAudio) and I was able to reproduce the files without any glitch.
So I monitored the eth0 interface of the NAS trying to compare the bandwidth requested by MoodeAudio with the one requested by Roon. In the graph below there are my findings:

(the huge peak about 16:10 was me copying a file from the NAS to a local disk, and in the meantime the playback continued without interruptions).

So, it seems that Roon requires a very large amount of bandwidth in comparison to MoodeAudio, and when the bandwith eventually got saturated Roon is forced to give up.

The user experience Roon provides is orders of magnitude better than every other player I’ve tried, but I’m afraid that if I can’t figure a way to solve this issue I would be sadly forced to revert to MoodeAudio as my standard player.

Every bit of help would be greatly appreciated.

Kind regards,

If you copy the slowly loading files to a folder on the Mac and then add that folder to roon as a source and playback does it show similar issues?

I’ve changed the topic to include the openvault reference- and I have a feeling that’s where the issue could well be.

I assume the moode audio is bypassing the Mac (and roon) completely? Does moode also cache the complete file before playing?

Just tried. Not a single glitch, not even with some DSD64 material.

Yes, moode runs on the same Rpi the DAC is attached to and of course bypasses the Mac and roon.

In moode you can define some kind of pre-buffering in terms of % of the file that should be loaded before the reproduction begins, usually I set this parameter to 10%.

Ok lets tag @support and see if the boys have any ideas why this might be different.

Rpi is known to have issues with Ethernet and usb traffic contention.

It’s very strange, indeed.

FYI, the same Openmediavault NAS serves on a separate share video files too (which in theory should be a lot more demanding in terms of bandwidth than the audio ones) and I can watch video (on the Mac, on the TV, wherever) without an issue.

Continuing my experiments, I tried to play the problematic files using a Mac player (VOX) and the playing is going on spotlessly. VOX seems to cache a good deal of the file even before starting playing: on the eth0 graph I can see a single peak at 80 Mb/s and near zero after.

Hi @Gaetano_Roberto ----- Thank you for the continued feedback, but more importantly, thank you for your patience. My apologies for the slow response here.

Moving forward, based on the observations you have shared, I would like to see if we can isolate some variables in order to determine where this issue (i.e “An audio file is loading slowly” message) could be occurring.

Before we start gathering/analyzing logs, can you please confirm if during your troubleshooting of this behavior you’ve tried the following…

  • Being as you are aware that the core device is on the “older” side, have you tried running your Roon core on stronger machine to determine how things behave with more power driving the application?

  • You also noted that with the HD content being hosted on the internal storage of the iMac, you were able to play to your endpoint(s) without any issue. Have you tried using another network based storage device to see how things perform?


Hi @Eric, thank you for your reply.
Unfortunately, I haven’t at my disposal neither a newer iMac (or PC) nor another NAS to perform more extensive tests.

What really gets me puzzled is the graph I posted: since we have time in the X-axys and MB/s in the Y-axys, the area in a specific time period should be more or less related to the amount of information (the MBs) transferred. But what the graph shows is that Roon requires a lot more MBs to reproduce the same track, and I can’t figure how that would be possible.

To be honest, I was so hooked by the Roon experience that I just ordered a new 4TB USB drive to which I plan to copy all my tracks in order to attach it directly to the Mac;this drive will in a (hopefully) not so distant future got eventually attached to an Intel NUC running ROCK.

Kind regards,

Sorry for the slow response here @Gaetano_Roberto!

This is probably related to how we buffer content – when you start playback, we immediately try to buffer the first 10 seconds of the selected track, and the next queued track.

This ensures we can work around content that’s loading slowly (from TIDAL or your local storage), and also gives a better experience when you hit the “Next Track” button. That’s why you’re seeing a spike in information being transferred there.

Hope that helps!