Analysis Stuck, need help determining which files are causing this

Roon Core Machine

MacBook Pro 16-inch 2021
Apple M1 Pro
16 GB RAM

Networking Gear & Setup Details

Using wired 1GB Ethernet
Netgear GS108 Switch
Linksys 1900ACSv2 Router

Library

The Library is connected over SMB protocol
The SMB Server is a Linux machine serving drives over SAMBA

Connected Audio Devices

Raspberry Pi 4 running Ropieee XL
Connected over TPLink Powerline Ethernet Extender
ifi ZEN DAC

Number of Tracks in Library

68,480 Tracks

Description of Issue

I had a database crash and had to restore from an older backup.
After restoring from the backup of course Roon had to re-analyze about 6 months of additions.
When starting up the storage scan runs to completion.
In the Library section there are clearly one or more tracks stuck in analysis. It stays at the same number and spins forever making no progress.
I have attempted to read the Roon logs to figure out what is stuck but I can’t figure it out from the log.
Please help me determine which files are causing the analysis to be stuck and spinning forever.

Hi @Michael_Furman ,

Are you still seeing this issue at the present time? I’ve enabled diagnostics for your account, but it looks like your Roon Core is not communicating with our diagnostics servers at the moment, can you please use the Roon Core for at least a few minutes when you have a chance and let us know once you’ve done so? Thanks!

It was not running, I started it back up last night so should be talking to your back end now.

Under settings → Library → Background audio analysis it says “Analyzing: 155/288” and just spinning there with no progress. So yes, still seem to have the problem with something in my library.

Thanks.

I have the same issue. When I stop and start audio analyse it’s solved. But as soon as I add new music the analyse starts again and stuck about 6-10 tracks before the end.

I’m running RoonOs 1.0(256) and Roon 2.0 (1182) on a i5 Nuc, 8Gb, 40.000 tracks library.

Don’t know if it can have anything to do with it but my log frequently shows:

12/28 07:48:53 Trace: [library] finished with 1 dirty tracks 1 dirty albums 2 dirty performers 0 clumping tracks, 0 clumping auxfiles 0 compute tracks, 0 deleted tracks, 1 tracks to (re)load, 0 tracks to retain, 0 auxfiles to (re)load, 0 auxfiles to retain, and 4 changed objects

Found this in my log at the moment the Analyse stucks. Maybe it has something to do with it? How can I find out what track belongs to trackid=20723506 ??

12/31 07:51:25 Warn: [analysis] failed to get filekey for librarytrack with trackid=20723506

@noris Can you please review if you have been getting any data over the past week?