And again the problem of playing Tidal with Roon on my iMac

Hello everyone! And again the problem of playing Tidal with Roon on my iMac.

It started a couple of months ago and to this day. It writes that the connection has an insufficient speed, then the playback error does not lose at all, except for files that are stored on the hard disk.


  1. From the browser Tidal is played well and stable.
  2. With Audirvana also there are no problems with playing!
  3. Already re-addressed the provider in order to transfer the nodes from me to but the problem remained.
  4. I connected the Internet through Wi-Fi by pairing via iPhone and LTE network to make sure that the problem is not in the wired network - everything remains the same.

So the problem is in Roon. How much blood he drank from me for the year you would know! That still lottery, coming home after a hard working day, know what you can do not listen to your favorite music today (((
And problems have become more after the last update. By the way, MacOS also updated.

Guys, what should I do yet?

1 Like

Can anyone help?
Maybe I should remove and reinstall Roon. I heard that when deleting, not everything is deleted from the iMac. Can you tell me how to completely remove Roon in macOS?

I completely removed and reinstalled Roon. Nothing helped! First, he writes that “tracks are loading slowly, this may indicate a problem with the network or Internet connection”, and then he does not want to play tracks from Tidal albums at all.

Although my tariff plan from an Internet provider implies a speed of 800Mbps

Where is Roon tech support @support ??? I have been paying for your player for the second year, and for the second year I can’t solve the problem!

Hi Evgeny,

Not official support, but, sometimes that can be caused by DNS errors. Have you tried to use the IP addresses or as your DNS servers


1 Like

Hello @Evgeny,

Thank you very much for posting about this and for your patience while we returned to work after the weekend (support is open Monday - Friday) :pray:

I appreciate the details you’ve shared about your setup and the issue you’re experiencing. Thanks for trying the troubleshooting steps you’ve mentioned :nerd_face:

@Rugby’s suggestion is right on point. Could you please try changing your Router’s DNS servers from the ISP provided ones to Cloudflare DNS, Quad9 or Google DNS.

Thanks in advace :pray:


Thank you, I will try and write to you.

1 Like

I have a Redmi ac2100 router. In the settings, DNS from Google is already registered. But the problem remains unresolved (((

For information, I inform you that today I completely reinstalled macOS, deleted, formatted the disk and re-installed - but this did not help!

1 Like

Connected the app. I will monitor whether it will help or not.

Thank you so much for going through all those steps, @Evgeny :pray:

I’ll keep my eyes out for you next post :nerd_face:

1 Like

Dear Rebeka!

After installing this application, all problems with Tidal playback are completely gone.

But only I should turn off this application - the tracks in Roon again start to disappear, again writes “slow Internet connection” or does not want to play at all.

And only when the slider is turned on - everything works without interruption.

Please clarify to me what caused this problem? Is she on Roon’s side? Or on the side of the ISP? I would like to figure out the reason, instead of using the “crutch” in the form of Cloudflare DNS.

I would be grateful for your answers. Indeed, for more than a year I have been suffering with this problem, and no one has yet been able to correct it and say what is the reason …

Hi Evegeny,

not official support but.

Instead of google’s DNS numbers, try using instead; which is CloudFlare’s DNS service.


Thanks! So far, the problem has been solved. Tested for 2 days. If there are failures, I will write.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.