Android 1.8 build 778 - volume buttons don't work

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro/Dell Latitude E6440/Roon 1.8 778

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Netgear R7800 WiFi in Access Point mode

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Samsung Galaxy S9+ with Android 10 connected to WiFI, headphones connected to 3,5 jack or USB-C DAC (Dragonfly Cobalt).

Description Of Issue

Hardware volume buttons don’t work in the app. To change volume I have to press the loudspeaker icon to open sound control panel screen and use buttons or slider there.

Same her with my Android 10 smartphone.

The hardware volume buttons don’t work if Roon is the currently active app. However, they work when Roon is in the background and another app is active.

Plus, seemingly random changes in volume. Sometimes the volume decreases a bit spontaeously for two or three seconds and then returns to the original volume. I couldn’t find a system behind this.

I have this issue too. Have to use the + / - buttons in the app of Roon is in focus.

@support, bump on this

Yeah, volume control was broken in 778, still broken in 783.

Roon DSP volume does not work. I can move the slider in Roon, but nothing happens. (no DSP entry turns up in RAAT in Signal path for the device)
If I set volume to ‘fixed’ (to use buttons on the device), Roon is actually blocking volume adjustment altogether. I must open the device config (in Android) to adjust volume.
Device volume works in Roon, but there is only 15 (16 from zero) steps to full volume. (Is this ALSA?)

Android 5.x, 10 - Tabs and phones

EDIT: by selecting and configuring playback on one of the Android remotes from my windows laptop the DSP volume entry in Signal path shows up, but it seems the Roon app resets device volume to a low level. If I then adjust device volume in Android config Roon looses control of playback volume. DSP entry is still in Signal path and dB values change, but sound level does not change. A restart (force-quit) of the Roon remote restores control of the volume level.

Yep confirm this too on Pixel 4.

Same issue here for a couple of days now on a Galaxy S10e/Android 11 running Roon app 783

Hello All,

Thank you for the reports, can you please confirm:

  1. You seeing this issue when playing to a locally attached zone to the Android device (either connected to 3.5mm or USB)

  2. The Android version of the affected device

  3. If the volume control buttons worked in earlier Roon builds for you (for the affected zone)

  4. The model/manufacturer of the connected DAC


  1. No, in my case I am using the internal DAC of the Android device - headphones connected to the 3.5 mm

  2. one remote is Android 5.0, one is 10.0 - both Samsung Tabs, A Samsung Note 8 phone is running Android 9

  3. Yes, buttons worked before

  4. N/A

  1. Yes this issue is when using the Android device locally via 3.5mm and via USB OTG cable to a Dragonfly Red.

  2. Occurs with both my phone on Android 8.0 and tablet on Android 9.0.

  3. Volume buttons worked perfectly in earlier builds.

  4. Isuue present for dac’s internal to both devices, plus using a Audioquest Dragonfly Red 1.07 on both devices.


1 Like

My volume buttons on my mobile devices have never controlled Roon’s volume. I thought this was by design. Glad to hear it’s not.

  1. Yes, with or without connected to 3.5 mm. USB: n/a
  2. Android 11
  3. Yes, worked through build 764 or 778 I think
  4. Internal dac of mobile phone
1 Like

Pixel 4
Android 11 latest patch
Phone output via Bluetooth
Used to control device volume on older versions.

Oddly my DAP on Android 8 works fine with its volume controls.

I’m also having the same issue since Roon 1.8 build 790 with two android devices as endpoints. Worked fine prior to update. Now I need to close out of Roon to adjust volume.

Galaxy S8

  1. Yes, with or without connection to 3.5 mm. USB: N/A
  2. Android version 9
  3. Yes, worked prior to Build 790
  4. No external DAC

Galaxy Tab A7

  1. Yes, with or without connection to 3.5 mm. USB: N/A
  2. Android version 10
  3. Yes, worked prior to Build 790
  4. No external DAC
1 Like

Ok, I realised my app on my DAP had not updated to the latest version of Roon remote , now it’s updated it won’t adjust volume at all the hardware volume controls are locked out completely they don’t change the system level output when Roon is active app. Prior to this the volume controls worked perfectly fine. @support is this being investigated?

  1. Yes device speaker.
  2. 10
  3. Yes.
  4. Phone OnePlus 7T.


Bumpity bump. Please :pray:

1 Like

Hello All,

Thank you for the additional information here! We are looking into this behavior, but as per policy, we cannot comment on a timeline. Thanks again for bringing this to our attention!

Hello @noris, do you have ANY progress in solving this issue?

As of today, it’s two months now (yes, 62 days!) this issue is adressed.

We’re talking about BASIC APP FUNCTIONALITY here. What about reshuffeling priorities?


Fixed by the 806 Build. Thank you!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.