Android 10 client keep disconnecting

Core Machine (Operating system/System info/Roon build number)

Linux x64 v1.7 build 667

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

OPNSense as firewall, NetGear Orbi rbk50

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

OnePlus 5 Android 10, latest build (A5000_23_201029)

Description Of Issue

I am a new user (sadly joined the trial a few hours before the black friday offer…), so I am trying to understand if Roon is for me for the next 2 weeks.

It works great with my Ipad, my Iphone, and all my computers, but I have big issues with my Android phone.

At first I was not able to connect, but reading the forum and entering as ip I was able to connect to the server, but it keeps disconnecting.

Even if it reconnects in few seconds it makes the interface unusable. For example I am scrolling the tracks of an album, and I can’t click to them as it keeps disconnecting.
If I try to play a music (a random un as I can’t reach the one I would like to hear), and try to play it on my phone, usually it plays for a few seconds and then get disconnected. If I have some luck it could be 30-45 seconds.

From my firewall logs I see a lot of IPv6 multicast calls that got blocked to ip ff02::16. It is correct that they are blocked as I don’t have IPv6 and in my lan I don’t have any IPv6 DHCP server.

The phone anyway creates alone it’s IPv6 address (like my server and my computers).

I tried to fix the issue disabling IPv6 on the server and seems it helped a little but it is still driving me crazy with all those disconnections.

To do that I run the following commands on the server:
$ sudo sysctl -w net.ipv6.conf.all.disable_ipv6=1
$ sudo sysctl -w net.ipv6.conf.default.disable_ipv6=1

I was not able to find any way to disable IPv6 on the phone or on the android app, perhaps this would fix the issue completely.

Thank you in advance for any help!

Hi @Zofoor,

In the Orbi’s settings can you uncheck Disable IGMP Proxying and let us know if that helps?

Thank you for the fast reply!
The Orbi wifi is configured as Access Point and not as Router, therefore most options like this one are disabled (as the main router manages them).

Anyway I’ve made a small change that greatly improved the stability.

In OPNsense I changed the configuration of the IPv6 LAN interface from “Disabled” to “SLAAC”.
With this change enabling/disabling the IPv6 on the Roon server does not seems to have any impact.

It is still not completely stable (specially if I try to play a song), but anyway a huge improvement: the interface is much faster, connections are re-stablished immediately and almost stable.

1 Like

Hi @Zofoor,

Thanks for letting us know that the change you made in your OPNSense firewall has helped!

Just to confirm here - if you temporarily disable the OPNSense firewall, does the issue completely go away, and you are able to connect without the previously mentioned issues?

Hello @noris .
Sorry for the delay, I had a very busy week at work.

Actually OPNSense’s firewall can’t be really disabled, but the default rules for then basically allows everything.

Back to my Roon implementation, this weekend I worked really a lot trying to make everything work smootly.

I tried to run Roon on my Win10 desktop to check if the issue with Android 10 could be fixed, but nothing changed. At the same time with another phone (Android 8) it works perfectly with both servers.

So I moved back to the original Roon Linux Server (inside a FreeNAS host using bhyve, guest OS is the latest Ubuntu).
I noticed that the samba share was falling every few minutes (causing also the playback to get interrupted). I tried to change on Freenas the network card configuration, disabling “Hardware Offloading” and the guest OS network card from VirtIO network card to Intel’s virtual network card but it didn’t helped.

I noticed the missing of some VIRTIO drivers to be loaded (running the command “lsinitramfs /boot/initrd.img-$(uname -r) | grep virtio”), so I enabled them (following ) but it didn’t helped.

I have to say that I run a lot of services under FreeNAS jails, all without any issue, so I see as a big miss that Roon does not support FreeBSD. I am adding the first VM only for Roon, and it is really time consuming making it working just for only one service.

Anyway, I made a new deployment of the Roon Server under a new Windows VM inside FreeNAS. Installed the latest stable Virtio drivers and enabled the Virtio network card.

Well, in this way something changed: now with my Android 10 phone the android app seems very stable (but unable to play on the device any song for more than 4 seconds), SAMBA share seems also stable.

@noris is there any way I could troubleshooting this specific issue?

It is very very strange because under a real Win10 system I was still seeing issues with the Android 10 application interface, and now under a virtualized one it is really stable (with the exception of the playback).
The playback on all other devices works perfectly, so the issue currently is only with the playback on my main phone (OnePlus 5 with Android 10).

Anyway finally some steps ahead! I still need to double-check if the performance of the virtualized system is good, and see if I am able to enable VirtIO also for the disk drive (to improve it’s performance).

My trial is ending in two days but sadly I still didn’t had the opportunity to test Roon as needed.

Anyway, I hope my experience could be userful to other (or for troubleshooting).

1 Like

Hey @Zofoor,

Thanks for sharing your additional findings here, that is very interesting!

Were you using the latest kernel version when you tried Ubuntu? There were a few reports of SMB issues using older kernel versions.

That is very strange, and you tried to reinstall the Roon app on your Android device following the Core change? A reinstall might help sort out the playback issue.

I’ve followed up via private message :slight_smile:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.