Android 11 update on S10+ Roon Core could not be found

I have the same problem after Android 11 update on S10+
Roon Core could not be found

Hi @Aldos_Zxz,

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

If you enter the IP address directly is there any change?

Hi @dylan
Thank you for the answer.
I can provide here a short description of my infrastructure:

ROON Core 1.7 build 710 on Debian 10 - ESXi 6.7
Music on NAS (same ESXi machine)
Netgear Switch (1 Gbps)
Various Ropieee endpoints (RPi4, RPi3A+) - wi-fi

I am using my Galaxy S10+ as ROON remote and everything was just fine until Samsung updates the phone to Android 11.
Nothing was changed, besides this update of the phone.

Now, as a workaround, I had to set my Core IP address as and I could reach the server.
On Android 10, the Core was discovered directly without any settings.

Hello @Aldos_Zxz, and thanks for the info! Can you elaborate on what router you have and how the core is connected to the router? Is your switch managed or unmanaged? Lastly, is the core connected via Ethernet?

Hi @nuwriy.
A short description of my infrastructure:
WAN - pfSense Router/FW - Qubs unmanaged SW - Netgear Managed SW (default settings, no VLANs) - ESXi (Debian 10 Roon Core)
All those devices are connected via Cat 5E ETH cables.
For wi-fi:
Netgear managed sw from above - Asus AC86U in AP mode
Qubs unmanaged sw from above - Asus AC86U in AP mode
The two Wi-fi APs are in a wired Aimesh infrastructure

Hello @Aldos_Zxz, and thanks for the information! So we know entering as the core’s IP when connecting the Android device works. Based on that information and our networking best practices guide regarding managed switches and access points, I think our next best step would be to simplify your network and build back up from there until we encounter the issue.

Hi @nuwriy.
Thank you for your suggestion but I don’t think this a solution !
I have to mention that I have the same network infrastructure for more than 2 years and everything worked fine until Android 11 update.
As far as I know, I am not the only one who has this problem after Android 11 update !
More than that, I also have an Android 10 phone, connected to the same network infrastructure, and it is working without any workaround !
There are a lot of topics on this forum with complains regarding this issue !
So, I think a best approach from Roon team will be to try to solve somehow this problem, not to make recommendation regarding user’s network infrastructure !
Best regards !

1 Like


Same issue here Galaxy note 10+
I had to let my phone spin to find roon core for 10min or so then the option to add roon core by IP pop.

Set the ip address and work immediately.

However since these my phone take around 10sec to access the core each time. Not so much but 10 times slower than before :cry:


+1 with the same issue using a Galaxy S10e. Using a Netgear R7000 route. Nothing in my configuration has changed with the exception to an Android 11 upgrade on Saturday. Prior to the upgrade, access to my Roon ROCK was flawless.

The problem is Roon ROCK. By installing ROON with any other operating system, such as Windows 10, Linux (Ubuntu or Debian), Mac OS, or I recommend trying Snake Oil OS (Ubuntu based), there is no problem. The problem is due to the non-existent assistance that from Roon, in the meantime we pay and we are here complaining in a forum.

I have ROON Core installed on Debian 10.
Maybe the problem is Android 11. Anyhow, Roon team must came with at least an announcement if not a solution !
For me, this “silence” does not sound good for a company who wants users money.
It is a matter of respect !

And this is not the first time when this is happening !
There was a problem also with older version of Android (7 I think) and Roon v1.6, which was fixed in v1.7 without any statement about it.

1 Like

Hello @Aldos_Zxz, and thanks for the feedback here. While using the multicast IP address is a workaround, our team is working to resolve the issue you’re seeing other reports of in the community. With that being said, we have noticed some of the reports are similar but not the exact same issue, so we’re trying to confirm that you’re experiencing the same issue.

I would at least expect clear answers. By assigning a static multicast IP to whom? If I try to assign it to ROCK it is no longer found on the network. If I assign it to the Samsung S20 smartphone it is not accepted as a valid address. In any case, do not specify which subnet mask six should be used with cannot be left blank.

Try entering the core address in these screens.
I will be stupid, but in 2 months they have not been able to explain it to me decently, and I am a computer technician. I can’t imagine if they have to support an ordinary person.

It’s not with a zero.

1 Like

Sorry, it’s a habit of entering the subnet mask.

The broadcast address to enter is:

When I open the app it doesn’t find the ROCK server instantly, but at least it finds it, in less than 7 seconds.

It’s also not a multicast address it’s a broadcast address…

I have a ROCK server, Android 11 Pixel 4 and have no issues with discovery of my core ever. If it worked on 10 and not on 11 then it’s something Samsung’s done to their network stack.

A broadcast address is always relative to a given network, there is no broadcast per se; when you have a network, you can compute its broadcast address by replacing all the host bits with 1s; simply put, the broadcast address is the highest numbered address you can have on the network, while the network address is the lowest one (with all host bits set to 0s); this is why you can’t use either of them as actual host addresses: they are reserved for this use.

If your network is, then your network address will be and your broadcast address will be

If your network is, then your network address will be and your broadcast address will be

And so on… is a special broadcast address, which means “this network”: it lets you send a broadcast packet to the network you’re connected to, without actually caring about its address; in this, is similar to, which is a virtual address meaning “local host”.

1 Like

So? Anybody at Roon working on patch? My Galaxy S10’s Android was updated four days ago and Roon ap still searching dor a Core… We have two other Android smartphones at home that can use Roon, but not mine (I’m crying now…). Please, just tell us what’s going on.

I did the trick and it worked. Maybe it could the standard in the next upgrade?

I hope they find a decent solution in a TCP / IP network. The broadcast address is a dirty solution, besides the fact that once I open the app I have to wait at least 5, 7 seconds. always better than before that the server was not found. But that’s a bit ridiculous as a solution!