Android app can't connect to roon core since avm router update to FRITZ OS7

I’m using a AVM 6950 Cable router. My core is on a windows10 connect by LAN to the router. My main play out is a cubox that is wired to a FRITZ 1750 repeater. I’m usind several remotes connectde by WIFI (Android phone, tablet, Windows, etc.)

Since the last router OS update the remotes very rarely find a connection. When I say connect to new core, the Status stays most of the time at initializing. Sometimes it connects, but the connection is always lost very fast.

From the core I can start playing to the cubox bridge without problems. WIFI connections are great, in speed tests I get > 200mbit Speed to the same client that doesn’t find the core.

The whole issue seems to be router caused. The support from the router vendor (AVM) tells me, that they introduced a dns rebind security. I can configure exceptions, but would need to know if the app is using dns names?

If so, can you tell me the Name it is using?

Any one else experienced the same problems?


Hello @Martin_Kogel,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Can you please post a screenshot of the router’s DNS Rebind settings page? I have not previously heard of reports affecting DNS rebinding but it is possible.

If there is a way to set firewall exceptions in the router for specific ports, the ports that Roon uses can be found here, (please make sure to include both Roon.exe and RAATServer.exe):

Have you changed any settings at all on the repeaters? Is Multicast enabled on both the Router and the Repeaters? If you connect one of your Roon Remotes directly to the Cable router, does it show up properly then? If all else fails, is there a way to downgrade the firmware to the previous version on the Router and verify if the same behavior occurs? Please let me know when possible.


No idea if it helps but anyway:

I’m using a Fritz!Box with Fritz!OS 7 and don’t have issues with my Android Tablet connecting to the core. I didn’t had to configure anything when the Fritz!OS was updated and I’ve never had to add exceptions for Roon on the router. I believe the Fritz!OS firewall only cares for WAN side connections which should not affect clients connecting to the core inside the home network.

What I do inside Fritz!OS is assigning each device on the network – be it wired or wireless – a dedicated IP address (“Always use the same IP for device …”).

HI @noris ,

thanks for stepping in! Unfortunately my router model can’t do a down grade according to support, but I can do a rma return in case and get a stuck unit with still the old OS version.

The router is a commercial model with little configuration options. I will check the multicast and ports with support from avm.

I have the same problems regardsless whther the roon remote is connected to the router or repeater.

Here is what I can configure in regards to multicast.


HI @anon47919701,

I also didn’t have any issues before the update. I will try the fixed IPs.

When I tried the beat of OS7, I had the same issue and reported it. With the beta you can go back to the older version, now with the final you can’t. The issues dissapeared when I downgraded the OS.

I thought after reporting the issue they took care about it before the release…

Which FRITZBOX are you using? Mine is the 6950 Cable

I’m on a different (non-cable) model. Maybe it’s something specific to the model you’re using.

Hello @Martin_Kogel,

Thanks for confirming that information for me. Unfortunately, I do not have any information regarding DNS Rebind Protection settings that I can suggest. We can work with you on this, but we’ve seen issues with these routers before, and many ISPs don’t let you configure settings like you could with a consumer router, which is why we recommend managing your network with one and using the Fritzbox just as a modem. If you make any progress or new findings regarding this issue please let us know.


1 Like

Hi @noris,

thansk for checking that for me. Just one more Question: What exactly happens on a Networking layer while the app says Status yellow initializing. This is where it usually get stuck when connecting to a core.

If I find a solution I will post it here.

Best Martin

@Martin_Kogel - you might have tried this already but since “Mesh” was another new functionality added to the router with OS7 I thought it could be related: if the repeater is off (no mesh) do you have the same problems?

Hello @Martin_Kogel,

The yellow “initialization” happens when the Roon Remote sees the Core on the network and tries to connect to it but is not able to do so, possibly due to network connectivity issues. Have you by any chance rebooted your Core yet? I would try rebooting your Core and Router and test to see if the “Mesh feature” has any impact here as @anon47919701 suggests.


Hi @noris and @anon47919701,

thanks for your hints. I tried to reboot multiple times no change. But I think I’m getting Closer to the issue. On a wired connection of the remote, everything works fine. On a WIFI Connection of the remote it doesn’t. For that test I’m using the same Windows10 PC.

I checked with AVM support. The Setting on WIFI “optimze for live TV” is in technical Terms “enable multicast”. It is turned on, but this is where the issue should be. I’m betting, that the update broke multicast over WIFI.

I’m on with the support of avm and will do some wireshark traces .

I will let you know.

1 Like

Hi @noris,

after some Wireshark traces I got a solution. The software packet acceleration caused the problem. If you have other users with the same problems:

It can be switched off in the support section of the GUI. On the footnote of the menu is a Content link and on the footnote link there is the support link. There you can start package tarces etc. and also switch off packet acceleration.


1 Like

Hello @Martin_Kogel,

Thank you for sharing your results, it will be useful info to have for any other users experiencing the same issue as you. If you have any more issue don’t hesitate to let us know.


Very Useful. Tonight I was caught cold, since my FritzBox 6490 Cable has performed the firmware update to Fritz-OS 7.0. Neither with the iPad Air nor with the Android Tablet I was able to connect to the Roon Core, things behaved exactly as described by Martin Kögel.

My network is not quite trivial, I have 4 Fritz boxes distributed in the house. The 6490 Cabel is the master router, the 7490, 7390 and 7270 boxes are connected via LAN as IP clients. All IP addresses and the WLan are managed by the 6490 (identical WLan, SSID & PW in the house).

The amazing thing was that there was only a connection problem when I got the WLan from the 6490 Cable. If I went with the iPad or the tablet near the 7490/7390, everything worked without problems. This is all the more amazing because in the 7490 this package acceleration is also activated and this does not seem to cause any disturbance. Likewise I do not only have a Windows Roon server but also a Roon Rock. The Roon Rock was not affected by the connection problem.

Actually, I think that I have more than good network knowledge. And unfortunately, tonight, I also did a firmware update of my main POE switch. I spent about 4 hours with troubleshooting. Then I gave up.

But the internet knows everything. And @Martin_Kogel knows even more. Dear Martin, you are my hero of the day. Because without you I would not have found the solution! Therefore, I sincerely award you the “Hero of the Day” certificate.


Just noticed: When restarting the FritzBox, the original setting (packet accelerator enabled) is checked on again.

I think AVM should urgently bring out a firmware update. Maybe it would be helpful if this problem would also be reported by @support to AVM. The Fritz boxes are with us (Germany, Austria, Switzerland) one of the most used routers.

And used here in the Netherlands by at least two ISPs, including the best-rated (XS4ALL).

Thanks Geoff, I also forgot to mention that the FB 6490 Cable is the default router of one of the biggest ISP (Vodafone) in Germany. With this firmware upgrade and the interaction with Roon trouble is inevitable.

A different data point:
My FritzBox (6490) upgraded to FRITZ OS7. Roon and my remotes are running without any problem ever since, without me changing anything. I do keep my fingers crossed, though.

Today I’ve got answer from AVM concerning this connection-problem.

AVM-support wrote:

Thank you for your request to AVM Support.

The firmware update to FRITZ! OS 7 may cause connectivity problems with NAS systems connected to the FRITZ! Box. Occasionally, customers have reported this error.

At the first sighting of the data of other customers, we were unfortunately unable to determine the cause of the error that occurred in you.

It is intended that packet and hardware acceleration remain active and re-enabled upon reboot of the operating system / hardware. We consider that there is a problem here with active packet and hardware acceleration.

The detailed investigation is expected to be completed within the next two to three weeks. If this results in concrete solutions to your problem, we will contact you.

If no direct assistance is possible from our side, we must refer you to an upcoming FRITZ! OS update. With regular updates, we extend the capabilities of our products and enhance interaction with other devices, as well as usability in a variety of environments. If, on the basis of the examination, we receive the corresponding optimization options, these will be included in the upcoming updates.

Since one day an updated firmware FRITZ! OS: 07.01 is available. This solved the connection problem.

1 Like