Android app having trouble finding Linux Core

Good evening @support!

I am currently trialing Roon on QNAP NAS, a TS451+ to be precise. With an iPad Pro, I have no problems connecting to the Roon Core on the QNAP. But I am struggling to make the Roon Remote work on the two Android phones we have in the family, namely two identical Moto G4. Since the iPad connects to the Core, I assume the Core is set up correctly to make connections, and I am not aware of any firewalls used on the Moto Gs – at least I couldn’t find any firewall setting in Settings. Searching for a fix, I also read about re-starting, re-booting and re-installing software – but with no success. The phones keep searching for the Roon Core. It is somewhat puzzling that the phones, as Zones, are recognised in the Roon app on the iPad, but the phones cannot find the Core.

This evening, for a few minutes, my phones connected to the Roon Core, and I thought Hallelujah, finally… I then tried my wife’s phones, with no success. By the time, I returned to my Moto G4, the connection was lost… Back to Square One…

Could you please advise any possible fixes that might make the Android phones work?

Many thanks,

Hey @Timo_Fleckenstein — Thank you for sharing you report with us!

I moved your post to this main thread regarding this topic so that way we can keep similar troubleshooting all in one place to make it easier for others to find later.

To start, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

May I also ask that you confirm the following:

  • You mentioned you tried rebooting above. Did you do this with the Core, remote devices, and networking hardware?
  • Is there any active firewall or antivirus on the Core machine? If so, have you tried disabling?


Dear Dylan @support

Many thanks for your swift reply – much appreciated!!

On the QNAP, I have a "Roon Server for QNAP (x64), and this is,I believe, the most up-to-date version: 1.5 (build 323) stable. My music files are stored on the same QNAP, but on a separate volume.

The firmware of the QNAP, a TS-451+ with 8GB RAM, is also up-to-date: Firmware – the NAS recently updated. I am not aware that any antivirus software is running, or that any firewall is enabled. At least, I couldn’t identifies these in Settings, and I haven’t installed any antivirus software or firewall. I can however see that “Allow all connections” is enabled, and that no “Network Protection Access” is enabled.

Re Re-booting, I have tried all – Core, Remote Devices (the Android phones) and the router – but with no success.

Does this help?

Many thanks,

Still get this issue on my Samsung Tab S2 but only when the apps been in the background and device is awakened from sleeping.

P.S. I forgot to mention that I use an Allo DigiOne as Roon Endpoint — just in case this is relevant as well.

Hi Timo,

What is the brand of router you mentioned, and do you use any other switches or Wifi access points (if so what are those brands). Others have had success by turning off IGMP snooping on their router(s).


1 Like

Hi Daniel and @support

Many thanks for your messages. We use a Bright Box 2 (from EE), and have no other switches or wifi access points. I went into the Settings of the Bright Box, but couldn’t find anything on IGMP – does this go by any other name as well? I googled IGMP but couldn’t find anything that helped me to identify it in my router’s Settings.

Bizarrely, today, my Android phone did find, for a second time, the Roon Core for a short time. When I had a connection, my wife’s identical phone didn’t find the Roon Core as before.

Where does this leave me? I hope I manage to get the phones connected before my test period with Roon ends… We have only one iPad, but I frequently need to take it to work (or need to take it with me when I travel), which leaves wife and child without Roon Remote…

Many thanks,


That router has a built in Firewall and that may be what is causing the issue. As a test you might try turning the firewall off and seeing if the phones can then connect. ( I would reboot the phones as well). If that is the case, then Turn the Firewall back on and then we can figure out how to open up the firewall to let Roon through.

The instructions can be found here:

Thanks Daniel.

I disabled the firewall, and rebooted router and phone – but no success. I still cannot connect. What puzzles me: how is it possible that I could briefly connect with one of our two phones?


Dear @support — any more ideas what I could do to get the Android phones running with Roon before my trial ends?

Many thanks,

Hey @Timo2708!

My sincerest apologies for the delayed response here. For our next step here, I’d like to kindly ask that you please fill out the survey mentioned here. This survey includes some great troubleshooting steps that I think will be great to try here. Once you’ve gone through the steps in the survey please report back and let me know if you’re still having difficulties.


Thanks your for message, @dylan – I went through the survey, and I am still not connecting. Are we running out of possible solutions?


Sorry to hear you’re still having troubles, @Timo2708.

I do have another recommendation that will help us narrow down the root cause of the behavior. Testing with a different Core machine and comparing the experience will be a great data point to know where exactly the problem is occurring.

For next steps, please install Roon on a different machine (Windows or OSX) and try connecting your remote devices to that Core. The result of this test will be a great data point in confirming the root cause of what you’re seeing.

Thank you for your continued patience and assistance as we continue to investigate here.


Thanks for your message @dylan! We are moving forward – at least in terms of identifying the “trouble-maker”. It’s not the Motorala, it seems. I have installed the Roon Core on my PC, and I could establish a connection. The problem appears to be with the QNAP! Any idea what I could do to get the QNAP running with the phones?


The clue is in the topic title :smiley:

If you have a switch or router in your system where you can turn off IGMP snooping, you can try that. Otherwise you’re SoL for now.

I went through the router’s setting (Bright Box 2 from EE), but I couldn’t find anything that looked like an IGMP setting. Do you have a clue where I should find the IGMP setting if my router had one?


The Brightbox won’t give you that sort of option, unfortunately. Like most ISP supplied routers, they are very locked down.

Oh dear – I guess I reached the end of the road… But I am still struggling to understand why I could connect for two brief moments though…

Your situation is not unusual, if you were to read up. It has become a bit of a threadnaught though.

That’s how it plays out. The devices will connect for a short space of time after rebooting the Core, then they nope out.

1 Like

This have been going on for the last six months I waisted days trying to solve this problem … I eventually installed core on pc and now I have no conections problems … and much better Sound quality ass a bonus. …