Android app having trouble finding Linux Core

Modulo the small problem that “similar” != “identical”.

Of course, had they used an existing discovery protocol like Bonjour from the getgo instead of rolling their own, they wouldn’t be in this position since those discovery protocols are all provided by the OSes now (well, except for Windows, but it’s easy to get Bonjour on Windows anyway) and have been well tested and work reliably on all platforms.

1 Like

For me, it’s the opposite. When the Roon Core is restarted, it will be approximately 24 hours before the Android app starts to find it.

From various comments by Danny and Brian in the forum, the remote code is (or was) apparently done by a single guy who isn’t a programmer, but rather a designer. Roon Labs wrote their own design language for this guy to describe his design with, along with a compiler that takes it into what is apparently their .NET/Mono/Xamarin (for Android/iOS) infrastructure. Things may have changed since those comments were made, but fixing network bugs with a stack like that would be difficult, like poking a 1-cm button with a jointed 10 m pole.

I have this problem only when I restart the machine running the core after upgrades (Ubuntu 18.04.1 LTS at the moment). Restarting the roon processes fixes the problem immediately.

My Android Tablet (Samsung Galaxy Note 8.0) can no longer connect to Roon. It was working well yesterday (Roon 1.5 version 233). When I tried starting it today, I got the message “Unfortunately, Roon stopped working”. Noticed on Application Manager that there had been an upgrade to version 254. Could this be the problem?

If it says 254 on your Note 8 it still needs to be updated to 354… Roon 1.5 (Build 354) Is Live!
My note 8 phone is working fine and it is on Roon version 1.5 (build 354).

My mistake. It is actually 354. Version 323 (if I remember correctly) worked okay. The update seems to be giving the tablet trouble. I’ll try to uninstall and reinstall and see if that works.

1 Like

I’m following this topic for half a year now. My son is the only android user in our house and he has had issues connecting to the Roon core on his Moto G6. None of the suggestions made (Android power settings, IGMP-snooping toggle, power cycling, etc) work. The best we ever got was ‘connecting’-‘initialising’ and back to ‘connecting’ and after that the familiar ‘searching for core’.
His old Sony Experia Z with Android 5.1.1. however works about half of the time.

All the other remotes (3 x iPhone, 2 x iPad and a MacBook) all work fine and with very snappy response.

My setup has some familiar ingredients: ASUS router, Ubiquity access points, TP-Link managed switch, QNAP-TVS473 NAS.

I’ll fill in the survey and follow this topic to see if a solution is found.
And I’m happy to volunteer for testing various scenarios. Roon crew is free to contact me for this.

I don’t know what had changed, and my Huawei P20 Pro is able to connect to Roonserver now.

If that is indeed true, then it’s pretty poor from Roonlabs really

Is it asking too much that an android remote app gets coded from scratch, by an expert, properly ??

There must even be someone on the forum who could do this, no?

My own personal experience is that some updates work fine for me, but the latest has broken it all again and I’m back to nicking the missus iPhone


I dunno, I think it’s kind of ingenious. Good coders are hard to get, these days.

And it’s not unusual, either. A majority of programming these days is done by non-programmers. Spreadsheets are the big example. But there are whole categories called “end-user programming” and “domain-specific languages” with lots of activity in them.

Ok fair enough, but that doesn’t alter the fact that this particular approach to development (legit or otherwise) hasn’t delivered a stable product for the paying customers

In the spreadsheet example, it is an acceptable practice because the underlying core functionality of the paid for product is intact (assuming we’re not asking Excel to add up correctly :rofl:)

Again, not sure. Remember that programming is still highly experimental, more or less a cottage industry and craft, rather than an engineering discipline – I always have to chuckle when I see a company advertising for “software engineers”! In California, you have to be board-certified to curl hair, but not to program self-driving cars.

How the app frontend was coded, whether by a designer or by an engineer, is likely irrelevant to the problem being discussed here, which is probably somewhere in the guts of the interactions between the .NET/Mono libraries and Android’s Linux network stack. In addition, the problem only happens for some Roon Server setups (mainly Linux ones) and some networking configurations (managed switches seem a common culprit). The problem has gone away for many of us, especially after we got rid of IGMP snooping on the relevant switches. And Roon has been unable to reproduce the problem, even though they use Android endpoints.


A brief update from my end:
The app is now working on the Moto G6!

One change in my network seemed crucial to achieve this: I still had a TP-Link managed switch (TL-SG108E) somewhere in the backwaters of my network that had no specific coding anymore (just used as a ‘dumb’ switch). But it did have the IGMP snooping box ticked. When I un-ticked this everything all of a sudden worked. And just for testing this: when ticking again the app refused to connect…

So, there is definitely proves that in my network the IGMP-snooping functionality blocks the Android app on some phones from connecting to my Roon Core. Still a lot of variables at play here.

Considering the consistent way I can reproduce the problem I can offer to run a couple more tests for the Roon team if you want to?

1 Like

I had this problem until the latest Core update two weeks ago. I didn’t change anything except letting the update run. It has been running flawlessly since.

  • Thomas Nielsen

On my home network, turning off IGMP snooping on a Netgear managed switch was the cure for this problem with various Android devices back last year. I’ve left it that way ever since, all good.

Have the same issue, no managed switch in the equation. In my case the problem appears to be Roon struggling with switching WAP’s that carry the same SSID.

I gave up in the end and now use @Mike_Plugge web controller extension on my phone

No queue management facilities (an API limitation I believe) but at least I can pause/play from my phone now

Reliably :wink: